6 Replies Latest reply on Dec 22, 2005 5:39 AM by (KevinJWalke)

    Registering PSA SE 3.0 (Upgrade from 2.0)

      I downloaded v3.0 as an update package through Reader. There's been a few messages on failure at Registration in this forum. When I complete all information on the registration form and hit 'Register', it says 'unable to connect to web site'.

      I tried disabling my firewall, and that makes no difference.

      Any ideas?

      SK