0 Replies Latest reply on Nov 13, 2008 1:32 PM by Joel_Spriggs

    Problem connecting flex and cfc

    Joel_Spriggs
      Hi All,

      I'm having an issue with using cfcs from flex. Everything seems correct in my flex code to use RemoteObject, with destination of ColdFusion and source is my cfc, referenced exactly as done in tutorial. I know my cfc works fine, but I got the error "faultCode:InvokeFailed faultString:'[MessagingError message='Destination 'ColdFusion' has no channels defined and the application does not define any default channels.']' faultDetail:'Couldn't establish a connection to 'ColdFusion'' when I tried to run the code on my server.

      According to most stuff I read on that error, I would need to define my services-config.xml and go to my CFIDE to make sure the Flex Integration pane shows that the flash remoting and flex data services are enabled. There's where I hit the problem, when I go to flex integration, my admin console throws an error: unexpected constant #2 88.

      I've got no idea why it throws that error, but the rest of the CFIDE admin console is working fine. We are a shop that builds our coldfusion servers as war files through ant scripts, so doing a reinstall isn't very practical for us. I've tried comparing some of the neo-XXXX.xml files to ones on a working server and haven't found anything immediately that jumps at me.

      Has anyone hit this issue before or anything like it? We are running CF 7.0.2.142559

      Any help anyone can give would be greatly appreciated

      Thanks,
      Joel