1 Reply Latest reply on Nov 25, 2008 5:55 AM by Ned Murphy

    Flash 8 application tests fine, no images when live

    Sky1947
      My Flash 8 application works great when I test within Flash 8 and even when I test on the local browser. However, when I use it on the server it does not show the images. Could this be caused by my not referencing my image files correctly so the application knows where to retrieve them . . . . how can I do this properly.

      I have attached some code that defines the image location.

      Attach Code

      var image0title:String = "Sharon Winchester";
      var image0desc:String = "Sharon Winchester is our Commercial Relations Director. Need a sounding board or a creative solution for your transaction? Feel free to contact Sharon-with over 10 years of experience in the industry, Sharon is able to assist you with finding the solutions that you need.";
      var image0uri:String = "images/image0.jpg";

      next_btn.onRollOver = function() {
      slideShow_mc.gotoAndPlay("slide1");
      menu_mc.title_txt.text = this._parent["image1title"];
      menu_mc.description_txt.text = this._parent["image1desc"];
      }

      next_btn2.onRollOver = function() {
      slideShow_mc.gotoAndPlay("slide2");
      menu_mc.title_txt.text = this._parent["image2title"];
      menu_mc.description_txt.text = this._parent["image2desc"];
      }

      next_btn3.onRollOver = function() {
      slideShow_mc.gotoAndPlay("slide2");
      menu_mc.title_txt.text = this._parent["image2title"];
      menu_mc.description_txt.text = this._parent["image2desc"];
      }
        • 1. Flash 8 application tests fine, no images when live
          Ned Murphy Adobe Community Professional & MVP
          You're getting closer to revealing what's doing the work of presenting the images. What happens in slideShow when you call on it...

          slideShow_mc.gotoAndPlay("slide1");

          slideShow_mc.gotoAndPlay("slide2");
          ...
          ?

          You need to show the code you are using to bring the image files into the slideShow from the server. And the problem may only be the path, as you say, so check to be sure there's an images folder in the same place as the Flash file and that it has the images in question within it.