6 Replies Latest reply on Nov 14, 2008 12:23 PM by Captiv8r

    TOC problem; lost Search and Keyword boxes

    katgentry
      I inherited a Robohelp X5 project that was originally started by a person very familiar with these types of programs, then ultimately messed up by someone who knew nothing about them or the content. I spent most of my time re-writing and updating the content using X5, then upgraded to 7 this morning. I have learned quite a bit about the program, not obviously not enough. I'm sure these are things I've messed up, because they worked before; but I don't know what I did or how to fix it...
      First, the TOC is built, with books and pages are in the order I want. The books are linked to a page - presumably, so that when a user clicks on the book, it defaults a particular page, and from there they can move to other pages in the section. However, when I view the results, you have to click on the book, then click on the individual page to get the page to open.
      Next, I have 'lost' the Search boxes for the Index and Keyword searches. When I look at the skin, they appear there, but when I view the project, they aren't - the index and keyword lists appear instead of the boxes.
      If anyone can give me some direction on what I need to do, I'd really appreciate it.
        • 1. Re: TOC problem; lost Search and Keyword boxes
          RoboColum(n) Level 5
          Hi katgentry and welcome to the RH community.

          If you right click on a book and select the Properties menu item you can see what a book is linked to. There is a "Book with Link" option that if selected allows you to specify a topic in the "Link To" field. What this does is open the specified topic when the user opens the book.

          As far as the skin is concerned, do you have any index keywords in the project? If you haven'e it doesn't matter what you have in your skin and the tab won't be displayed.
          • 2. Re: TOC problem; lost Search and Keyword boxes
            Peter Grainge Adobe Community Professional (Moderator)
            Sounds like you have changed the settings in the penultimate page of the wizard. Try DHTML.

            • 3. Re: TOC problem; lost Search and Keyword boxes
              katgentry Level 1
              Thanks so much for trying to help me - I apologize in advance for being suce a novice, and I promise I'll try to learn more about this program and not bother you guys so much in the future. Right now I'm just in a bind with needing to get the file posted.
              I right-clicked on each of the books, went to Properties, and confirmed that the Book with Link box is checked, near the bottom of the window, in the Link to: box is the page that I want the book to open with. However, when I view the project, that isn't what happens. For example: I have a Book named Getting Started, under it are several pages related to initial set up of the software, one of which is named Getting Started. The Book is linked to the page; but when I open the project in View, I click on Getting Started and it expands to show the pages; I have to actually click on the Getting Started page to open it. Before, whenever I clicked on the Getting Started Book, the Getting Started Page opened to reveal the contents of the Book. On the Book Properties window, there isn't anything in the Available Variables box, and if I go to the Advanced tab, the Frame reads Default (none) - should the Book or the Page be designated as a Parent Frame?
              With regard to losing the Search and Keywords boxes - I have an Index full of words; went through yesterday and cleaned it all up, then generated Webhelp. When I open it to View, the project opens to the TOC, which is good, but the Search button that usually appears at the top of the Help screen is not there. Then, when I click on either the Index or Search tabs, what I see is the alphabet where the Search box should be, with a list of all of the index words below. If I open the Skin that was used on the project and View it, the Search boxes appear there.
              I looked at the website that Peter directed me to, but I don't really see anything there that addresses either of these issues. Under the Tools menu I did locate an Update DHTML Effects in Topic; but when I click on it, it returns a message that tells me that after the conversion the topics cannot be opened by previous versions of RoboHelp HTML. I've answered No to convert all of the topics, because I'm not sure that's what I should do.
              • 4. Re: TOC problem; lost Search and Keyword boxes
                Captiv8r Adobe Community Professional & MVP
                Hi there

                If you click File > Generate Primary Layout you should see the first of a few different dialogs you may interact with. The dialogs all control different settings for how the WebHelp is created. This is what Peter was alluding to in his post. One of the options governs how the WebHelp Navigation works. Your choice is between Java Applet and DHTML. It sounds as if your setup is either using the "Pure HTML" option or you have enabled the "Section 508" option.

                Does that make more sense?

                Cheers... Rick
                • 5. Re: TOC problem; lost Search and Keyword boxes
                  katgentry Level 1
                  Oh, thank you so much - that made perfect sense, and it worked. Everything seems to be good - except I still don't have the Search box at the top of the window, but I can live with that until I figure out how to fix that. The search boxes are there for Index and Search, and the problem with the TOC cleared up with it!

                  Do you have any suggestions about a book or a course I could take to learn more about the technical aspects of the program?
                  • 6. Re: TOC problem; lost Search and Keyword boxes
                    Captiv8r Adobe Community Professional & MVP
                    Hi again

                    Funny you should ask. If you look at my signature line in the forums...

                    Take a look at this link: ShowMe Solutions

                    As for the missing field, it's in the same dialogs. On the second screen, it is labeled "Search Input Field in Toolbar".

                    Cheers... Rick