5 Replies Latest reply on Nov 26, 2008 1:57 PM by Newsgroup_User

    Need help with RichTextEditor

    Daniil_T.
      Hello, i`am Daniil from Lithuania.I have this problem and i don`t know how to solve it.
      When i send text message thro RichTextEditor to my Database it stores there normaly with all HTML tags.But when i want to display it in textarea or somewhere else, the text displays without any thml tags.. displays like normal text.
      I tried to display text firstly in textarea with all htm tags and then send it to DB, but it wont work.After some tryes, i look up in to my DB and saw that text are store in it with all HTML tags, but still i couldn`t display text ir proparly.
      Can somebody help me to solve this problem ?
        • 1. Re: Need help woth RichTextEditor
          Level 7

          "Daniil T." <webforumsuser@macromedia.com> wrote in message
          news:ggjuvd$4fi$1@forums.macromedia.com...
          > Hello, i`am Daniil from Lithuania.I have this problem and i don`t know how
          > to
          > solve it.
          > When i send text message thro RichTextEditor to my Database it stores
          > there
          > normaly with all HTML tags.But when i want to display it in textarea or
          > somewhere else, the text displays without any thml tags.. displays like
          > normal
          > text.
          > I tried to display text firstly in textarea with all htm tags and then
          > send it
          > to DB, but it wont work.After some tryes, i look up in to my DB and saw
          > that
          > text are store in it with all HTML tags, but still i couldn`t display text
          > ir
          > proparly.
          > Can somebody help me to solve this problem ?

          Are you setting the htmlText property on the TextArea or somewhere else?


          • 2. Re: Need help with RichTextEditor
            rtalton Level 4
            Have you tried seeing if the html tags are being removed by your call to the database?
            Are you using HTTPService, RemoteObject or WebService in Flex?
            • 3. Re: Need help with RichTextEditor
              Daniil_T. Level 1
              I`am using HTTPService, when i send text from richtexteditor i send it as .htmltext
              • 4. Re: Need help woth RichTextEditor
                Daniil_T. Level 1
                I`am setting it in HTTPService request list exp:
                <test>{test.htmlText}</test>
                When i setting it in textArea, the result that i see is: [Object]
                • 5. Re: Need help woth RichTextEditor
                  Level 7

                  "Daniil T." <webforumsuser@macromedia.com> wrote in message
                  news:ggk329$9di$1@forums.macromedia.com...
                  > I`am setting it in HTTPService request list exp:
                  > <test>{test.htmlText}</test>
                  > When i setting it in textArea, the result that i see is: [Object]

                  Could you show more complete code? That doesn't make any sense.