1 Reply Latest reply on Aug 17, 2008 2:47 AM by vogelscheuche

    Flex on Linux: Problems with importing fl.*/mx.* packages

    vogelscheuche
      Hello,
      I'm trying to get an official Adobe example about the DataGrid to work, so there should be no problems with the source code.
      As well I'm a little bit confused about the package names, because they are mentioned as fl.* ( in the Flash9 Language Reference) and as mx.* ( in the Flex3 Language Reference). Whichever I am trying to import, Eclipse gives me a #1172-Error (could not be found).
      This thread couldn't help me though, because everytime I am trying to create/open up a Flex-Project I get the following error:
      "Could not open the editor: Assertion failed: " (detailed error attached)
      So I am bound to use only ActionScript. Please note, that I am on a Linux machine and run Flex alpha 4 on Eclipse.
      What can I do to get the components or the mxml files to work?
      Thanks for you help in advance

      EDIT:
      I found out that I can access the following mx packages: core, events, managers, modules resources, utils. But unfortunately those don't contain the code I need.
      I played around with the ".actionscriptproperties" file in the project's root folder, but removing the "excludedEntries" nodes had no effect.
      Please help cause I really don't know what else I could do to get the components to work.
        • 1. Flex on Linux: Problems with importing fl.*/mx.* packages
          vogelscheuche Level 1
          I just found out that Flex Projects/mxml is not yet supported, because of a bug.

          But I just wanted to use mxml as a substitute to be able to use the components.
          Still if I want to use the components within an ActionScript project, like here, I get again an error that the needed file could not be found (#1172).
          When I tried to compiled the linked script I get this error for everything but flash.display.Bitmap and mx.events.FlexEvent.

          I just had a chat with someone who is workin on a Linux machine too and he was able to compile it. We weren't able to get this solved tho.

          Thanks for any help