8 Replies Latest reply on Nov 24, 2008 7:06 AM by Peter Grainge

    RoboHelp hanging

    shawntrident
      I use Tortoise SVN as a repository for my changes in RoboHelp. I recently had some problems with RH files being in conflict or out of date in SVN. We fixed those problems by updating the SVN folders, and now my file in RoboHelp just hangs. It opens but I never get an active arrow to click with; it stays on hourglass and I can't do anything. There are moments when it flashes between the arrow and the hourglass and I can click, but even then everything is very slow. Also, all of the topics suddenly have red graphic boxes at the top and bottom of each page. I have no idea what those are.
        • 1. Re: RoboHelp hanging
          shawntrident Level 1
          I should add that I have other RoboHelp projects that I do not put into SVN; these are functioning normally.
          • 2. Re: RoboHelp hanging
            Ben Minson Level 2
            Red boxes in your WYSIWYG editor represent JavaScript. Topics may look that way if you open output files in RH instead of source files. Are you possibly opening the output files in RH instead of the source files?

            Or, in updating your source folder from SVN, could you have maybe updated from the output folder instead?

            --Ben
            • 3. Re: RoboHelp hanging
              shawntrident Level 1
              I checked the file path and the .xpj I open is located in my source folder. I don't think I updated the output files, but just in case that was as issue, how would I fix that.

              I did according to Captiv8r's advice in the "I think I've killed my project" topic and deleted the .cpd file. The project no longer hangs but I find that all the tables are screwed up. Columns are missing.
              • 4. Re: RoboHelp hanging
                shawntrident Level 1
                I checked the file path and the .xpj I open is located in my source folder. I don't think I updated the output files, but just in case that was as issue, how would I fix that.

                I did according to Captiv8r's advice in the "I think I've killed my project" topic and deleted the .cpd file. The project no longer hangs but I find that all the tables are screwed up. Columns are missing.
                • 5. Re: RoboHelp hanging
                  Ben Minson Level 2
                  Create a new folder on your hard drive, and then do an update from your project source folder in SVN to that new folder. Open that copy of the project in RH and see what you get.

                  I'm assuming with all of this that you commit both your source files and your output files into SVN. If that is the case, verify before updating that you're pointing at the source files in SVN and not the output files.

                  I would ask if you made a backup of your project before you deleted the .cpd, but the source files in SVN should work as a backup.
                  • 6. Re: RoboHelp hanging
                    shawntrident Level 1
                    I tried it and the version of RH that I opened from the new folder hangs like before.
                    • 7. Re: RoboHelp hanging
                      Ben Minson Level 2
                      I haven't had to fix a project by deleting the .cpd, so I don't know what to recommend for that. Have you done a text search of the forums for other threads having to do with hanging projects?
                      • 8. Re: RoboHelp hanging
                        Peter Grainge Adobe Community Professional (Moderator)
                        For projects outside source control and using RH7 it is as simple as creating a backup and then deleting / renaming the CPD file. After that open the project with the XPJ as usual and a new CPD is created. If it has solved the problem, you then check the new project into source control.