2 Replies Latest reply on Oct 28, 2008 8:38 PM by Jim_Simon

    Backward compatibility.

    Level 1
      I own Aspect 3.4 and Premiere 1.5. I already have CS3 and will be upgrading to Prospect HD next.

      However, I am editing a show for a client with Aspect 3.4.

      I want to finish the show before I upgrade to Prospect HD because I don't want to upgrade now and risk a backward compatibility problems.

      I could upgrade to Aspect 5.0 but that would be wasted money since I will upgrade to prospect HD anyways.

      So I have 2 questions:

      _Can I upgrade Aspect 3.4 to 4.0 for free?

      _If I upgrade to Prospect HD and CS3 now, can I open the show in CS3 and Prospect HD and pick it up where I left off?

      Thank you.