25 Replies Latest reply on Mar 6, 2009 5:27 AM by (jaxim)

    Speeding up Video makes it look interlaced

    Level 1
      I altered the speed of one of my clips within Premiere and now I see jagged lines where there is movement.

      I don't think I should see these jagged lines since I took the footage at a progress mode and not an interlaced mode. Actually, when the clip is not sped up and displayed at regular speed, there are no such jaggies when I view the footage frame by frame.

      How can I both be able to speed up the timing of my clip but still not see there jagged lines?

      My footage was taken by a Canon HF100 Camcorder @ 1080p30. The premiere sequence is set to 1080p30.
        • 1. Re: Speeding up Video makes it look interlaced
          Orytek Level 1
          It is my understanding that the 30FP and 24F modes on the HF100 are basically fake 30p and 24p. The footage it records is still interlaced, but once you de-interlace it looks pretty close to 30p and 24p footage. Try putting it on the 60i avchd timeline and deinterlacing.
          • 2. Re: Speeding up Video makes it look interlaced
            Level 1
            1) If that is true, would you happen to know why Canon advertises a "30p" mode if it doesn't actually shoot in 30p? what is the advantage to their 30p mode?

            2) Plus, what are the steps in de-interlacing "30p" Canon footage?

            thanks for your help!
            • 3. Re: Speeding up Video makes it look interlaced
              Dan Isaacs Level 2
              Can you go to Interpret Footage and choose "Progressive"? Also try turning off frame blending on the clip.
              • 4. Re: Speeding up Video makes it look interlaced
                fuaho Level 1
                I've noticed the same thing happen with individual *.tif files imported from an animation. Obviously those frames have no interlacing at all.

                I always thought that it had to do with Premiere interpolating frames to make the speed adjustment.

                In my case, I had slowed the footage down, but it would probably work the same with a speed up.

                HTH,
                • 5. Re: Speeding up Video makes it look interlaced
                  Level 1
                  I re-encoded the video and NO jagged lines. I didn't do much differently. I'm going to test out the things that I did do differently. I suspect that it may have something to do with the clips in question having rendered preview files in premiere the 1st time. The 2nd time, I had made some slight color correcting adjustments to the clip and thus lost the rendered preview files and I did not re-render previews for the clips in question. I'll be testing this out 1st.

                  p.s. I did more research on my Canon HF100 camcorder and it would seem that the camera DOES record in true 24p or 30p. When you upload your footage to a computer, however, the camera's software converts it to 60i.
                  • 6. Re: Speeding up Video makes it look interlaced
                    Jim_Simon Level 8
                    >When you upload your footage to a computer, however, the camera's software converts it to 60i.

                    I can't say with certainty, but that does seem unlikely. Pulldown is normally added during the recording phase. This would be the first instance I've seen of adding it later, if indeed it does.
                    • 7. Re: Speeding up Video makes it look interlaced
                      Level 1
                      >I can't say with certainty, but that does seem unlikely. Pulldown is normally added during the recording phase. This would be the first instance I've seen of adding it later, if indeed it does.

                      Hey Jim. Below is an excerpt of an email I received from Canon. It states that the camcorder "uses true 24 Frame progressive shooting" and that "these frames of video are recorded by the camcorder and then output via the HDMI, USB 2.0 or composite terminals by adding a '2:3 pull-down' to convert the 24 Frames in 30 Frames to be compatible with Televisions and monitors"

                      I'm still learning the video editing/encoding process so I appreciate everyone's help thus far. Again, I'll report back with what happens with the jagged lines if I encode w/o a preview version of a clip.

                      ===============================================
                      Canon's email on the HF100 camcorder...

                      "In the USA as well as many other countries the Canon VIXIA HF100
                      camcorder offers a selectable shooting mode which uses true 24 Frame
                      progressive shooting to give your video a more cinematic look. These
                      frames of video are recorded by the camcorder and then output via the
                      HDMI, USB 2.0 or composite terminals by adding a "2:3 pull-down" to
                      convert the 24 Frames in 30 Frames to be compatible with Televisions and monitors. This is the same industry standard system used to show
                      "Hollywood" movies on Television.

                      Most consumer software packages that support editing AVCHD video are
                      capable of editing this video in the same way as any other high
                      definition video. However, some high end customers have requested the
                      ability to import the video into professional video editing suites and
                      applying a 2:3 pulldown to the footage which allows the individual 24
                      Frames to be extracted.

                      Since the VIXIA HF100 is a consumer class camcorder it does not include a feature to record 24 Frame video directly. By not including this feature, frame extraction is somewhat more difficult, requiring that the editor manually identify the 2:3 pulldown, then the editing program can extract the 24 Frame video. This process varies from one editing program to the other and may not be available on all programs. Please check with your editing software provider to see if this capability is supported."
                      • 8. Re: Speeding up Video makes it look interlaced
                        Level 1
                        p.s. there are a few people's comments on this thread that I no longer see. What happened to them?
                        • 9. Re: Speeding up Video makes it look interlaced
                          Level 1
                          duh! I see everyone's comments now. The comments are on the 1st page of the thread and i am looking at the 2nd page.
                          • 10. Re: Speeding up Video makes it look interlaced
                            Jim_Simon Level 8
                            >Since the VIXIA HF100 is a consumer class camcorder it does not include a feature to record 24 Frame video directly.

                            That is as I suspected. The imaging devices are "shooting" 24 fps, but the pulldown is added for both the "recording" (to cards) and "output" (HDMI) stages of the process. This means that you would edit in a normal 30i preset (also called 60i).
                            • 11. Re: Speeding up Video makes it look interlaced
                              Level 1
                              >This means that you would edit in a normal 30i preset (also called 60i).

                              When I first started my project, I was not aware that my camera did this so I used a 30p sequence. Obviously this is incorrect and I should be editing my video within a 60i sequence; however, when I encode the current 30p sequence, it looks okay. What is the point of setting the settings of a Premiere sequence if the video footage looks ok? I'm a real newbie so I appreciate the info!
                              • 12. Re: Speeding up Video makes it look interlaced
                                Jim_Simon Level 8
                                For 30p, you may be OK. My comment was in regards to shooting 24p.
                                • 13. Re: Speeding up Video makes it look interlaced
                                  Level 1
                                  So I'm not sure how I got the jagged lines to disappear before. My theory of cached preview files causing the problem (that I mentioned previously) was not the issue. When I was able to encode the footage withOUT the jagged lines, I used Adobe Media Encoder directly w/o 1st going thru Adobe Premiere. When I went thru Media Encoder directly, I must have selected a different setting, since the outputted video was smaller. Perhaps by selecting a smaller resolution output caused the jagged lines not to show up. Who knows?!

                                  HOWEVER, I took the advice of everyone here and created a 60i sequence and imported the same footage that was giving me problems, and guess what! NO JAGGED LINES! So setting the sequence to the correct setting did the trick. It's funny it only affected a few clips in my video.

                                  Okay, now that I have that issue resolved, I have another on-topic question. How do I do a reverse pulldown so my 30p footage is no longer 60i footage. In some Canon forums, people said that this would be possible and that it would probably be a (somewhat) lossless process. However, the people in the Canon forums did not know how to do this within Premiere (or another Adobe product). Can anyone tell me how I would go about reversing the pulldown on my "30p" footage? Thanks!!!!
                                  • 14. Re: Speeding up Video makes it look interlaced
                                    Jim_Simon Level 8
                                    >How do I do a reverse pulldown so my 30p footage is no longer 60i footage.

                                    You don't. Pulldown get's added to 24p footage to make the off number of frames fit into a 30i cadence. 30p doesn't have any pulldown because it's already at 30 fps.
                                    • 15. Re: Speeding up Video makes it look interlaced
                                      Level 1
                                      But since the 30p footage is wrapped in a 60i footage, shouldn't I do something to get it out of the 60i wrapper if my goal is to display it on TV/monitor that can handle progressive footage?
                                      • 16. Re: Speeding up Video makes it look interlaced
                                        Jim_Simon Level 8
                                        No. Shooting 30p just means that both fields are from the same moment in time, whereas normally each field is 1/60th of a second apart.
                                        • 17. Re: Speeding up Video makes it look interlaced
                                          Level 1
                                          I understand that Canon placed the 30p footage into a 60i wrapper to allow the footage to be viewed on older TV sets.

                                          But, if a 60i-wrapped 30p footage has no loss in quality on a modern progressive capable monitor and has the added bonus of being backwards compliant with older sets, then why would you ever "NOT" place your 30p footage within a 60i wrapper? Is there ever a time you'd want to display your 30p footage in a 30p sequence and not first wrap it into a 60i wrapper and placed the footage in a 60i sequence?

                                          Is it just a factor of time? For example, if your camera does NOT place your 30p footage in a 60i wrapper like the Canon does, then you'd have to manually wrap the footage which may be time consuming. And if your audience is going to watch your footage on modern day TV sets or monitors, then it doesn't make sense to wrap the footage and waste your time. Is that the only reason or is it something else?

                                          Again thanks for your time explaining this to me.
                                          • 18. Re: Speeding up Video makes it look interlaced
                                            Jim_Simon Level 8
                                            > then why would you ever "NOT" place your 30p footage within a 60i wrapper?

                                            I think most cameras do. Maybe some higher end solid-state cameras (Panasonic, Sony) offer 30pN (Native), but most that shoot 30p actually record 30i. There's just no temporal difference between fields is all.
                                            • 19. Re: Speeding up Video makes it look interlaced
                                              Dan Isaacs Level 2
                                              The difference between real 30p and so-called "30p over 60i" is how the chroma is sampled. Since HDV (and AVCHD) uses 4:2:0 chroma subsampling, each chroma sample contains information shared by two lines.

                                              In the case of progressive YV12, chroma is shared by lines 0+1, 2+3, 3+4, etc.

                                              In interlaced YV12, chroma is shared by lines 0+2, 1+3, 2+4, etc.

                                              In Premiere CS4, when dealing with "30p over 60i" on a 30p timeline, be sure to force "progressive" in the Interpret Footage options.
                                              • 20. Re: Speeding up Video makes it look interlaced
                                                Level 1
                                                >In Premiere CS4, when dealing with "30p over 60i" on a 30p timeline, be sure to force "progressive" in the Interpret Footage options.

                                                What's the advantages of doing this versus placing the "30p over 60i" footage on a 60i timeline? I'm trying to understand when it's worth it (if at all) to have it play 30p instead of 60i.
                                                • 21. Re: Speeding up Video makes it look interlaced
                                                  Dan Isaacs Level 2
                                                  I guess it all depends on your intended output format. However, if all your sources are "30p" (over 60i or not) it seems to make more sense to use a 30p timeline, at least to me.
                                                  • 22. Re: Speeding up Video makes it look interlaced
                                                    Level 1
                                                    I placed my footage into a sequence with the wrong settings. The sequence should have been set at 60i, but it is set at 30p.

                                                    Is there an easy way to change a sequence's settings so it's no longer 30p, but 60i? Or do I need to create a new sequence, choose the correct 60i setting this time and place all my footage into the new sequence.
                                                    • 23. Re: Speeding up Video makes it look interlaced
                                                      Level 1
                                                      ok. I encoded my 30p video that is wrapped in 60i as a 60i sequence and now things are worse.

                                                      Yes, the 3 second clip that I had sped up which I mentioned at the start of this thread looked choppy now looks better. However, it is at the sacrifice of the rest of the 20 minutes of video. Now every clip now has small refined interlaced lines.

                                                      So NOW, my questions is how do make my video look as good as it did when I placed it in a 30p sequence but STILL make the sped up clips look good?

                                                      Is there a way that I can remove the 60i wrapper and output at 30p?
                                                      • 24. Re: Speeding up Video makes it look interlaced
                                                        Level 1
                                                        I found the following thread that seemed to relate to my original problem. According to this thread Adobe has a problem with some footage with speed changes. Probably because my 30p footage is wrapped in a 60i wrapper. I'll try to place filters on the footage to see if it self-corrects itself, but if anyone else any ideas on how to correct my problem, I'm all ears.

                                                        http://forums.creativecow.net/thread/3/886215
                                                        EXCERPT FROM THE THREAD...
                                                        The problem is that Premiere assumes any clip with DV compression to be interlaced -- and (as it lacks an override via Interpret Footage, etc.) cannot be told that the clip is, in fact, progressive.

                                                        Most of the time this does not make a difference. Speed changes, however, is an instance where it will affect the quality.

                                                        Like the original poster discovered, there are certain filters that also cause this "auto-deinterlacing" of progressive footage. These are filters built off of the AE model -- where fields must be separated in order to achieve interlaced rendering. Premiere assumes your clip is interlaced and separates the fields. Then, since the project is progressive, it applies the effect to and returns only the first field.

                                                        I compiled a list of filters that are problematic in this regard:
                                                        http://invertedhorn.axspace.com/premiere_cs3_filter_problems.html

                                                        Placing a non-problematic filter above one of the problem filters seems to remedy this issue in most cases (but not all). In particular, time-based effects (like Time Warp. Posterize Time, etc.) are apparently always applied first and as such are beyond redemption.

                                                        Curiously, one cannot use the 3rd party FieldsKit deinterlacer in progressive projects within Premiere for this reason. It would be nice to import a 60i clip into a 30p timeline -- and use FieldsKit to make it progressive. But this cannot be done: by the time FieldsKit processes the frame it has already been destroyed by Premiere's internal deinterlacing.

                                                        Apparently Adobe's apps append a RIFF header marking whether a clip is interlaced or progressive. Premiere supposedly honors this flag when processing footage. So, a possible workaround would be:

                                                        1.) import your 30p DV clips into After Effects
                                                        2.) make sure you turned off separate fields on "Interpret Footage" options for all clips
                                                        3.) re-output your clips from AE (no field rendering) as DV

                                                        Premiere should now see these correctly as progressive. It's a nightmare, I know. The absence of a field order/progressive frame option in Premiere's Interpret Footage dialog is a major oversight on Adobe's part.
                                                        • 25. Re: Speeding up Video makes it look interlaced
                                                          Level 1
                                                          I am happy to report that my problem is solved!

                                                          1) I did NOT have to put the 60i wrapped-30p footage into a 60i timeline/sequence. Nor did I have to interpret or de-interlace the footage.

                                                          2) I placed my footage into a 30p timeline/sequence

                                                          3) For the problem footage that looked interlaced when sped up, I placed the "4-color gradient" effect on that footage. I changed the opacity to 0 so the effect did nothing except that it CORRECTED the interlaced problem!

                                                          4) problem solved!

                                                          All I needed to do was place a filter on the problem footage.

                                                          thanks all for your help and educating me on this matter.