7 Replies Latest reply on May 17, 2009 11:48 AM by Harm Millaard

    Trial install fails on Vista 64

      I wonder if anyone can help me? I was going to buy Premiere Pro as it is highly recommended by our media folk, but now am not sure. I can't get the trial version to install on Vista 64; the only message is "Setup has encountered an error. Contact product support". As if there were such a thing anymore.
      I have disabled UAC, Defender, firewall, antivirus, spybot, and am running on an admin account with full privvies anyway... am I missing something obvious? Any suggestions welcome.
      Thanks,
      DD
        • 1. Re: Trial install fails on Vista 64
          Harm Millaard Level 7
          Contact product support.
          • 2. Re: Trial install fails on Vista 64
            Level 1
            Thanks for the suggestion, Harm. I have spent considerable time on the website trying to do that, but even logged in, without a serial number there seems to be no way to either post a question or to access phone support. Either I am totally missing something or I'm caught in a catch-22.
            • 3. Re: Trial install fails on Vista 64
              I'm in the same boat. I tried support, but they just sent me to the Installation troubleshooting guide I had already been using.

              Adobe Anchor Service CS4
              Error:
              Error 1603. Fatal error during installation.

              I've been through every step of the Installation troubleshooting guide (all 12 of them). Phone support was no help. I'm stuck.
              • 4. Re: Trial install fails on Vista 64
                Level 1
                Hi Adam. I have finally been successful- sort of. After a couple of days fiddling around, I gave up and created a new user with admin privileges, and it installed first go with no problems. I can't remember whether UAC was on or off at that point.
                The first error message in my install log was that it couldn't invoke MS installer. So I checked the MS knowledge base and found a memo on re-registering msiexec.exe. Not sure if I had it right, since there are 32-bit and 64-bit versions, and I don't know which one Premiere Pro uses. And anyway, I've not had install problems with other applications. Maybe someone more knowledgeable than I can answer that one.
                I think I tried everything else- my user account, "true" administrator account, all security systems turned off, safe mode, etc.. Still can't figure it out!
                Please let me know if you find anything out, its a bit of a pain having to switch users to run an application.
                Daniel
                • 5. Re: Trial install fails on Vista 64
                  I just got the same error message while trying to install the Dreamweaver trial on Vista:
                  Adobe Anchor Service CS4
                  Error:
                  Error 1603. Fatal error during installation.
                  Installing with admin rights didn't help at all.
                  • 6. Re: Trial install fails on Vista 64
                    Studio-EF Level 1

                    Seems to be a x64 problem, because I'm trying to install on the Windows 7 Ultimate x64 (RC1) and got a fairly same error message:

                     

                     

                     

                     

                    Adobe Anchor Service CS4
                    Error:
                    Error 1603.
                    Error 1402.
                    Could not open key: UNKNOWN\Components\C2A2A973-71FD-33D4-BB5A-610DE8420B9A\A4378161-7593-DDA4-1899-9F3767139 08A
                    Verify that you have sufficient access to that key, or contact your support personnel.

                     

                    I did some digging and actually got pointed in the right direction through Adobe Support where I found a technote on this subject.

                    http://kb2.adobe.com/cps/404/kb404622.html

                     

                    By just following the instructions I found out that the regkey:C2A2A973-71FD-33D4-BB5A-610DE8420B9A is accessible but the value A4378161-7593-DDA4-1899-9F376713908A is protected by means of restricted permissions.

                     

                    At step 8 or 9 of the Technote you do also have to set the Administrators permission in the tabs: Auditing and Effective Permissions.

                    You will also have to make Administrators the owner. Do not forget to check EVERY checkbox and after that press APPLY. Just pressing OK will not do the job.

                     

                    And just to be sure, I also did a search in the registry on A4378161-7593-DDA4-1899-9F376713908A and found another hit. So I changed that one also with the account-permissions-method.

                     

                    After making these thrilling changes in the registry (you DID take the advice in the technote to fost make a backup of the registry, didn't you?) I was able to delete the whole register-key.

                    After all this, I was able to install CS4 on my Windows 7 system with no problems of what so ever!!!

                     

                    All in a nutshell: CS4 tried to make a change withing the registry of Windows but failed due to a write-protection on the users-account level.


                    I hope you all will have as much luck with this as I did.

                     

                    If it works on Windows 7 x64 then it will also work on Windows Vista x64, because actually Win7 is a much better version of Vista.

                    • 7. Re: Trial install fails on Vista 64
                      Harm Millaard Level 7

                      Good that you found a solution and good to post it. That may help others in the future. I do not agree with your last statement, because there may be differences in the registry between Vista and 7. It may or it may not. Somebody has to try it out before you can claim this for Vista as well and I have not heard of these problems with Vista, so it seems there are differences.