13 Replies Latest reply on Sep 3, 2009 6:38 PM by kmcgraphics.com

    Media Encoder does NOT deinterlace properly

    mpiper_valero
      If you export a DV-based sequence (29.97 LFF) with graphics and text in it, the video does not deinterlace properly.

      This applies to AT LEAST WMV v9 and FLV VP6.

      With WMV, it deinterlaces with TFF order, resulting in a very blurry, but smooth image. This is NOT what CS3 did. It deinterlaced properly.

      With FLV, it treats the video as progressive and creates stairstepped lines, even though the rendered previews in DV format look pristine and razor sharp.

      The only solution for a web-based export that looks nice is to use F4V (the new flash video) and set the H.264 to process "Lower" field priority. My problem is our company systems for employees can't handle F4V yet. (If you set F4V to "Upper, it processes and looks like WMV, and setting to "Progressive" looks like the FLV above)

      Any suggestions or work-arounds that don't require exporting a DV video, opening Virtualdub to flip field order and then using Media Encoder?
        • 1. Re: Media Encoder does NOT deinterlace properly
          Jeff Bellune Adobe Community Professional
          >With WMV, it deinterlaces with TFF order, resulting in a very blurry, but smooth image. This is NOT what CS3 did. It deinterlaced properly.

          There is no way that what CS3 does to footage when it deinterlaces that footage can be called "proper". CS3 throws out half the image resolution instead of doing any kind of *proper* deinterlacing.

          I haven't tried WMV, but if you set your CS4 sequence for high-quality render, and verify that setting (and the chosen bit rate) in the AME before starting the queue, you should see much better deinterlacing and/or scaling results than with CS3. Specifically, I have done HD --> SD conversions using the HQ setting in CS4, and the results have been obviously superior to anything that CS3 can do.

          However, a workflow involving VirtualDub and AviSynth produces results that are better still.

          If you do produce an intermediate file out of VirtualDub, don't use the AME to encode it to WMV. Use Microsoft's free stand-alone WMV encoder instead.
          • 2. Re: Media Encoder does NOT deinterlace properly
            mpiper_valero Level 1
            Jeff, you've got a point. CS3 didn't do GREAT. I tended to use the old 2003 Microsoft WMV encoder as well. But, the Media Encoder in CS3 at least allowed me the turn on or off the "deinterlace" feature when I was converting from DV to WMV. The option to turn it on or off was on the left, not in the codec settings. It was next to the crop controls. If I turned it on, then when I wanted to turn a 720X480 DV AVI into a 640X480 WMV, the fields got blended, but at least I kept all the detail of eyes, letters, etc. and only the motion got blended. If I left the deinterlace turned off, then the fields stayed and you got a 640X480 WMV that looked like it had jagged edges because both fields got encoded "as is" with no loss or dopping."

            The new one does give me the option of turning "interlacing" on or off, but off blurs everything vertically, even when I'm not resizing height. So eyes become blurs and sharp serif fonts become these blurred rounded things. The processing shouold follow the F4V/H.264 model where field order determines deinterlacing order.

            I prefer not to use AviSynth or Virtualdub, except when absolutely necessary. I'm trying to have a workflow that other media employees (who only know Adobe) can follow without asking me every 5 minutes. there are 4 of us who do video, but I'm the only one who has a serious knowledge base. The others are cameramen or Flash developers who cross trained.
            • 3. Re: Media Encoder does NOT deinterlace properly
              Jeff Bellune Adobe Community Professional
              Did you try the "Maximum Render Quality" option? It really is an improvement. It's very similar (if not identical) to the results you can get from AE when you separate fields and check the "Preserve Edges" option.
              • 4. Re: Media Encoder does NOT deinterlace properly
                MerlinBiggs Level 1
                I just had a problem with de-interlacing and graphics.

                I resolved it by creating a new project and selecting the progressive option.

                Didn't have to do that with earlier versions
                • 5. Re: Media Encoder does NOT deinterlace properly
                  TC1221 Level 1
                  Having the same problem, even when you use Media Encoder as a standalone app and just want to convert a separate movie into WMV.
                  That movie was not edited in any way by Premiere, I just wanted to use the converter.

                  Did both with "Allow interlaced processing" checked and unchecked, both are interlaced.

                  And I'm guessing Adobe won't put the manual "Deinterlace" option back, will they?

                  WHAT THE HELL IS IT WITH THIS PIECE OF JUNK? $800 for this crap? So far I've had more problems than at any time with any prior version.
                  • 6. Re: Media Encoder does NOT deinterlace properly
                    Eddie Lotter Level 4
                    >Adobe won't put the manual "Deinterlace" option back

                    Please explain your need for an option.

                    The only time de-interlacing is required is when going from an interlaced source to a progressive destination. Anything else does not require de-interlacing.


                    Cheers
                    Eddie

                    PremiereProPedia   ( RSS feed)
                    - Over 300 frequently answered questions
                    - Over 250 free tutorials
                    - Maintained by editors like you
                    Forum FAQ
                    • 7. Re: Media Encoder does NOT deinterlace properly
                      Jeff Bellune Adobe Community Professional
                      desertboy,

                      Open the flyout menu for the settings tabs and choose "Maximum Quality Render". That option forces the AME to use advanced scaling and deinterlacing algorithms.

                      The results aren't as good as with AviSynth and VirtualDub, but it produces the same quality deinterlacing result as After Effects does when "Preserve Edges" is selected.

                      The downside is that your render time will increase dramatically.

                      There's a lot of new stuff in CS4, and a lot of old procedures that work differently than in any prior version. Realizing that may reduce some of your frustration.

                      -Jeff
                      • 8. Re: Media Encoder does NOT deinterlace properly
                        TC1221 Level 1
                        @ Eddie: that's exactly right, I have interlaced Quicktime DVs that need to be prepped for the web. The standalone media encoder from Microsoft has problems processing QT files properly.

                        @Jeff, thank you - will try this workaround. Just very frustrated that Adobe decided to screw with our workflow so much.
                        • 9. Re: Media Encoder does NOT deinterlace properly
                          When I use CS4 Encoder, I have to resize the video for a stream. When I do so, the final flv is really fuzzy. I have tried everything, including exporting a progressive AVI and it wont even let me see the original AVI, just the fuzzy output. Any help?
                          • 10. Re: Media Encoder does NOT deinterlace properly
                            Eddie Lotter Level 4
                            >and it wont even let me see the original AVI

                            What does that mean?


                            Cheers
                            Eddie

                            PremiereProPedia    ( RSS feed)
                            - Over 350 frequently answered questions
                            - Over 300 free tutorials
                            - Maintained by editors like you
                            Forum FAQ
                            • 11. Re: Media Encoder does NOT deinterlace properly
                              Bill Seper Level 1
                              "There is no way that what CS3 does to footage when it deinterlaces that footage can be called "proper". CS3 throws out half the image resolution instead of doing any kind of *proper* deinterlacing."

                              You took the words right out of my mouth. Premiere has never been known for its deinterlacing ability, and I haven't used AE, but from what I understand, it's not much better.
                              • 12. Re: Media Encoder does NOT deinterlace properly
                                Level 1
                                If I import an AVI instead of, lets say an MOV, I cannot compare the quality of the source file and the output. When I click on source, it is black, all the way through the time line.

                                And no matter what, when I output my files at 320X240, they look like they have a blur on them, or a soft focus, even though I didnt use that setting.
                                • 13. Re: Media Encoder does NOT deinterlace properly
                                  kmcgraphics.com

                                  Before you go to Media Encoder select your final video in the timeline and then go to -> video options -> field options -> deinterlace

                                   

                                  This replaces the CS3 easy option of just ticking a (de-interlace) box

                                   

                                  This is where I sourced the info: http://www.avforums.com/forums/camcorders-video-editing/883688-giving-footage-film-look-ad obe-premiere-pro-cs4.html#post8347287


                                  Hope this helps!

                                   

                                  Kieran

                                   

                                  www.kmcgraphics.com