29 Replies Latest reply on Apr 20, 2009 7:13 AM by paulgoelz

    The software used to decode.... isn't available...

    paulgoelz Level 1
      Well, I'm back again with problems. This one has me stumped.

      I have added some footage to a DVD project that has been successfully rendered and burned. The additional footage consists of three AVIs. In fact, ALL of the project consists of DV-AVIs including a slideshow as a background for the opening menu. And about 2/3 through the DVD render process, PE barfs with a "The software used to decode the media is not available" error. What in the world is it talking about? With the exception of about 10 seconds of black (created by PE) and a couple titles (created by PE), EVERYTHING on the asset list is a DV-AVI.... CREATED BY PE. I don't get it.

      This happened the first time I tried doing the slide show.... I had downsized photos (approximately 800 X 600) on the asset list. Some were BMPs, so I tried making them JPGs. That semeed to work so I exported the slide show as a DV-AVI and used that under my main menu. Some o fthe photos were video frame captures from MPEG captured from VHS. PE seemed to be OK witht he video and rendered the captured frames to DV-AVI as a slide show just fine.

      I'm gonna take a break... I'll welcome suggestions ;) PE sure isn't helping me out any. I want to strangle someone at Adobe.

      Paul
        • 1. Re: The software used to decode.... isn't available...
          Steve Grisetti Adobe Community Professional
          How much free, defragmented space is left on your hard drive, Paul? Do you regularly maintain your computer and clear off the temp files, per my recommended regimen?
          http://www.adobeforums.com/webx/.3bc43f9a

          Have you gone into Premiere Elements' Edit/Preferences and cleared the Media Cache?

          Have you tried renaming your project so that the program must create new render and transcoding files?

          Generally, with situations like yours, it's either a lack of resources or outdated drivers or Quicktime.
          • 2. Re: The software used to decode.... isn't available...
            the_wine_snob Level 9
            Paul,

            I did not see mention of any Audio Assets. Do you have any Audio in the slideshow, narration, music, etc.? The message usually indicates the lack of a necessary CODEC on one's system. If your Video Assets are DV-AVI and still images, this would lead one to check any Audio Assets.

            Back to the Video Assets, I'm a bit confused by one sentence,
            i "Some o fthe photos were video frame captures from MPEG captured from VHS. PE seemed to be OK witht he video and rendered the captured frames to DV-AVI as a slide show just fine."

            You started with a VHS tape, that you captured to a digital format via some device to an MPG file (what CODEC?), and then did Frame Captures from this. Is that assumption correct? If so, these Frame Captures should not create any problem.

            You've got stills that are all now JPEG (some converted from BMP), right? No additional formats in the still, right?

            Hunt
            • 3. Re: The software used to decode.... isn't available...
              paulgoelz Level 1
              Good suggestions Steve.... I have about 450GB free on my video drive, and that is where all files including scratch disks etc. are stored. It didn't occur to me to clear my cache since the only things that should have been rendered to output the DVD were DV-AVIs on the timeline. No, I didn't rename it although the project was a save-as from the version that did render OK with the slide show but without the added DV-AVIs.

              To Bill..... I had not considered that the error message might refer to audio, but the only audio in the entire project is that which is contained in the DV-AVIs that make up the project. This includes the audio loop under the slide show.

              You are correct.... the slide show consisted of stills taken from an MPEG file captured vie Dazzle from VHS. That same MPEG file was used for about the first third of the project and PE had no trouble with it, so there wasn't anything fundamentally wrong with it.

              In the end, I simply removed the slide show from the menu and replaced it with a still image JPG and no audio. After that single change, it rendered and burned to a folder (and then to DVD) just fine with no problems.

              So..... I still don't get it. But I got it ;)

              Along the way I also ran into yet another oddity.... all of a sudden, the last 3 letters of the title of each scene menu reverted to some other font and color than the one I selected (I think they reverted to the original font/color from the menu template). But only in the menu edit window.... if I clicked "preview", they showed correctly. When I re-applied the correct font, the problem went away.

              When the process works, it works very well. I am VERY pleased with the end results. Even cutting the bit rate down to about 5Mb/S to fit the project on a DVD resulted in very good looking video. The menus look great too. If PE would just be a little less obtuse with its error messages we could all figure out what was wrong and spend a lot less time with endless trial and error.

              Paul
              • 4. Re: The software used to decode.... isn't available...
                the_wine_snob Level 9
                Paul,

                Glad you got the Project burned.

                Now, tell us a bit more about
                i "... the audio loop under the slide show."
                What is the format there, and where did it come from? It still sounds like something uses a CODEC, that PE is not able to access for some reason.

                If it worked without the slide show, that *might* indicate a problem with it. That's where I'd start looking.

                One thing to try would be to do a New Project and use just that slide show, built exactly to how it was in the competed Project. The closer you can come to duplicating it to the letter, the better it can be used to troubleshoot the problem.

                I do agree with the error messages. In the Adobe products that burn DVD's, much of the code comes from Sonic. Sonic uses modules and they do not often talk to each other. Errors are generated by a module, but the rest of the program hasn't a clue what it's talking about.

                One other problem is that Assets can be allowed to be Imported, but then can cause problems. The upside is that something stops the process, before a bunch of coasters are burned. The downside is that one often does not know which Asset is causing the problem. Many users wish that Premiere was not so strict (they feel the same about Encore) with regards to Assets. I feel just the opposite. I wish that all of these Adobe programs flagged Assets more carefully. Again, with the Sonic-authorcore modules, some will OK an Asset, only to have it grind the next module to a halt. That is why I am so very anal about my Assets. I do all of my conversions outside of my NLE, including all still and Audio Assets. When I Export to my authoring software, Encore, I always do it the same exact way, with the same exact formats. Yeah, it might seem boring, but I've never had a Project fail to burn to DVD - to date, I'm 100%.

                Please try a re-build of the slide show and let us know how that goes. Also, tell us more about the Audio for that slide show.

                Thanks and good luck,

                Hunt
                • 5. Re: The software used to decode.... isn't available...
                  paulgoelz Level 1
                  That's just the thing..... the slide show as incorporated into the project that threw the error was rendered to a DV-AVI before icorporating it into the project... it was no longer a slide show, it was simply a video clip. The sound track to the slide show was a portion of another DV-AVI that was already part of the project. There was NOTHING in the project or the asset list except DV-AVIs that PE had created.

                  One thing that occurred to me is that the slide show clip might have been shorter than the length I set for it in the menu creation menu... if that is even possible. The slide show was supposed to be 30 seconds and I think I had the duration set to the max. Maybe the slide show was a bit shorter (or longer?) than that. Maybe that freaked it out.

                  Your suggestions are on target.... but I don't think they apply here, unfortunately. To recap, I had burned the project to a folder and then to a DVD with no issues whatsoever. This included the slide show and sound track. ALL I did after that was add three other DV-AVIs that PE had rendered from the same source material that the project was made from. These were the out takes, so they were from the same two cameras as the rest of the project. As soon as the three DV-AVIs of out takes were added along with about ten seconds of black and one title, I could no longer render to DVD. It makes no sense. Yet.

                  I too wish PE was stricter. Better yet, it desperately needs a project standards check function. And of course, better error tracking and explanation. Without that, I fail to see how it can be successfully marketed to the general public.

                  Thanks..... still scratching my head ;)

                  Paul
                  • 6. Re: The software used to decode.... isn't available...
                    the_wine_snob Level 9
                    Paul,

                    I cannot directly speak of PE on this, but Encore (kinda' the big brother to the DVD authoring part of PE) does not like Audio Assets that are longer, or shorter than their Video counterparts. I'd look into re-working these so they are the exact same Duration.

                    Other than that, I'm scratching my head too.

                    Hunt
                    • 7. Re: The software used to decode.... isn't available...
                      paulgoelz Level 1
                      (Edited to remove the rant tone.... sorry guys. I'm not a happy camper right now. Not your fault.)

                      I deleted my slide show... the thing that I guessed was causing the "The software required" error. After that, PE rendered the project just fine. I actually rendered it several times because each time I discovered small errors on my part and corrected them.

                      The last time I rendered it, I discovered that there was audio under my "bonus cuts" menus. I don't remember putting it there in the first place, but there it was... from the DV-AVI clip the menus referred to. So I deleted it. I MADE NO CHANGES WHATSOEVER ASIDE FROM THAT. And PE rendered for an hour or more and then barfed the old "The software required to decode...." error. What the H*** is it talking about? It was happy. I deleted audio under a menu (the audio came from the clip the menu referred to). And then it wasn't happy any more. The ONLY audio on the project is that which is encoded in the DV-AVI clips in the project... which PE rendered. I don't get it.

                      I also discovered when I looked over the project again that my last menu was not a still frame like I intended. I could swear that I never made it a motion menu, but it suddenly turned into one. Kinda like suddenly having audio under my menus.

                      So I made sure all my menus were still frame backgrounds and I'll render once more. But I swear, if it barfs again, I've had it for a while. PE is wonderful when it works. But it is 100% horrid when it does not. I have wasted far more time than I should have had to trying to get this project done and burned. A few well placed error messages with some CONTENT would go a long way.

                      Oh, and several times I have caught it changing the font size for portions of my menus including the main title. Last time, I didn't notice until it was rendered. Another couple hours wasted. Makes it very difficult to proof the project when you cannot rely on things that were OK STAYING OK.

                      Paul
                      • 8. Re: The software used to decode.... isn't available...
                        Paul_LS Level 4
                        Older versions of PE had issues with trying to burn a DVD with no audio under the video if there were DVD markers. Place an audio clip under the video, just turn the volume way down.
                        • 9. Re: The software used to decode.... isn't available...
                          paulgoelz Level 1
                          I'm afraid that isn't the problem. At least not directly. I am using PE 3. My project consists of about 8-10 DV-AVI clips. ALL have audio under them. Wait a minute.... there is no audio track under the black that is under a title that preceeds my bonus cuts. Could that be it? It has been like that forever.

                          It is rendering now. Lessee what happens.

                          All this guessing wouldn't be anywhere near as annoying if it didn't take a couple hours to find out if you guessed right or wrong. That combined with eating, sleeping and working has stretched this project out from a day or two to WEEKS. I have to wonder how the less adventuresome fare with this software......

                          Paul
                          • 10. Re: The software used to decode.... isn't available...
                            paulgoelz Level 1
                            It rendered just fine. Go figure. ALL I did was correct a couple font issues (that PE caused) and made the last menu background a still frame like it was supposed to be.

                            I am wondering if the "Software required" error is either random or not directly related to the real issue.

                            Paul
                            • 11. Re: The software used to decode.... isn't available...
                              paulgoelz Level 1
                              Well, it isn't QUITE right. It rendered OK and I burned it. Only to find out that PE changed the font size and position of one of the main menu titles.... AGAIN. I have NO idea why it does that. It isn't too bad.... one size smaller (24pt vs. 30pt) so I'm gonna leave it like that and just burn the danged things as-is. Bugs me though. I have yet to figure out what triggers the font size changes, but they definitely happen.

                              Paul
                              • 12. Re: The software used to decode.... isn't available...
                                the_wine_snob Level 9
                                Paul,

                                One little tripping point with the Titler and existing Titles is that if one *intends* to make a Copy of the Title and then make changes to the "new" Title, they have to do this with a few steps. P-Pro makes it a bit easier, but not totally foolproof. People often *think* that they are working on a Copy of the Title, but are, in fact, editing the previously used Title. One has to take care here. I know how easy it is to commit this one error, as I have done it a few times, thinking I'm working on a Copy.

                                Also, if one selects a new Style for a Title, the Font and Effects will change by the specs. of the new Style - care needs to be taken if doing this, as well.

                                Hunt
                                • 13. Re: The software used to decode.... isn't available...
                                  paulgoelz Level 1
                                  Happened again. And again, it seems to involve either a video or audio clip that runs as the main DVD menu.

                                  On this latest project, all the clips in the asset list were AVIs (not DV-AVIs) from my Canon S5 still camera. All I did was place all clips on the timeline (with no transitions) and create a DVD menu structure. The DVD menu used 30 seconds of audio and video from one of the clips under the main menu, and still frames from the other clips as the background for the various scene menus.

                                  The project assembled and previewed just fine.

                                  But when I burned it to a folder, I got the same old "The software used to decode the media is not available" error. Based on past experience, I simply changed the main menu to a still frame with no audio, made NO other changes and it burned just fine. Very annoying.

                                  As an aside, I have also discovered that if you keep another program open in the background (any program will do), you can force PE to give back some of its memory if you simply give the other program the focus. If you don't do that, I have found that PE uses more and more memory as time passes and eventually gobbles up enough memory to crash.

                                  Paul
                                  • 14. Re: The software used to decode.... isn't available...
                                    the_wine_snob Level 9
                                    Paul,

                                    Have you run those AVI files (from the Canon) through G-Spot to see what CODEC is being used? The Canon specs. *might* list it, but often mfgrs. do not bother to tell the end-user what is going on under the hood. If it uses some odd CODEC, it might well be possible to either get it from the Canon Web site, or locate it on the software CD/DVD that came with the Canon. Last, you might be able to locate it on another site, though that might well be a hacked version, that causes problems - I'd use this as a last resort.

                                    In G-Spot, pay very close attention to both the Video and Audio CODEC. With any DVD authoring app. both are very important, especially any of the Adobe authoring apps. The Assets MUST be DVD-spec. compliant - 100%. Even "big brother" Encore is very, very picky. Most errors in it are from feeding non-DVD-spec. compliant files and trying to Burn to DVD. Some other authoring apps. are not so critical of Assets, but you run the risk of Burning a DVD that will not play on many set-top players.

                                    Good luck,

                                    Hunt
                                    • 15. Re: The software used to decode.... isn't available...
                                      paulgoelz Level 1
                                      Very possibly (most likely?) it is a CODEC issue. But the annoying part is that PE has no trouble AT ALL burning a DVD as long as I don't use video or audio from the clips under a menu. All I had to do to fix the problem was revert the menu background from a video clip to a still frame and delete the audio. So if it IS a CODEC issue, it is only an issue with motion menus.... the main "movie" itself is fine (remember that the motion menu background was from a clip that is included in the body of the project).

                                      Too bad, too... the clip I used for the menu background was a good one. Not a total loss though, because that clip is included in the body of the DVD.

                                      THIS WOULD ALL GO AWAY (or get a LOT easier to handle) if PE had a "verify project" feature (with GOOD error messages) that could be used to ferret out problems before you wasted hours rendering only to end up dead in the water with an unhelpful error message. I still find it hard to believe that a program of PE's stature in the industry is SO obtuse in the face of mass confusion over video standards.

                                      Paul
                                      • 16. Re: The software used to decode.... isn't available...
                                        paulgoelz Level 1
                                        OK, here is some more data......

                                        I rendered the project originally with a motion menu for the main menu. I got a "The software used to decode the media is not available" error.

                                        On a hunch, I removed the motion menu and substituted a still frame with no audio. It rendered fine, and I burned it to a DVD, which played fine.

                                        However, when I played it I discovered a couple spelling errors in my titles so I corrected them and added two more titles. I MADE NO OTHER CHANGES WHATSOEVER and once again got a "The software used to decode the media is not available" error when I tried to render it.

                                        So the error would appear to be random, since I did not change the content at all. ??

                                        Paul
                                        • 17. Re: The software used to decode.... isn't available...
                                          the_wine_snob Level 9
                                          Paul,

                                          I feel your pain. I have lodged many "feature requests" for a pre-flight function, especially in Encore. PE contains parts of Encore. I believe that it is still based on the Sonic-authorcore, that Adobe purchased some years ago. Encore has a "Check Project," function, but that only looks at DVD-spec. navigational errors - not at Asset problems.

                                          On one hand, Encore will allow Import of many Assets, that cannot be re-done into DVD-spec Assets, though it will try. When it cannot, it fails, and often with one of those cryptic error messages. Problem with the error messages is that they are generated by Encore, or one of the Sonic-authorcore modules (it is modular in its design and often the modules do their own thing, not really communicating with the host program, or with each other) or from Windows itself. I do wish that someone would compile a list of EVERY possible error message and at least break them down to the particular module/source and also list general places to check for a problem.

                                          As for your replacement of Assets, I can only offer a tiny bit of input from another Adobe program and another forum. In Encore, the replacement of Assets, without clearing up all of the links to the old, can result in problems. Now, I have a habit of doing something similar to what you did. I'll do my final preview and discover a problem with an Asset (spelling, double instances of "the," Audio too loud, etc.), and just open up PP to fix the problem. I just Save as the same file (already linked in Encore), and let Encore basically re-Import that Asset. Many respected gurus of Encore say "Do Not Do That!" Still, I've never had a problem, but obviously others have. The recommended method is to Save_As (new file name), then in Encore do a Replace. Not sure how one goes about that sort of workflow in PE, as it's all combined (PP & Encore into one program, basically).

                                          Maybe Steve, or someone more knowledgable in exactly how PE works can offer a modification to your workflow. Unfortunately, I cannot. Maybe flushing a cache, before Assets are changed would do the trick. I just don't know.

                                          Now, to your Motion Menu: you're attempting to use a part of an existing Asset as the Motion Background, right? That original Asset works fine from the Timeline and burns to DVD fine. Correct, so far? You do an edit on this Asset, to shorten it to the necessary Duration for the Motion Menu. What is that in PE, 15sec.? Now, it doesn't work. What is the format of that Asset, both in the Menu and in the Timeline? In Encore, the Motion Menu (from the Library) Video footage was MOV in earlier versions and is now WMV. Normally, I use DV-AVI footage and either PCM/WAV 48KHz 16-bit or DD 5.1 SS AC3 for Audio Motion Menus. Your Asset wouldn't happen to be mux'ed, would it? If so, de-mux it and Export as elemental streams. I do not know how to set these two to a Motion Menu in PE, but others will. Even though your Asset plays/Burns fine from the Timeline, try Exporting the mini-clip for the Menu as a DV-AVI elemental stream (Video only).

                                          I'll go play with PE and Motion Menus, to see if I can get you more info. Sorry, but I only use Encore for DVD authoring, so I do not know PE's ins-n-outs.

                                          Tips:
                                          Always use elemental streams, where possible
                                          Always use DV-AVI elemental Video stream, where possible
                                          Always use PCM/WAV 48KHz 16-bit elemental Audio stream, or AC3 DD stereo, where possible
                                          Never use MPG Audio (mux'ed, or elemental stream). This includes MP3/Mp4. Convert beforehand.
                                          Note: I did not mention AC3 DD 5.1 SS above, because I do not believe that PE can handle it.

                                          Good luck,

                                          Hunt
                                          • 18. Re: The software used to decode.... isn't available...
                                            paulgoelz Level 1
                                            Hmmm.... a lot of that makes sense..... except that it went from an OK render to an error after I merely chenged the text within a couple titles and added two others. I did nothing else.

                                            You are close re: my project composition. However, I did not edit the asset that I used as motion (and then still) background for my main menu. I just pointed PE to the whole asset, let it limit to 30 seconds, and set the in point. PE has no trouble at all with the asset until it comes to the menus. And I am still just guessing there too.... when I have had trouble, changing or deleting menu backgrounds usually resolves it. However, the menus render first and the "Software used to decode" error pops up near the end of the main render, so it is just a guess what it really means.

                                            Interestingly, I rendered the entire timeline to DV-AVI (went OK), replaced the assets on the timeline with the rendered AVI.... and I still got the "Software not installed" error. At that point, the menu backgrounds were still linked to the original AVI camera file assets, so I removed all backgrounds and re-did them, pointed to the rendered AVI. The first time I tried to burn to a folder, I got an error "Error, cannot read menus". I closed PE, re-started it, and all was fine. It is still rendering so I don't know if it will be successful.

                                            Conclusion: there is something different and potentially flakey about the menu creation vs. timeline rendering routines. Your explanation about the modular construction of PE makes sense.... who knows how similar the menu rendering is to the timeline rendering. Lesson learned.... build the project minus DVD menus, render the timeline to DV-AVI, then build the menus. At least then, PE doesn't have any excuse ;)

                                            I think I have said it before but..... I am VERY glad I didn't pay money for this program. It came free with my h.264 video camera. And there's a bit of irony in that, eh? Editing h.264 of any size in PE is a guaranteed crash 100% of the time unless you monitor memory use and save / close / reopen at about 1.4GB.

                                            Paul
                                            • 19. Re: The software used to decode.... isn't available...
                                              the_wine_snob Level 9
                                              Paul,

                                              Once you get your Project Burned, try a test with the Motion Menus, please.

                                              It sounds like you have Exported your original Project to a DV-AVI, that works fine on its own. Start a new Project, and use that DV-AVI as your Timeline. Back in the "original" Project, edit your intended Motion Menu footage to 30 sec. (thanks for that, as I could not remember the limitation in PE), and Export it as elemental Streams: DV-AVI (Video and no Audio), then Export just the Audio as PCM/WAV. Try linking those to your Motion Menu. Let us know how it goes.

                                              In the meantime, I'll go into PE and try to get a handle on how it handles Motion Menus and their Assets. Sorry that I am just not familar with what/how it does this.

                                              Good luck with your Project,

                                              Hunt
                                              • 20. Re: The software used to decode.... isn't available...
                                                paulgoelz Level 1
                                                Well, the new project with the one big AVI didn't work either. Same error. I decided to give it one more shot in case there were old links to something. But I'm really guessing here.... this software is so NOT ready for prime time.

                                                So..... I deleted all clips and all assets, leaving ony the scene markers (so I didn't have to recreate all 75 of them).

                                                Then I added the big rendered DV-AVI and checked to make sure the scene markes still lined up OK.

                                                Then I completely re-did the menus from scratch, using a different template even. I also used a still image instead of a freeze frame for the menu backgrounds. It is about as far from the original project as I can get and still have a project.

                                                It is now rendering.... we'll see how it goes. One thing I noticed s that until this last render, it ALWAYS rendered the menus first. This time, it seems to be rendering the timeline first.

                                                I know I have said it before, but if this fails, I am done for a while. I am four or five 3+ hour renders down the road and still don't have a finished project. I used to think that Studio 9 was the second worst program I have ever used. But PE is real REAL close to that "honor". I realze you guys have all sorts of cautions and work-arounds and that by not using DV-AVI as the input I am asking for trouble. But I simply don't have the disk space to convert everything to DV-AVI. And sometimes it DOES work....

                                                Paul
                                                • 21. Re: The software used to decode.... isn't available...
                                                  paulgoelz Level 1
                                                  OK, we're missing something important.

                                                  My latest attempt produced the same "The software used to decode..." error. It has absolutely nothing in common with the first project. It consists of single 2 HOUR dv-avi that was made by PE, a DVD menu with 15 pages, each one with 6 scenes. The menu backgrounds are from a still image (not a freeze frame) of about 1100 pixels wide.

                                                  One thing I noticed was that the error happens (I think) AFTER the rendering is done and at the very beginning of the "burning to folder" step. That makes no sense at all, since at that point the rendering (assumed) is completed. ??

                                                  I don't know what else to try. I have plenty of HD space but it has not been defragmented. Could that be it? Is PE so stupid that it has to have contiguous chunks or it barfs?

                                                  I don't know what else to try. And all this searching, guessing and WASTING TIME is wearing me down. I'm using PE 3. Does PE 4 do it any better? From what I have read, no.

                                                  Paul
                                                  • 22. Re: The software used to decode.... isn't available...
                                                    the_wine_snob Level 9
                                                    Paul,

                                                    Sorry, but I'm out of ideas. I'll monitor the thread, and hope to read some good news. Maybe someone else can chime in with some fresh thinking.

                                                    Hunt
                                                    • 23. Re: The software used to decode.... isn't available...
                                                      paulgoelz Level 1
                                                      Hey, at least you had more ideas than I did ;)

                                                      I have pretty much given up. But I just defragged my video drive and I'll have yet another go tonight while I'm in bed.

                                                      I still think we're barking up the wrong tree, if you can believe the status reports when it is burning.... it says it is rendering the menus. When it finishes that, it says it is rendering the timeline.... and that takes an appropriately long time. AFTER that, it says "Burning to folder" and shortly thereafter throws the "Software used to decode" error. I'm wondering if this is a resource or system error that simply stimulates the "Software used to decode" error but that isn't really the root cause.

                                                      Now that I have defragged, I'm gonna try rendering the original version with all the individual clips. It DID render the first time... just not after I made some title spelling corrections.

                                                      Paul
                                                      • 24. Re: The software used to decode.... isn't available...
                                                        paulgoelz Level 1
                                                        OK, i don't have an answer but I d have more input data....

                                                        After I defragged my video drive, I re-created my project totally from scratch under a new name. I added about 30 minutes more video and omitted the titles. I also used a simple still image for the menu backgrounds. All clips are the camera original AVIs.

                                                        It rendered and burned to a folder just fine.

                                                        One thing I discovered when I went through the original project was that there were a lot of duplicated assets on the asset list..... both video clips and still image titles. I did not create them.... I think most but possibly not all were created by PE when I (for example) used a still frame from a video asset for a menu background. But I wonder if this is what is confusing PE when it begins the "Burning to folder" step. Especially if it creates additional duplicated assets as you change things. I found several instances where an asset was present three times.

                                                        Also, if it makes any difference, I am putting about 2.5 horus of video on one DVD using PEs feature where it adjusts the bitrate to allow the project to fit. Came out to about 3.7Mb/S.

                                                        Paul
                                                        • 25. Re: The software used to decode.... isn't available...
                                                          Steve Grisetti Adobe Community Professional
                                                          2 1/2 hours on one DVD! You do realize a standard DVD can only hold about 60-70 minutes of video at full resolution, right?

                                                          Also, 2 1/2 hours of video is going to require a tremendous amount of scratch disk space on your hard drive. Depending on what you're using for source files, how many transitions and how many effects you've applied, you could require well over 100 gigabytes of free, clean, defragmented hard drive space.

                                                          I know we've been digging around and troubleshooting for over a month on this, Paul. But I'd be tempted to at least do a test run of, say, a 30 minute project, just to see if the size of this epic project might be the issue.
                                                          • 26. Re: The software used to decode.... isn't available...
                                                            paulgoelz Level 1
                                                            Yes, I am aware that there will be a quality tradeoff. This is a very simple project.... just a bunch of clips and a DVD menu. I came back from a mucic event with a bunch of video that others would like to see, so I just put it all on the timeline, added scene markers, did a simple DVD menu and let it reduce the bitrate (to about 3.6Mb/S) to fit a standard single layer DVD. No transitions and now, no titles either. There isn't a huge amount of motion, so the reduced bitrate isn't all that obvious.

                                                            My video HD is a 1/2 TB drive that has 350+ GB free and it was just defragmented. Note that it has now rendered successfully. Not sure if that is because I defragged it or because I started over from scratch and omitted the titles.

                                                            If I can believe the status messages, the error always occurs after the timeline is rendered successfully. At that point, the menus are also (usually) rendered, so it is not as straightforward as a simple rendering problem.

                                                            I am assuming that making a DVD from non-DV AVI clips involves two renders? It seems like it renders to an intermediate format (DV-AVI perhaps) and then renders to the actual format used for DVDs. It appears it is during that second render that it runs into trouble. I have seen two different status messages when that happens.... sometimes it says it is "Compiling media" and sometimes it says it is "Burning to folder" when it announces that "the software used to decode" should be installed. Always, that is after a lengthy render process.

                                                            Can we hope that PE7 will be an improvement? Or conversely, maybe what I need is a different DVD authoring program. I do OK with the video editing steps. In retrospect, I think the vast majority of my problems have been while actually authoring the DVD.

                                                            It would also be HUGELY helpful if Adobe would publish the system ramifications for things like many clips, many DVD menu entries, h.264 clips, etc. so we could stop guessing. And they REALLY need to fix the memory leaks. I have many times seen it chew up more and more memory until it crashed..... without me doing anything. Especially with h.264 clips and/or lots of DVD scenes.

                                                            Paul
                                                            • 27. Re: The software used to decode.... isn't available...
                                                              paulgoelz Level 1
                                                              I have also noticed yet another oddity in the project that DID finally finally render and burn. After rendering and burning to folder and watching the subsequently burned DVD, I opened the project again. It is now using a totally different font for the last letter in the titles in the scene menu pages. I can change it back easily enough, but I don't know why it is doing it in the first place.

                                                              I have seen this before in other projects. What is odd is that once it starts doing this, it does it EVEN IF I CLOSE WITHOUT SAVING AND RE-OPEN. Either something has changed in PE or it has done something to the project file(s) that survives even if you do not save.

                                                              Not sure if this is related to the "software used to decode..." issue.... probably not. But who knows. In my experience, PE is flakey enough that nothing is beyond reason.

                                                              Paul
                                                              • 28. Re: The software used to decode.... isn't available...
                                                                Level 1
                                                                This thread saved me a lot of wasted time. I got the program with a Sanyo Exacti HD700 and I just copied the video in and put some pictures in and I got the "software used to decode..." issue. No editing was done except to make some video clips shorter. This was to be a test DVD and the camera as it was only about 2 minutes long.
                                                                Jim
                                                                • 29. Re: The software used to decode.... isn't available...
                                                                  paulgoelz Level 1

                                                                  OK, reviving this thread for an update....

                                                                   

                                                                  In the intervening months, I have migrated from XP to Vista Ultimate 64 bit.  While rendering a new project to a WMV file, I got an error that I think might be at least related to the old familiar "The software used to decode..." error.  Except that this time, the error message actually provided more information and a solution.  What seems to have happened was that I selected to do a two pass render to WMV but something about the audio format was not compatible with a two pass render.  The error message suggested that I do a single pass render, which worked without any other changes.

                                                                   

                                                                  Is this perhaps the real problem?

                                                                   

                                                                  As an aside, I am finding that PE7 is FAR more stable under Vista x64 than it ever dreamed to be under XP x86.  "Just because", I have done most of my recent editing work on my new Thinkpad X61s (1.6GHz Core2Duo / 2GB / 160GB).  Pushing the envelope, as it were.  To my utter amazement, PE7 worked just fine with no issues at all.  I have gone so far as to browse the net, check Email AND watch TV streamed from my HTPC over WiFi while AT THE SAME TIME rendering 1080i video to MWV.  CPU was pegged at 100%, RAM was at about 75%, and the PC was only a little slower than normal.  The TV played back 100% flawlessly during the render.  Really surprised me.  And on a 1.6GHz machine to boot.  I can only imagine how much better it will be when Adobe finally comes up with a native x64 application.

                                                                   

                                                                  Paul