7 Replies Latest reply on Dec 20, 2008 2:16 PM by (Groundrod)

    Component not installed

      I have been using mpeg files in my video presentations for some time now. Today when I try to bring them into Premiere Elements, I get this message "Unsupported format or damaged file. One of the necessary components may not have been installed." The present nation works fine with Windows Media Player but will not load into Premiere.

      Any ideas what may have happened and how to correct it?

      Thank You
        • 1. Re: Component not installed
          Steve Grisetti Adobe Community Professional
          Some MPEGs may not work in Premiere Elements.

          If you convert them to DV-AVIs, they should work fine.
          http://www.adobeforums.com/webx/.3bc4800e
          • 2. Re: Component not installed
            Level 1
            grisetti,

            Thanks again for the prompt reply and help location.
            • 3. Re: Component not installed
              Level 1
              I have been trying to understand why PE will not load mpeg files. Here is another finding that may help. I am using an external hard drive to store my mpeg files "M". When I attempt to import these files it finds the file name but I noticed that it contain another drive name "J". When I try to move it into the monitor, I get the message about unsupported file---------. When I check my "Computer" area I have 5 hard drives listed but no "J". I think PE is trying to locate the mpeg file in a drive that doesn't exist.

              Any ideas as to what is happening?

              Thanks
              • 4. Re: Component not installed
                the_wine_snob Level 9
                Groundrod,

                It is likely that one of two things is happening:

                1.) these files were linked from a time that your OS assigned drive letter J:\ and that is getting in the way
                2.) your OS is confused about what the drive letter really is

                I normally mark each external with the drive letter that I set in the OS manually. I then set it to the exact same for the OS of every machine I work on with this external drive. You need to do this with your System Disk Manager in the OS.

                I would also guess that you have a second problem afoot. The "Unsupported... " usually indicates one of two things:
                1.) file is corrupted (the changing of the drive letters *could* account for this, depending on how confused the OS, and PE, have become
                2.) the necessary MPEG CODEC has been lost, or its priority has been changed by another program. This most often happens with either an OS update (even those Hotfix updates from MS CAN cause this), or the installation of some other program with its own set of CODECs (CODEC "packs" can really mess things up with an otherwise stable system).

                I would address the drive letter issue first. Since PE "thinks" the files are on J:\, I would set the external to J:\ (Disk Manager) and also mark it as J:\ with a removable label. Reboot and check to make sure that the drive letter change "stuck." Then, launch PE and try the Import again. We'll all X our fingers for you, in hopes that the files on the external are NOT corrupt.

                If this fixes things - good. If not, I think that I would do a Repair Install of PE, in hopes that this will re-install the MPEG CODEC and register it with the proper priority. If this fails, to do the trick, you have two possible routes to attempt:
                1.) using a CODEC utility (do not have a link handy, but will look for one), set the Adobe MPEG CODEC as #1 priority
                2.) download and install either the Main Concept, or Lead MPEG CODEC. Seems that both are shareware, i.e. they cost $ and something in my memory tells me that the Main Concept CODEC might have been either discontinued, or bought up by someone else - just cannot remember what the deal was there.

                If the files ARE corrupt, things get a bit tougher. If you have an archived copy, I'd definitely try that. If not, you might get lucky with a little freeware program, Digital Media Repair. I forget the formats that it handles, but it has saved my bacon on a few instances. Last, you could use a program, like Stellar-Phoenix to "recover" the files from the external. Stellar-Phoenix is a great recovery utility and can do some amazing things. The suite is not inexpensive, but I like it so much that I bought a license for it on all three editing systems. I've only used it twice, but it more than paid for itself with some irreplacable client Assets. If you even *think* that you might have to go this route
                b DO NOT
                copy over, delete, replace, or modify your original AV Assets. Make a Copy of all in another folder and work from those. Matter of fact, I would make those Copies onto another hard drive and
                b NOT
                touch the external. There could be file "pieces" scattered all about and you will not want to do any writing to that external, until after you have run Stellar-Phoenix (or other) on it. I cannot over stress the importance of not writing
                b ANYTHING
                to that external, until after you run the recovery program.

                Sorry for being so long-winded, but I wanted to try to cover all bases, and in the order that I would use to solve the issue(s).

                Good luck,

                Hunt

                PS this sort of thing is why I always work from copies of my Assets, leaving the originals on a separate hard drive for safety. Yes, this means a ton of 2TB externals sitting around the editing suite, but corruption can happen - those 1's and 0's can get scrambled. If I am working with Captured footage, and have the physical tapes in my possession, I will work from the Captures, as I can re-Capture from the tapes. If the Assets are direct from the client, or even from my libraries of SFX, stock footage, etc., I always work with
                • 5. Re: Component not installed
                  Level 1
                  Hunt,

                  You put a lot on the plate of a non computer person. However, I will dig into it. I am a grandpa who is trying to make videos of the grand kids. Somehow, I can usually make things work.

                  Thanks for all of your help.
                  • 6. Re: Component not installed
                    the_wine_snob Level 9
                    Groundrod,

                    Considering the above, I am glad that I did go into detail. After working through the comments, if you have any specific questions, please do not hesitate to ask them. I tried to cover *most* bases, but might not have used the most concise language.

                    Also, one of the easiest ways to check (very light check) for AV file corruption is to play the file in Windows Media Player (WMP), or MediaPlayer Classic (freeware). If the file plays in either/both, the chances are fairly high, that the actual files are not corrupt (always a concern with your error message and not a good sign, but not always fatal).

                    As for the exact method of assigning a permanent drive letter to an external, it will differ slightly by OS and even version of an OS. The best way to find out how YOUR version of the OS needs to have this done is go to Start>Help and then type in "drive letter," with out the quotation marks. Help will bring up a list of references to "drive letter," and one of these will be for assigning a specific drive letter. There will probably be active links on that page in Help to get you to where you need to be. You *should* get to a screen that lists the Properties for all hard drives on your system. When you locate that particular hard drive, it will show the drive letter that Windows has assigned, and there should be a button to "Change" the drive letter. There you will see a drop-down list of possible drive letters. All that are already assigned, will not appear in this list. In your case, you say that there is no "J:\" If this is correct, that letter *should* be available in the drop-down. That would be my first step - renaming that external to J:\. Reboot, then launch PE (often a reboot is not required, but let's do it anyway, to make sure that the change "sticks"). Try Importing these AV files again. If the same, or similar, error messages pops up, then we can move on to CODEC issue.

                    As I stated, there are several ways that CODECs can get overwritten, or moved down on the priority list. Since PE ships/installs several, that it looks first for, the Repair Install from the original DVD would probably be the next best step. Your Project files will NOT be overwritten with this operation. Try to Import these files again and report any error messages that you get.

                    At this point, we will have ruled out three possibilities:
                    1.) the drive letter is confusing PE
                    2.) the proper CODECs are installed
                    3.) probably ruled out file corruption, if they play elsewhere

                    If you still have no luck, go to www.headbands.com/gspot. Download and install the freeware program, G-Spot. Don't let the name fool you. I have not sent you to a porn site. This little program will do several things, when launched. The first is to survey all CODECs on your system for proper installation and registration. Next, drag each of the AV files to G-Spot and it will tell you exactly what CODECs are required and whether you have these properly installed. This is what we want.

                    If you get the message that you do NOT have the proper CODECs, there will be two boxes at the top-right, that will tell you the CODEC(s) needed, and their official name. Report these, and we'll find them for you on the Internet. Most are free and easy to install.

                    Remember, ask specifically, if I did not make something clear. I've tried to stay away from jargon, but might have missed something that was perfectly clear to me, but might not be to another.

                    Good luck,

                    Hunt
                    • 7. Re: Component not installed
                      Level 1
                      Hunt,

                      I appreciate all of the time that you have taken to help me through this situation. It will take me some time to work my way through all of this. I'll see how I do and send another message if more help is needed.

                      Thanks again