2 Replies Latest reply on Jan 30, 2009 6:02 AM by the_wine_snob

    Premiere Elements 7 Takes Over 1 hour to OPEN

      Hello,

      I'm new to this forum, so please bear with me.

      PE7 takes over 1 hour to open on my computer. Does anyone have an idea what the problem could be? This is absolutely outrageous. I'm a music producer, & I've run all sorts of huge programs on this computer w/no problem. Why would such a simplistic program like PE7 take over an hour to open???? Once it opened, it froze & crashed while I was browsing thru font styles.

      I'd appreciate any assistance

      Thx
        • 1. Re: Premiere Elements 7 Takes Over 1 hour to OPEN
          Steve Grisetti Adobe Community Professional
          It could be any of a number of issues:

          1) Your computer isn't powerful enough, especially if it is a laptop. Check out our recommended specs, not Adobes:
          http://www.adobeforums.com/webx/.59b699a8/8

          Or tell us how fast your processor is, how much RAM you have, how much free space is left on your hard drive and what operating system you're using and we'll tell you.

          2) A bad install. Try uninstalling and reinstalling the software.

          3) Your firmware and drivers are out of date. Outdated RealTek drivers and Quicktime, in particular, can foul the program. (Again, as listed in the FAQs at the top of this forum.)
          http://www.adobeforums.com/webx/.3c057647/2

          4) Your computer just needs some basic maintenance. This is particular true if you've got a variety of software installed (as you apparently do). Here are our recommended regular maintenance steps.
          http://www.adobeforums.com/webx/.3bc43f9a/0

          There also could be a number of other issues, including whether or not you've optimized Vista or XP for video editing and what type of video you're editing.

          But you'll have to tell us what you're working with in order for us to say.
          • 2. Re: Premiere Elements 7 Takes Over 1 hour to OPEN
            the_wine_snob Level 9
            Miss Monroe,

            Steve has addressed many possible issues with the time to Open, as well as potential crashes.

            One thing that struck me was your mention of Font Styles. You might get some ideas of one possible cause of that, in this thread:
            http://www.adobeforums.com/webx/.59b7b860/3

            Good luck,

            Hunt