12 Replies Latest reply on Apr 11, 2009 3:58 PM by Rob P Parker

    PE4 - No audio

      Until recently, PE4 worked fine. I have made no hardware changes to my system, and I'm not aware of any software changes/additions which could cause my problem, which is:

      PE4 fails to give any audio output on my system. It does still include audio in output that it generates (eg. DVD). All my other programs which output audio still work fine.

      In the Preferences screen, in the Audio Hardware section the default device is "Premiere Elements Windows Sound". Clicking the ASIO Settings... button in this screen opens a DirectSound Full Duplex Setup dialog; the top section of this (DirectSound Output Ports) under Device Name shows only "No Audio Device". There is no facility in this screen to change or add another device.

      Similarly, in the Preferences screen, in the Audio Output Mapping section, the Map Output for: "Premiere Elements Windows Sound" shows No Audio Device - 1 and No Audio Device - 2. Again, there is no facility to add or change audio devices.

      The PE4 Help file has nothing on this topic. The PE4 User Guide (.pdf file downloaded from http://help.adobe.com/en_US/PremiereElements/4.0/premiereelements_4_help.pdf) has nothing on this topic. Indeed, neither the Help file (local or on-line) nor the 300+ page .pdf file have any mention of the preferences dialog at all!!!

      I've done a repair of PE4 - nothing changed. I've completely removed and re-installed PE4 - still nothing changed.

      How can I get audio output from PE4? And why is it so hard to find this out?

      Rob
        • 1. Re: PE4 - No audio
          Paul_LS Level 4
          Sounds like your Realtek AC97 Audio device has disappeared. This is what is normally selected in the places where you have No Audio Device 1 and No Audio Device 2.

          If you go into "Device Manager", then "Sound, video and game controllers" do you see "Realtek AC97 Audio"? Have you tried updating your audio drivers?
          • 2. Re: PE4 - No audio

            Sorry about the delay getting back - other projects got in the way.

             

            Device Manager shows Realtek Audio, and reports it is working correctly; drivers are latest version (and I've re-installed just for good measure).  The only place the Realtek Audio device has disappeared from is PE4 - as I said in my original post, sound works fine in every other application.

             

            Any other suggestions?

             

            Rob

            • 3. Re: PE4 - No audio
              Steve Grisetti Adobe Community Professional

              Go to Edit/Preferences/Audio Hardware and then enter your ASIO settings.

               

              Check to make sure all is right there.

              • 4. Re: PE4 - No audio
                Level 1

                Thanks for the suggestion, Steve. I've been there before - as I said in my original post.

                 

                Edit - Preferences - ASIO Settings opens a dialog box, with two sections: DirectSound Output Ports and DirectSound Input Ports.  In the Output section, there is an entry which reads "No Audio Device", followed by several settings.  There are buttons to change the Port Order (rather pointless when there is only one port). I can double-click this text and change it, but that has no effect; and if I do that, exit the program, and restart it, the entry has reverted to "No Audio Device".  It seems there is no way in which I can add or select another device in this dialog.  And that, I guess, is the essence of my problem.  Why does PE4 - even when removed and re-installed - fail to recognise the audio device which everything else on my system does recognise and use perfectly well?

                 

                I'm willing to try even direct editing of Registry settings, if that's what this will take to get it to work.  Is that a possibility?  If so, does anyone know the keys and entries I should check?

                 

                Exceedingly frustrated,

                 

                Rob

                • 5. Re: PE4 - No audio
                  Steve Grisetti Adobe Community Professional

                  I still say that if things used to work but suddenly don't, it's related to either a update or a new program that you've installed.

                   

                  Have you installed other media programs recently that may have disrupted things? Creative Cow reports people having problems with Premiere after installing other CS3 and CS4 programs.

                   

                  I don't know if this will be helpful. Most of it is what we've already been over.

                  http://kb.adobe.com/selfservice/viewContent.do?externalId=kb407927&sliceId=2

                  • 6. Re: PE4 - No audio
                    Level 1

                    I agree with your overall assessment.

                     

                    My problem is, I'm not aware of anything that I've updated or installed since I last used PE4.  And even if I had done that, why wouldn't my latest removal/re-install (certainly after any new/updated program installations, and including a repair operation of PE4 which I tried today -in desparation, and it had no effect) have taken any new/updated programs into account?  And (for completeness in response to your suggestion) I don't have any other CS3 or CS4 programs installed.

                     

                    I've looked at the link you provided, but (as you say) it only covers ground I've already been to.  In that link, my problem is the first situation described "Sound in missing from all clips".  Nothing there helps.

                     

                    What now?

                     

                    Rob

                    • 7. Re: PE4 - No audio
                      Steve Grisetti Adobe Community Professional

                      Sorry, Rob. I'm tapped.

                       

                      If you've installed Secunia and updated everything, uninstalled and reinstalled the software and even changed the ASIO and the playback settings, I'm out of ideas.

                       

                      I hope someone else can maybe offer more guidance.

                      • 8. Re: PE4 - No audio
                        the_wine_snob Level 9

                        I've been following this thread, and agree with all of Steve's comments, though they are not getting you what you had, and what you want.

                         

                        I am concerned that PE does not "see" your Realtek HD Audio Output/Input. Something is blocking that.

                         

                        Under my Preferences>Audio Hardware>ASIO settings, I get Realtek HD Audio, Bluetooth AV Audio and Bluetooth SCO Audio (in both Input & Output). I have Realteck checked in both, with the radio-button (DirectSound Input) selected, and Full Duplex checked.

                         

                        The Realtek drivers include ASIO info for programs, that use them. Let's try a test. Download and install ASIO4All. When done, reboot, and launch PE. You *should* now see ASIO4All listed in the Preferences>Audio Hardware>ASIO settings. Try going through this. Test your Audio in PE. There are also FAQ's on the site that I listed. Maybe a good read through those will yield something.

                         

                        As for the uninstallation of the other program ( was it Roxio?), many times hardware can be "hooked" by other software, and just the removal (Add/Remove Programs) will not correct the Registry. You might also run a registry cleaner, like CCleaner, just to make sure that there are no residual entries in the Registry, that were not remvoed.

                         

                        Good luck, and please report on any change in the Audio in PE.

                         

                        Hunt

                        • 9. Re: PE4 - No audio
                          Level 1

                          Thanks Hunt,

                           

                          ASIO4All has done the trick!  After downloading, installing and rebooting, I simply changed the Default Device in the Preferences - Audio Hardware from "Premiere Elements Windows Sound" to "ASIO4ALL v2" and everything now works.  The ASIO Settings button then opens an ASIO4ALL v2.9 dialog box (rather than the previous PE4 one) which shows a single device, Realtek High Definition Audio, in the WDM Device List; it is set to a buffer size of 512 samples.  There is a button for Advanced Options, but I have needed to touch anything there (and generally my philosophy is "if it ain't broke, don't fix it").

                           

                          Eternally grateful,

                           

                          Rob

                          • 10. Re: PE4 - No audio
                            the_wine_snob Level 9

                            Rob,

                             

                            Great news! It has been a wonderful little .dll for many. A lot of folk on the Audition forum have solved all sorts of issues with it.

                             

                            Though I do not need it for my PrPro workstation, I went ahead and installed it anyway, so any Windows update that trashes my Realtek driver, doesn't shut me down. I have plenty of Audio, until I can update the driver.

                             

                            Also, thanks for reporting back, as it might well help someone else in the future - that's part of what these fora are for.

                             

                            Hunt

                            • 11. Re: PE4 - No audio
                              Steve Grisetti Adobe Community Professional

                              Wow! Great find, Hunt!

                               

                              Glad you're up and running, Rob!

                              • 12. Re: PE4 - No audio
                                Level 1

                                I agree, Steve.  Your efforts were appreciated, but Hunt got the cigar

                                 

                                Rob