2 Replies Latest reply on Sep 3, 2008 6:54 AM by Gregory Lafrance

    Really Weird Build Issue...

    jamespenney
      Hi there,

      I have been studying Flex 3 for about 2 or 3 weeks now so forgive me if I am missing a big picture here!

      I have been working hard to create an app that uses a SQL db. It all works fine when 'previewing' (i.e. Running the AIR app within Flex 3 Builder), it is able to connect to the database etc... but it does not work if I export a release build and install it!

      I am doing the Dev work on my MacBook (Core2Duo). The weird bit is, that the .AIR installs and runs perfectly fine on my Dell machine running Win XP??? But does not work in my Win XP environment in VMWare Fusion??!?!!?

      When I say it 'does not work' I mean, it never seems to establish a connection with the Database that it should connect to.

      Does anyone have any thoughts on this? Any help would be greatly appreciated!

      Best regards,
      James
        • 1. Re: Really Weird Build Issue...
          Level 7

          "jamespenney" <webforumsuser@macromedia.com> wrote in message
          news:g9hatv$re7$1@forums.macromedia.com...
          > Hi there,
          >
          > I have been studying Flex 3 for about 2 or 3 weeks now so forgive me if I
          > am
          > missing a big picture here!
          >
          > I have been working hard to create an app that uses a SQL db. It all works
          > fine when 'previewing' (i.e. Running the AIR app within Flex 3 Builder),
          > it is
          > able to connect to the database etc... but it does not work if I export a
          > release build and install it!

          Do you mean a mySQL database, a sqlLite database, or a SQL Server database?
          The vast majority of databases use sql, but AFAIK, there is no one database
          known as a SQL database. When most people say a SQL db they mean a SQL
          Server DB, but I don't think you can establish a direct connection to that
          from AIR without using any back-end technology.

          > I am doing the Dev work on my MacBook (Core2Duo). The weird bit is, that
          > the
          > .AIR installs and runs perfectly fine on my Dell machine running Win XP???
          > But
          > does not work in my Win XP environment in VMWare Fusion??!?!!?
          >
          > When I say it 'does not work' I mean, it never seems to establish a
          > connection
          > with the Database that it should connect to.

          What code are you using?


          • 2. Re: Really Weird Build Issue...
            Gregory Lafrance Level 6
            Sounds like its related to the fact that you are using VMWare. Maybe there are additional restrictions or hoops to jump through when using VMWare.