12 Replies Latest reply: Jan 26, 2009 9:19 PM by pwillener RSS

    Cannot uninstall Adobe Reader 7.0.8...keep getting "Error 1402" message..

    Community Member
      Hello. I use Windows XP Home Edition. I am trying to uninstall Adobe Reader 7.0.8 so I can then install version 9, but I am not able to uninstall 7.0.8. During the uninstallation process, I get the following error message:

      *****Error 1402. Could not open key HKEY_LOCAL_MACHINE\Software\Classes\CLSID\{C523F39 F-9C83-11D3-9094-00104BD0D535}\Programmable.

      Verify that you have sufficient access to that key, or contact your support personnel.*****

      I went to another forum and asked for some help there...the guy there gave me some steps to follow, and I did so. Here they are:

      1. Deleted "Adobe Reader Speed Launch" shortcut from Startup folder.

      2. Deleted the Adobe folder (which contained 2 other folders: Acrobat 6.0 and Acrobat 7.0) from C:\My Computer\Local Disk\Program Files. I had to use a separate program (provided by my helper who gave me these steps to follow) called "Unlocker" to accomplish this, since, originally, when I tried to delete this Adobe folder, I would get a message saying "Cannot delete pdfshell.dll: Access is denied. Make sure the disk is not full or write-protected and that the file is not currently in use." Unlocker solved this problem, and was able to delete the Adobe folder.

      3. Rebooted machine

      4. Ran CCleaner's registry cleaner

      5. Rebooted machine again

      6. Tried using CCleaner's "Uninstall" utility to uninstall Adobe Reader 7.0.8. When I tried this, I got the same "Error 1402" message as listed above.

      7. Backed-up my registry

      8. Tried to just delete this particular offending key using RegEdit...but when I tried, I got a message saying this:

      *****ERROR DELETING KEY
      Cannot delete Programmable: Error while deleting key.*****

      I really need some assistance with this...at the moment, Adobe Reader 7.0.8 still seems to be installed on my machine (it's still listed in "Add/Remove Programs" in the Control Panel, and it still shows up in CCleaner's Uninstall Utility)...despite the fact that, as I mentioned above, I used Unlocker to delete the Adobe folder from Program Files. Also, at this moment, no pdf files will open on my machine...so this is quite an urgent situation. Does anyone know what else I should do now? Is there something I need to do regarding the "Permissions" for this particular registry key?

      I appreciate anyone's assistance...thanks.