23 Replies Latest reply on Jan 8, 2011 4:45 PM by Elizabeth Vongola

    Problem installing 9.0 and 9.1

    Level 1
      I delete Adobe Reader 8.0 to install Adobe Reader 9.0. However I was unsuccessful in installing Adobe Reader. Everytime I tried to install Adobe Reader 9, I get this message. "Error 1406:could not write value installed to key\software\microsoft\windows\currentVersion\Run\Optionalcomponents\MSFS".

      I have tried everything, even follow others advise to go inthe registry and do something but still unsuccessful. Please advised
        • 1. Re: Problem installing 9.0 and 9.1
          pwillener Level 8
          > I delete Adobe Reader 8.0

          Never delete software; always uninstall it from Add/Remove Programs. Installing a newer version of Adobe Reader will automatically uninstall previous versions.

          To repair your mistake, download and install the Windows Installer Cleanup Utility, then run it and remove everything related to Adobe Reader 8.
          • 2. Re: Problem installing 9.0 and 9.1
            Level 1
            Hello Sir.Thank you for your prompt response.I did remove the software from the control panel.However,I should have known better not to uninstall it until I successfully install a new version.

            Anyway,I did what you instructed me to do.I'm still unsuccessful.Any further advise/recommendation?

            Thank you again for you assistance.
            • 3. Re: Problem installing 9.0 and 9.1
              pwillener Level 8
              Installing 9.x will automatically remove earlier versions of Adobe Reader, so you don't have to worry about it.

              About the error message you are getting - can you check the permissions of that registry key?
              • 4. Re: Problem installing 9.0 and 9.1
                Level 1
                Hi Folks,

                Interesting thread that I would like to add to it. I have three problems:

                Tried to install Reader 9.1 and got "network resource not available..." I searched my entire drive for .msp filetype, found zero such files. Hit 'cancel' on the error message and the installation proceeded and said 'completed succesfully.'

                Despite this, Reader v.7.0.5 is still on my hard-drive. I did 'uninstall' from add/delete software but got the same error message about the missing .msp file and therefore cannot uninstall. So, installing v. 9.1 did not remove previous versions.

                Now, I see on add/remove software that Reader v9.1 is 222 MB!!!!! Yikes! At the download page, it said it was only 41.9 MB. Is it really that big?

                I will try the Windows Installer Cleanup Utility, but would appreciate any insight, advice, commiseration... :)

                Thanks.

                --Maria
                • 5. Re: Problem installing 9.0 and 9.1
                  pwillener Level 8
                  > Is it really that big?

                  On my Windows XP it is only 205MB (English version).
                  • 6. Re: Problem installing 9.0 and 9.1
                    Level 1
                    I have the same problem trying to install Reader 9.1, uninstall 8 and I also had removed all entries with the Windows Install Clean up continues outgoing me the same error and pulls back the installation. Unable to open key HKEY_LOCAL_MACHINE32\SOFTWARE\Microsoft\Windows\CurrentVersion\Run\OptionalComponents\MSF S
                    That key does not exist as you can give access rights ... also the route is not HKEY_LOCAL_MACHINE32 is HKEY_LOCAL_MACHINE

                    I apologize for my English translator :-)
                    • 7. Re: Problem installing 9.0 and 9.1
                      pwillener Level 8
                      > I have the same problem...

                      No, this is a totally different problem; please start a new thread for a new problem.
                      • 8. Re: Problem installing 9.0 and 9.1
                        Level 1
                        I agree.
                        I open new thread: "I can not install Adobe Reader 9.1"
                        Thanks.
                        • 9. Re: Problem installing 9.0 and 9.1
                          Level 1
                          Sorry my pc got messed up after downloading the window uninstall utility cleaner.

                          Anyway,not sure what you mean by checking the permission of the registry. The message I got was exactly the same as aef_aef posted above.Message says "error 1402.\SOFTWARE\Microsoft\Windows\CurrentVersion\Run\OptionalComponents\MSFS".

                          Thanx again for your help.
                          • 10. Re: Problem installing 9.0 and 9.1
                            Level 1
                            Thanks Mxz Elz seemed to me that was the same. However it also opened the other thread.
                            Let's see if someone can guide us a little about the solution, I would not like having to install another browser.
                            • 11. Re: Problem installing 9.0 and 9.1
                              Level 1
                              aef_aef

                              I have successfully re-installed Adobe Reader on my pc.I used a powerful software to cleaned up all Adobe Reader files on my pc. Softawre is call WinCleaner.You can either buy it from a store(more safe) or downloaded from online.

                              Others recommended downloading Window Installer Cleanup Utility which okay but be careful.I downloaded this software and my pc just got messed up big time.

                              take care.
                              • 12. Re: Problem installing 9.0 and 9.1
                                Level 1
                                Thanks Mxz Elz, but I have not succeeded yet.
                                WinCleaner I tried, I tried the Windows Installer Cleanup Utility and the result is that I keep getting the same error: \SOFTWARE\Microsoft\Windows\CurrentVersion\Run\OptionalComponents\MSFS
                                That key does not exist as you can give access rights ...
                                I am a little tired of this problem
                                • 13. Re: Problem installing 9.0 and 9.1
                                  pwillener Level 8
                                  OK, let's try that one more time.

                                  Do you know how to use the registry editor? If so, open it and navigate to key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run\OptionalComponents; right-click on MSFS and select Permissions - what do you see for your userid? Make sure that you have Full Control.

                                  BEFORE you make any modifications to the registry, backup your registry. A safe and simple utility for registry backups is ERUNT.
                                  • 14. Re: Problem installing 9.0 and 9.1
                                    Level 1
                                    If your using Windows Vista, ensure you've got Administrator privilages. That could be preventing the program from installing properly. It's also possible the registry is locked by another program. The most common culprits are misbehaving anti-virus programs.
                                    • 15. Re: Problem installing 9.0 and 9.1
                                      Level 1
                                      Thanks Pat Willene and thanks Calvin Jefferson for contributing ideas.
                                      The key does not exist in the registry, I have imported from another PC was that even if and I have full privileges to all users although we always try to install it as administrator. I have also tried to disable the antivirus. The fact is that the error persists.
                                      Is desperate. :-(
                                      • 16. Re: Problem installing 9.0 and 9.1
                                        Level 1
                                        Are you certain that the registry error does not change to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run\OptionalComponents\MAPI and then to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run\OptionalComponents\IMAIL ?

                                        I had the same problem trying to uninstall 9.1, and finally I succeded. If you do not have this, you can import them or make them yourself (do not know if that is clever, but it worked for me with the MSFS registry - value 0000 00 00). Unfortunately I cannot give you the values as I did uninstall it and I do not intend to reinstall it :)

                                        Good luck!

                                        Rune
                                        • 17. Re: Problem installing 9.0 and 9.1
                                          Level 1
                                          Thanks Rune K. Andersen for the contribution. If I tried again to say that regardless of the keys to another computer and giving them any rights, including the values they put zero commented. The result of all these attempts is again the same message. Sure the error is something on my computer but it seems incredible that Adobe does not provide us with the solution or the cause of the problem.
                                          • 18. Re: Problem installing 9.0 and 9.1
                                            Biker38 Level 1
                                            I'm running Reader 9.0 with XP Pro and IE 8. In trying to install 9.1 I get the Error 1402 message. Right-clicking on MSFS appears to indicate that I have Administrator rights. All suggestions would be appreciated. Thanks.
                                            • 19. Re: Problem installing 9.0 and 9.1
                                              bmasure Level 1

                                              Hello,

                                               

                                              I've got the same errors on a Windows Vista Edtion Familiale Premium [a French one!] and I succeeded in resolving this.


                                              This is my story:

                                              No error Code, just a regestry key than I cannot write:
                                              "\HKEY_LOCAL_MACHINE\SOFWTARE\Microsoft\Windows\CurrentVersion\Run\OptionalComponents\MSFS "

                                              [I am log on a default user]

                                               

                                              >>> Go to the registry location "[WIN]+R\regedit"
                                              Nothing in there. The Folder(s) \MSFS\ (,\MAPI\ and \IMAIL\) do(es) exist.


                                              >>> RMB on the higher folder "\OptionalComponents\ Right

                                              I cannot give any rights to this folder...

                                              Great, need to active the admin user hidden in vista

                                               

                                              >>> Go to Start\Accessory\Command Manager
                                              >>> RMB \Execute as an administror
                                              in the cmd dialog box,

                                              >>> Type: "net user administrator /active:yes"
                                              >>> Type:"net user administrator <password>"

                                               

                                              >>> Log off the default user
                                              >>> Log on as an administrator

                                               

                                              >>> Go in regestry key once again,

                                              >>> Set up the folder for all user with full rights

                                              Ok so everything should be allright now? No,no, no nOoo, Mister Hell! That's not f**ing damn finished! [French guys love swearing in

                                              any languages!]
                                              For sure, I kept this bloody chicking message:
                                              "Blablabla! ... blabla &#!°% \HKEY_LOCAL_MACHINE\SOFWTARE\Microsoft\Windows\CurrentVersion\Run\OptionalComponents\MSFS

                                              That key does not exist as you can give access rights!!!"

                                               

                                              Great! So I'm logged on as the administrator and still have no rights to have any access rights?! So can you tell me Who can, bloody

                                              you?


                                              My clever BitDefender does!
                                              >>> Desactivate your stuff [Notorn, Node32,etc.] and your installation should be on the track again! If not, complete this story.

                                               

                                              For me that's done I can read PDF document! Youhou, my boss will be happy! Damn!

                                               

                                              Just to be as the start, you can switch off the access for the administrator as previously:
                                              >>> Go to accessory Command Manager
                                              >>> RMB \Execute as an administror
                                              in the cmd dialog box,

                                              >>> Type: "net user administrator /active:no"

                                               

                                              Have a nice day

                                              \bmasure

                                              • 20. Re: Problem installing 9.0 and 9.1
                                                Steve Medley Level 1

                                                This "HKEY_LOCAL_MACHINE\software\Microsoft\Windows\CurrentVersion\Run\OptionalComponents\MSFS " issue is still at large without a viable solution. A computer that I am troubleshooting after the owner downloaded several redundant and useless registry fixers and toolbars -which I uninstalled -had PDF files associated with a program called TaxCut.

                                                 

                                                Changing the file association in Folder Options would not help as TaxCut kept its association. Running Microsoft's Essentials AV and malware program found none so I believe that the damage to the registry remains though an Adobe_com.exe keeps being created. Any attempt to install Adobe Reader, whether from a CD or download, results in error 1406 with the aforementioned registry key. Using the Find function in Regedit I searched to no avail for "HKEY_LOCAL_MACHINE\software\Microsoft\Windows\CurrentVersion\Run\OptionalComponents\MSFS ".

                                                 

                                                This problem is listed in many forums without a solution or even a relevant path to a solution. My best solution (as a hardware technician) will be to format and reinstall Windows. I do that for myself once or twice a year as "OS decay" has been a problem since the creation of the registry.

                                                 

                                                respectfully,

                                                 

                                                Steve Medley

                                                San Diego, California

                                                • 21. Re: Problem installing 9.0 and 9.1
                                                  Berdman21 Level 1

                                                  I had the same problem and can finally say i solved it.

                                                   

                                                  The problem is that the error calls for "HKEY_LOCAL_MACHINE32" Which does not exist. The string in the registry that redirects to this is as follows:

                                                   

                                                  HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node

                                                   

                                                  Once you get to this directory you just go to whatever string it called for follwing the HKEY_LOCAL_MACHINE32.

                                                   

                                                  If you get to the currentversion\run\optionalcomponents and the subdirectories \MSFS,\MAPI\ and \IMAIL do not show, right click on optional components and add a new key. They will then show up and you can change the permissions.

                                                   

                                                  Hope this helps.

                                                  • 23. Re: Problem installing 9.0 and 9.1
                                                    Elizabeth Vongola Level 1

                                                    yes it work for me the solution gave by Berdman21...thanks...

                                                     

                                                    i have error message when trying to update adobe and i follow his post

                                                     

                                                    If you get to the currentversion\run\optionalcomponents and the  subdirectories \MSFS,\MAPI\ and \IMAIL do not show, right click on  optional components and add a new key. They will then show up and you  can change the permissions.

                                                     

                                                    then i try to reinstall again..

                                                     

                                                    horay!! its works for me