1 Reply Latest reply on Mar 16, 2009 7:38 PM by pwillener

    AR 9.X Crashing IE (6 and 7)  when opening PDF with sw:iexplore - Application Error

      The majority of my systems are having a problem with Acrobat Reader 9.0 and 9.1.

      When they click on a PDF from within IE the browser crashes with the following error:
      sw: iexplore.exe - Application Error
      The instruction at '0x051251b6" referenced memory at '0x00000010". The memory could not be "read".

      Running AR 8 causes no difficulty, however I have an organizational requirement to have addressed the in-the-wild vulnerability of AR by March 18th for 100% of my client systems. And Adobe is holding on to those versions until the 18th.

      So I _have_ to install 9.1 on 300 systems in the next 36 hours.

      If I take the check mark out of 'Display PDF in Browser' it works fine. The problem with this solution is that there are certain web sites and applications that departments here use which absolutely requires that the PDF be integrated within the browser - so taking Display PDF in Browser is not a universal solution.

      I have tried the following key to no luck:
      [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\SOFTWARE\Adobe\Acrobat\Exe]
      @="\"C:\\Program Files\\Adobe\\Reader 9.0\\Reader\\AcroRd32.exe\""

      On a couple of machines opening up Reader and closing it first while having admin rights clears up the problem - but not for the majority of my systems.

      I've tried repairs, reinstalls, full reloads and reboots to very little luck.

      It's is for various PDF files from different sites, and it's the same ones that work for the small number of systems not experiencing a problem.

      Any suggestions would be welcome.