4 Replies Latest reply on Dec 19, 2011 11:58 AM by Ken Dyall

    The root object is missing or invalid

    Level 1
      I'm trying to open a .pdf file at a website and get the following message... The root object is missing or invalid.

      I'm using Adobe Reader 9.1.0. Does anyone know what the fix is to this? Thank you.
      The url I went to is:
      http://www.doityourselfbankruptcyforms.com/B4%20List%20of%20Creditors%20in%2020.pdf
        • 1. Re: The root object is missing or invalid
          Bernd Alheit Adobe Community Professional & MVP
          This file is damaged. Inform the publisher of this document.
          • 2. Re: The root object is missing or invalid
            Ken Dyall Level 1

            I have been experiencing the same problem, opening a PDF file from a local HTML page. The PDF file can be opened directly in Adobe Reader, so it is not damaged. The problem appears when the PDF file is opened from a link in an HTML document. Following the error message is what appears to be a path: Local\<some string>, where <some string> is an apparently random collection of characters. In other circumstances (a different version of our software), I get the message "The file is damaged and could not be repaired" followed by a similar path. The error occurs when opening any of our PDF files from a link in the HTML documents. The PDF files can be opened successfully when opened directly, or when opened via a link from some other PDF file. My OS is Windows XP SP3, 32-bit machine. I am using Adobe Acrobat Pro 10.1.1; I've tried Firefox 3.6.18 and Internet Explorer 8.0.6001.17602 My colleagues are using a variety of other machines (Vista, 7) with Adobe Reader.

             

            It sounds to me like the failure occurs when trying to read the temporary downloaded version of the PDF file. The source file itself is not damaged, because I can open it in Reader/Acrobat but the copy that Reader or Acrobat is trying to open appears to be damaged. Given that the same error occurs with IE as with Firefox, I'm doubtful that the problem is the browser. Any information would be appreciated.

             

            Ken Dyall.

            • 3. Re: The root object is missing or invalid
              shasunder Level 1

              I too have the same issue. But it opens well in Chrome and IE 8. But when I open in FF 8.0.1 I get the message"The root object is missing or invalid". Any help would be appreciated on this.

              • 4. Re: The root object is missing or invalid
                Ken Dyall Level 1

                We found the cause of our particular problem. The web server we were using (a lightweight Python-based server) was trying to open it as a text file rather than as a binary file. This caused the temporary local copy to be truncated, and resulted in the error message.