5 Replies Latest reply on May 30, 2011 6:59 AM by Jeff_Coatsworth

    Bughunter is not responding

    Glahe
      I installed RoboHelp 7.02.001 for HTML on a "clean" machine (reformatted yesterday) that is running Windows XP with Service Pack 3. (I had also installed Microsoft Office 2003 and Acrobat 6 Professional, and all updates, before installing RoboHelp.)

      I opened my project in RoboHelp, and enabled the Bughunter pod.
      The Bughunter appeared in its usual pane, displaying "BugHunter Enabled...".
      Then, I invoked help from the program I am documenting.
      The program displayed the help file, but the Bughunter did not capture any information about the call.

      Before the reformat, the Bughunter was working fine.

      What should I do to get the Bughunter to notice the calls?
        • 1. Re: Bughunter is not responding
          RHGrace

          I could not find a response to this topic, and I have a similar problem. I've used RH7 to convert a Help project from WinHelp to HTML Help. BugHunter worked fine for the WinHelp project. I have now enabled it, and the Test HTML Help API function seems to work fine. However, when I open the application and call up CSH, the Help topics appear but the Output View shows no details about the call. Any ideas?

           

          Lacona

          • 2. Re: Bughunter is not responding
            EileenPalsson Level 1

            I am having exactly the same problem -- but with RH8.0.2 on Windows 7 (32 bits).

             

            I did not having this problem before I switched to Windows 7. On Windows XP the exact same thing worked fine.

             

            I can't find any solutions posted anywhere. Did you two ever manage to find a solution? If so, what was it?

             

            Thanks!

            Eileen

            • 3. Re: Bughunter is not responding
              EileenPalsson Level 1

              Hello again. I got the solution (at least one that worked on my PC): Launch HHW.exe (HTML Help Workshop). Then close it. Launching Html Help Workshop once is necessary for Bughunter to work. (Wouldn't it be nice if Adobe told us that or mentioned it in the related help topics?)

               

              If this does not work for you, try these complete instructions that I got from Adobe (with my additions):

               

              1.       Go to url http://www.microsoft.com/downloads/en/details.aspx?familyid=00535334-c8a6-452f-9aa0-d597d1 6580cc&displaylang=en

              2.       Download HtmlHelp.exe (3.3 MB). If you see a message that the dowloaded has been reported as unsafe. Ignore this and download anyway.

              3.       Double click Htmlhelp.exe to install it to default install location C:\Program Files\HTML Help Workshop. If Windows doesn't let you run the installation because it's supposedly unsafe, then use Windows Explorer to go to the download location. Now right-click the file and select "Run anyway." Continue all the steps though it say that Html help is already installed.

              4.       After Html Help workshop is installed successfully, close all the running instances of RoboHelp.

              5.       Now go to the Html Help workshop install folder (i.e. C:\Program Files\HTML Help Workshop or C:\Program Files (x86)\HTML Help Workshop).

              6.       Double click hhw.exe to launch Html Help workshop.

              7.       Close Html Help workshop application. Launching Html Help Workshop once is necessary for Bughunter to work.

              8.       Now launch RoboHelp

              9.       Go to SSL pod and and set Microsoft Html Help as the primary layout.

              10.   Click “View->Pods->Bug Hunter” menu item to open Bughunter pod. Right click in the pod and enable bug Hunter. Check that bug hunter is enabled is specified in the pod.

              11.   Now call any HtmlHelp Api, it should show the mapid and other information in the bughunter pod.

               

              FYI, I am running RH8.0.2 on a Windows 7 (32-bit) machine, and the above instructions worked for me.

               

              Hope this saves someone else the hours of troubleshooting I spent looking for the solution to this problem.

               

              /Eileen

               

              • 4. Re: Bughunter is not responding
                RHGrace Level 1

                Sorry you had to discover this on your own. I think the solution I found was

                to load a free similar program from Microsoft to be used with the Microsoft

                Help builder. Somehow, that "woke up" the RoboHelp BugHunter, and it seemed

                to work fine after that.

                 

                I hope to remember your solution if I have this problem in the future.

                 

                Lacona

                • 5. Re: Bughunter is not responding
                  Jeff_Coatsworth Adobe Community Professional & MVP

                  Why don't you add it to the Community Help so that it gets included in the next releases?