7 Replies Latest reply on Feb 20, 2018 3:59 AM by pravinninawe

    Negative/Inverse/Reverse color

    Level 1
      I always think of a nice feature all reader programs should have: an option to reverse the output onscreen.

      Normally our documents are black text over white background, mimicing the way we are used to in paper documents. PDF is a really nice format because we can have carefully laid out document in digital format.

      But think about it: to read a book on screen is like staring at a bulb. It would be nice to read white texts over black background.

      But one should not expect for a PDF to be produced this way (anyway, printed media should be black over white). This support must come from the reader program: just reverse the client area (page) where the text is rendered.

      For a glimpse of the result, one can issue the following command under X:

      xcalib -i -a

      The whole X screen will be reversed. I'd like to see this implemented directly in acrobat reader, with a handy shortcut to switch back and forth quickly.
        • 1. Re: Negative/Inverse/Reverse color
          nseth Level 1
          There is a preference to do exactly that - replace the document's foreground and background colors. You can find it under Edit->Preferences->Accessibility->Replace Document Colors. The foreground and background colors that one wishes to be used can be specified here.

          Hope that helps!
          2 people found this helpful
          • 2. Re: Negative/Inverse/Reverse color
            Level 1
            Sure it helps.

            By the time I've file this bug entry I did already seen this option, but were concerned about text written in other colors. What I missed that time was the "Only change the color of black text or line art" option.

            Actually I am still concerned. Think about gray-almost-black-but-still-gray text. Over white background it will look nice. Over black background, since it isn't black text, well, I don't know how Acrobat Reader will behave.
            • 3. Re: Negative/Inverse/Reverse color
              johns43590502 Level 1



              I'm using this "Replace Document Colors" function and it is great.


              However there is a tiny annoying bug about it.


              On some documents I have scanned pages with pdf lines drawn on it.


              The scanned image itself, doesn't change color, only its background.


              Because the images have a transparent background, the black background comes through and I get black on black text.


              To detect this, I made my background color slightly brighter (26,26,26) than pure black. So at least I can see the image outline.


              When that happens I have to go to all the way to  Edit->Preferences->Accessibility->Replace Document Colors to disable the function. That is a lot of steps to performs 3-4 times per day !


              Could it be possible to add a keyboard shortcut to turn this function on and off ? (and better yet, could there be a function to force all non-white pixels (including alpha 0 pixels) to turn to the text color ?)



              • 4. Re: Negative/Inverse/Reverse color
                Lon Winters Level 4

                This Preference/Option does not work at all for scanned documents. I've tested documents scanned from two difference scanners, both into Acrobat. Documents created from Words files or other files in that manner work fine. I think I may have posted a thread on this myself a while ago, but there has been no solution presented thus far. I hope someone is still watching this thread as it is several months old and can possibly help.


                My workaround is to scan directly into Photoshop and then invert the colors there. But that created a rasterized image with no ability to edit the text or any of the elements.

                • 5. Re: Negative/Inverse/Reverse color
                  xinyiyeo Level 1


                  Many had suggested using the **Edit->Preference->Accessibility** method but sadly it did not work for me.

                  After testing and playing around PDF setting, I managed to get what I wanted!


                  - Go to **Print** (<kpd>Ctrl</kpd> + <kpd>P</kpd>)

                  - Click **Advanced Settings**

                  - Check **Settings:** Custom

                  - Click on **Output** from left panel

                  - Under **Color:** select **Composite Gray**

                  - Check the **Negate** box

                  - Click **OK**



                  This should do the trick! <br/><br>

                  **Important Note!**<br>

                  I would suggest printing this file to a PDF than directly. Especially if you intend to print multiple pages in one page as it will result in the whitespace turning black too!



                  Lastly, if you are going to print the document as another PDF, under **Page Sizing & Handling** , click on **Fit** and check both the boxes - "**Choose paper size when needed**" and **Use custom paper size when needed**.

                  (To avoid unwanted whitespace)



                  Hope this help!