4 Replies Latest reply on Oct 28, 2008 1:15 PM by Mylenium

    Not Supported on this Architecture

      I'm getting the message "You can't open the application 'Adobe After Effects' because it is not supported on this architecture." when trying to use AE CS4 on a year and a half old Macbook Pro. I know my computer has all the necessary requirements so whats the issue here?

      I'm running OS X 10.5.5 and I have the GeForce 8600M GT card running a 24" apple display through a Matrox MXO. My first thought was that the MXO was causing problems, but I unplugged the external monitor and restarted and it was still giving the same problem.
        • 1. Re: Not Supported on this Architecture
          Mylenium Most Valuable Participant
          Have you tried with the external monitor unplugged? Quite possible that AE somehow misinterprets your monitor settings because of it. Also run Apple Software Update again. I recommend you do so by manually tricking it into scanning for all updates again. you can do this by deleting the update cache which should be under Users:Alan:Library:Caches somewhere. Thereafter running software update will scan for all potentially missing snippets. it will take longer, but is guaranteed to not miss anything. You may also use tools like OnyX to check this and other things. Maybe you simply ended up with bad config data some time after a crash or so. Repairing the disk and cleaning out the caches also helps in such situations.

          Mylenium
          • 2. Re: Not Supported on this Architecture
            Andrew Yoole MVP & Adobe Community Professional
            I've experienced this issue on a number of Macs - never with AE, but I've seen it with CS3 Premiere, SoundBooth and Illustrator on different occasions.

            The only thing that worked for me was a total uninstall, including running the Adobe CleanScript, then a full reinstall. In the case of a recently-purchased MacBook Pro, I never resolved the problem, despite multiple high-level assessments from Adobe Tech Support. Eventually I gave up, and decided to wait for CS4 - I'll tell you how it went next week! :-)
            • 3. Re: Not Supported on this Architecture
              Level 1
              Ok, so uninstalling and reinstalling without an external monitor plugged in worked to actually install the programs. (It seems that before even though the installer app said it was going to install the programs, it only installed certain elements and not the actual program, which was the problem) And now Encore and Premiere work, but After Effects will quit out immediately. I get this error code in the console.

              10/28/08 1:08:20 PM [0x0-0x2e02e].com.adobe.AfterEffects[761] /System/Library/Frameworks/Carbon.framework/Versions/A/Support/LaunchCFMApp[761] Launch failed with error code -2857 (cfragCFragRsrcErr) for application /Applications/Adobe After Effects CS4/Adobe After Effects CS4.app/Contents/MacOS/After Effects
              10/28/08 1:08:20 PM com.apple.launchd[108] ([0x0-0x2e02e].com.adobe.AfterEffects[761]) Exited with exit code: 215

              I went so far as to uninstall my Matrox MXO drivers from the system and I still get the same thing.
              • 4. Re: Not Supported on this Architecture
                Mylenium Most Valuable Participant
                Try removing the OpenGL plugin, maybe this helps. However, the graphics are perfectly sufficient for CS4's requirements (I have the same MacBook), so something is definitely up...

                Mylenium