10 Replies Latest reply on Mar 17, 2009 10:09 PM by (latino_heat)

    CS4 - OpenGL warning when disabled?

    lchapman66 Level 1
      I have an AE CS4 project that gives me this warning on start-up:

      "After Effects Warning: A problem occurred when processing OpenGL commands"

      Thing is . . . I have the use of OpenGL disabled in the preview preferences because I was getting hard crashes related to OpenGL while developing the project.

      I'm using an Nvidia Quadro FX 570 and have updated to the most recent driver.

      Thoughts?
        • 1. Re: CS4 - OpenGL warning when disabled?
          Mylenium Most Valuable Participant
          It's PixelBender, most likely. Unfortunately there's no way to fully disable it, as it's a DLL, not a plugin and AE will frown if you remove it. It's actually a design limitation (or bug, if you will). If you are not using any PB filters, I wouldn't worry. You can just confirm the warning without fear of any problems. You might also want to update your graphics driver or change its settings, this may improve behavior and at least suppress the warning.

          Mylenium
          • 2. Re: CS4 - OpenGL warning when disabled?
            Same Prob here I get that warning just before it crashes...everytime.
            • 3. Re: CS4 - OpenGL warning when disabled?
              Mylenium Most Valuable Participant
              Joe, what graphics card? Did you remove the normal AE OpenGL plugin and try? PixelBender itself should not cause crashes, even if it's probing your graphics card.

              Mylenium
              • 4. Re: CS4 - OpenGL warning when disabled?
                Level 1
                You could also try renaming sniffer_gpu.exe to something like dead_sniffer_gpu.exe. That will fully disable the GPU. It's located in Program Files/Adobe/After Effects CS4/Support Files/

                --chris
                • 5. Re: CS4 - OpenGL warning when disabled?
                  Level 1
                  i'm having the same problems. this is what happens when i'm trying to use the cartoon effect. i get the error when i disable opengl in prefrences and even when i remove it from the plugins folder. if i try renaming sniffer_gpu.exe the effect actually affects the video in the composition but i cannot get it to render over time, just that initial starting frame. i tried setting my system colors to 16 bit and it works but it takes foorreevveerr to render. i mean really, a really looong time and opengl doesn't even show up in ae prefrences. i'm running windows vista with geforce go 6150. the other issue that may be related is that no matter what i do (and believe me, i've tried everything i can think of or seearch for) quicktime doesn't work properly with my system so i have to use vlc media player to play .mov. all my drivers are latest.
                  • 6. Re: CS4 - OpenGL warning when disabled?
                    Mylenium Most Valuable Participant
                    QT not working? Tried the GDI-only mode (in your QT control panel)? If it's really so bad, then you have a quite severe problem on all your system, which cannot at all be blamed on Adobe software only. I'm afraid in that case only a re-install of the whole system will fix the issue. It's even possible that your graphics card has a physical defect and thus the system has a hard time coping with it...

                    Mylenium
                    • 7. Re: CS4 - OpenGL warning when disabled?
                      Level 1
                      i set my ide drivers to the standard windows drivers that came with my os and now quicktime works like a charm (when i untick direct3d video acceleration in prefrences) but after effects is still messed up in the exact same way it was before...

                      tried as many different settings with my computer's video card driver utility today and nothing worked so i uninstalled cs4 production and used the cs4 remove script thing, then reinstalled after effects only. still not working with that effect and i get the gl error message. haven't tried any other effects as i'm using that one as my test.

                      i'm not blaming adobe software i was just putting this out there so that maybe someone might be able to suggest something i haven't tried yet.
                      • 8. Re: CS4 - OpenGL warning when disabled?
                        Mylenium Most Valuable Participant
                        Mmh, still quite puzzling. There's definitely a misconfiguration of your graphics system, it's just not clear where... Sorry, no further ideas at the moment....

                        Mylenium
                        • 9. Re: CS4 - OpenGL warning when disabled?
                          tonygtr
                          I was getting the same problem. I also have an Nvidia card. This solved the problem. It's from the Adobe Technote "Troubleshoot OpenGL problems in After Effects CS4" line item 10. It worked for me.

                          10. Disable advanced functions of the video card. (Windows only)
                          Most display card drivers include utilities that allow you to access advanced functions of the card. In particular, Antialiasing and 16-bit mode functions may conflict with OpenGL and cause After Effects to crash. Set the advanced functions of the card to their defaults, then disable the Antialiasing and 16-bit mode options.

                          If you are using multiple monitors with an Nvidia card, set the Multimonitor setting to "Compatible".

                          Refer to the documentation for the video card or to the manufacturer's web site for instructions on how to access the advanced functions of the video card.
                          • 10. Re: CS4 - OpenGL warning when disabled?
                            I was having the exact same problem as the people above...however after re-installing the ATI Catalyst Install Manager, the problem went away, photoshop and after effects open up with out any issues for now at least....I suggest giving this a try. Maybe there is an equivalent install manager for nvidia that you can do the same with.

                            Im on Vista 64bit with an ASUS ATI EAH 4670 512MB.

                            Roger