6 Replies Latest reply on Jan 20, 2009 10:46 AM by Mylenium

    Error: Failed to initialize mediacore

      Hi people, im having trouble at startup, im using AE CS3 and when crashes it throws me "failed to initialize mediacore".
      Then the program runs but it kinda throw some artifacts in the project im working, like little black bars ruining everything, those also appear on the exported render.

      I tried updating codecs and downloading the latest quicktime but nothing works.

      CS3 is the only alternative because my partners are sending me AE CS3 projects.

      Im working on windows xp proffesional sp3, mi proccesor is an Intel Core2 Duo CPU T5750 @ 2GHz, mi ram is 3GB, an my video card is an integrated onboard Mobile Intel 965 Express Chipset Family.

      Google doesnt help to much, only a few results came up.

      Well thats it, anyone have any idea? dont be shy, everything help.
        • 1. Re: Error: Failed to initialize mediacore
          Mylenium Most Valuable Participant
          >Well thats it, anyone have any idea?

          Sure. ---> "my video card is an integrated onboard Mobile Intel 965 Express Chipset Family". Adobe does not officially support hardware acceleration with intel chipsets. Therefore you are required to turn off any such functions. For AE, this means turning off OpenGL/removing OpenGL plugin, for Quicktime you may need to to disable hardware acceleration in the control panel and revert to the GDI only mode.

          Mylenium
          • 2. Re: Error: Failed to initialize mediacore
            Level 1
            But After Effects 7.0 works perfect on this computer.

            I´ve turned off hardware acceleration and its the same. Nothing changed.
            • 3. Re: Error: Failed to initialize mediacore
              Mylenium Most Valuable Participant
              Apples and oranges. Even for AE7 Adobe never supported OpenGL officially, but since it used an older version of OpenGL, your chip set may just be sufficiently powered to deliver all the features. And AE7 did not have MediaCore... Anyway, could you just try to reduce the hardware acceleration level in your system generic display settings? Or perhaps there is some compatibility settings you can tweak? Down to the point: You problem is, that MC still thinks hardware acceleration is available and does not revert to software-only mode, which requires you to somehow convince it to do so by adjusting things outside of AE. If you are adventurous enough, maybe you can also download the CS4 trial and see if it behaves any better... As a last resort, you could also attempt to remove all MediaCore plugins from your Support Files folder (move it to a different location so you can restore it at any time, don't delete it!). This should, in theory suppress all functions handled by it (you will also loose the ability to deal with some of them entirely), but may prevent at least the rendering errors. you will still get the warning message, though...

              Mylenium
              • 4. Re: Error: Failed to initialize mediacore
                Level 1
                I´ve tryied that on the acceleration settings. I´ve turned off all of those but nothing works. I´ve removed the Media-Core folder and still unable to import video files.

                Anyway i´ve downloaded the installator file from a diferent mirror and still getting the same error but magically the ugly bars are gone.

                I will try CS4 and see what happens.
                • 5. Re: Error: Failed to initialize mediacore
                  Level 1
                  Well, i´ve tryied CS4 and works perfect. It doesnt throws me any error, and it allows me to import video files.

                  The thing with all these versions is OpenGL. I´ve been told that CS4 supports opengl and other hardware accelerations. But im still unable to activate opengl. The check box stills gray.

                  Has somewone any solution for that? because this could be the end of my problem. And i will thank you a lot.
                  • 6. Re: Error: Failed to initialize mediacore
                    Mylenium Most Valuable Participant
                    OpenGL is not supported by Adobe apps on intel chips due to massive hardware and driver bugs and general lack of performance of these chipsets. No way around it short of buying a compliant graphics card and plugging it into your system (which should theoretically be possible by disabling the onboard chipset in the BIOS). or is it a notebook?

                    Mylenium