5 Replies Latest reply on Jul 16, 2009 10:35 AM by Mylenium

    Severe audio problems in After Effects CS4 and MXF and more...

      Hi!

      I've been experiencing a lot of problems lately with several CS4 products.

      First, and the worst, is that there seems to be some severe audio bug in After Effects when handling mxf-files. I pre-cut a project in premiere CS4, shot with a Sony EX1, and then imported the project in After Effects CS4.

      In premiere everything worked fine and I had all the audio. In AE however the audio matched with the MXF-files disappeared (Yes I had the import audio box checked). All other audio worked fine from the music tracks and so on, but the MXF-files (MXF for NLE) was completely blank, the waveforms were completely flat. I checked every option there is in AE regarding audio and tried enabling and disabling XMP ID's and so on. After a lot of tweaking and testing I understood that the problem was not with any settings anywhere, the MXF-files lacked audio even if I started a new project and just imported the MXF-file.

      The problem seems to be connected to when importing from Premiere. My colleague was editing a similar project on his computer in After Effects without problems, and he started out fresh in AE (didn't pre-cut in premiere). However, we tried to move my project to his computer, to see if the problem was connected with incompability with my hardware or such, and he got the same problem as me when he opened the project. Waveforms on MXF-files were completely flat. Certain confirmation that the problem was not connected with my computer appeared when he later reopened his own project, that had worked fine before, and audio was now completely gone - waveforms flat. An hour later, by chance, his audio suddenly popped back.

      I have experienced this problems in two different projects in different forms (but both pre-cut in premiere). In the first, audio disappeared while previewing but was there when I ctrl-scrolled and rendered (no I hadn't muted audio in the preview panel). In the second, audio was completely gone even when rendered.

      In both cases I tried saving and restarting the computer, reimporting from premiere, starting a fresh after effects project and only importing the mxf-files, changing the project settings, fps fixed to the correct instead of auto, changing output audio mapping, changing XMP, and so on in every possible way and combination I could imagine.

      At my company our suspicion is that After Effects flags mfx-files imported from Premiere in some wierd way, to strengthen and ensure compatibility between the two - regarding different audio tracks, settings and effects from premiere (and this is almost what you could suspect that the XMP ID is for, but as explained with or without doesn't change a thing regarding this). We have no problem with the pure MXF support for AE, as MXF-files work just fine in After Effects if you import them directly and have not imported them through premiere earlier (but after a file has been "flagged" you seem to be sc***ed)

      Anyone else experiencing this? Or am I missing something huge?

      As additional notes, the dynamic link function seems extremely buggy and both premiere both sometimes complains about "dynamic link already in use and only one connection blah blah" even though only one link is used, and even though you restart the projects, programs, computer, whatever.

      In furher addition Adobe Media Encoder (which also seems to be using some sort of dynamic link offspring) is super-buggy and most codec formats either doesn't start to render or just renders partially and then the program hangs. The problem have a connection with a process named pproheadless.exe eating upp all the RAM (4gbs).

      (My workstation has been working smoothly for one and a half years and I have had very little problems with CS3 and "just" AE CS4. I am cautious of updates, don't have spyware and use Quicktime 7.5 as 7.5.5 is superbuggy and people seems to have problems with 7.6 and it doesn't fix the gamma issues anyway.)

      Sorry if this was a long post but the problem is compl