8 Replies Latest reply on Feb 18, 2009 7:21 PM by craulmedia

    exporting graphics over interlaced futage

      I would realy aprishiate your help on this one!!
      And sory for my poor english.

      working on pc p5q deluxe core2quad 8gb ram vista 64
      After effects cs4

      Im working on 1920:1080 50i square pixels uper field first futage and I aplied some graphics in after effects. But when I render it in same interlace resolution and import (interpretate futage) the futage looks good but graphics like text and every other element drown in after effects looks in poor resolution. I have to deliver interlaced futage and i tryed everything I could think of with no resoults.

      befour rendering I render preview and everything looks perfect, but when I render it(1920:1080, sqere picsel, uper field first, TIFF sequence, same as the footage) and import renderd sequence back on top of layers to compare, the footage looks perfect but graphics look 5% blured.
      Is it posibile that only a part of the same, renderd footage is previewed incorectly ??

      I always interpretate futage as it is captured or renderd.

      Delivery metod is a little tricky too, I have to export to editors interlaced footage so they could put it in their project and further down the line they will send whole film to the laboratory so they can deinterlace everything together and transfer it to 35mm so even if it looks good on interlaced monitor will it look the same on the film??

      plese help!!
        • 1. Re: exporting graphics over interlaced futage
          Mylenium Most Valuable Participant
          Are you using motion blur? OpenGL rendering? Could be any of those. If you don't use the same options when previewing the comp, naturally it will look different. And look for nested comps that may not inherit full resolution from the parent comp (if you turned off the respective option in the prefs).

          Mylenium
          • 2. Re: exporting graphics over interlaced futage
            Jonas Hummelstrand Level 2
            Sounds like you are just seeing the interlacing.

            - Jonas Hummelstrand
            http://generalspecialist.com/
            • 3. Re: exporting graphics over interlaced futage
              Andrew Yoole MVP & Adobe Community Professional
              ^ I agree with Jonas. Does it look wrong when viewed on a true interlaced monitor?
              • 4. Re: exporting graphics over interlaced futage
                Level 1
                Thank you so much four reply, I tried with OpenGL rendering on and off but the problem is still there
                and I watched it on interlaced monitor, it looked little better but not perfect. But I realy think that the problem is in my work flow so I made this smaller and much simpler project where I get the same kind of defect and maybe you could tell me where I made mistake??

                -open new project make new comp(dv pal sqere picsel) and make one text leyer(I wrote "test" with big futura bold font, white font against black bg).
                then animate text, I applied expresion to rotation time*120. Add to render queue and go to render settings and set field render to upper field first
                quality best resolution full ofcourse, and in otput module chouse TIff sequence and render it.

                Then I imported renderd tiffs,interpreted them as upper field first and edges of the text look like they lost a half of resolution horisontaly.
                ..ok, if its my monitor than i shuld be able to deinterlace that and see a normal picture right??
                Add that new comp to render queue and export with same settings just change upper fild to no field. and again i get the same problem vith edges.

                obviesly i make some mistake in that proces but if that same proces works great with captured interlaced futage why do I get this problems with grphics made in after efeects and how do you combine those two(interlaced fotage and AE graphics) and export them as same interlaced footage??

                Is that the right way of interlacing the graphics made in after efeects??

                and Thank you once again, I will appreciate any thoughts and help on the subject.
                • 5. Re: exporting graphics over interlaced futage
                  Andrew Yoole MVP & Adobe Community Professional
                  Can you upload one of the problem frames and post a link so we can view it?
                  • 6. Re: exporting graphics over interlaced futage
                    Level 1
                    These pictures are from simplified project above.

                    no fields
                    http://img6.imageshack.us/img6/2884/testnofiledszq3.png

                    upper filed first
                    http://img18.imageshack.us/img18/6416/upperfieldfirstpz7.png

                    upper filed first and (interpretated) deinterlaced
                    http://img148.imageshack.us/img148/3715/upperfieldfirstafterintgv4.png
                    • 7. Re: exporting graphics over interlaced futage
                      Andrew Yoole MVP & Adobe Community Professional
                      Yes, the images are perfectly normal - nothing is wrong. That's what interlaced graphics look like when both fields are visible.

                      If displayed correctly on a true interlaced monitor, the motion should essentially be smooth and clean. If that is not the case, I'd suggest there may be some configuration issue with how the material is being displayed. What hardware are you using to view your interlaced material?

                      The proposed workflow - creating an interlaced master for transfer to film - seems strange to me. Personally, I'd be creating a non-interlaced master for anything going to film. Perhaps you should question the workflow also.
                      • 8. Re: exporting graphics over interlaced futage
                        craulmedia Level 1
                        if you work with interlaced footage and graphics in AE you FIRST have to interpret your (video)footage >> right click your clip in the project browser >> "interpret footage" set fields to "none".

                        Send your work to render queue (NOT EXPORTING) and set field rendering in the render settings >> "field render" to upper field and start render.

                        now your video footage and your graphics should be rendered correctly.
                        If you preview the final render at your computer, fields will be visible but not - as already mentioned - on a interlace Class A monitor or TV.

                        later on, deinterlacing is not your part.

                        cheers.