17 Replies Latest reply on Apr 14, 2009 10:56 AM by deucmp06

    After Effects- Administrator Account

      Hi, ive been using AE for quite some time. Ive just installed windows vista 64 and ive started using AE, but the issue is, when i run it as an administrator, the program starts up and then there is a delay in the menus and the whole program is acting very sluggish.

      On the other hand, when i DON'T run it as an administrator, the program runs absolutely smoothly, but i get this error at the start up 'Please run this program from the Administrator account so it can set up your license. Once the license is set up, you can run it from any account.' and twice.

      Any help would be much appreciated.
        • 1. Re: After Effects- Administrator Account
          Mylenium Most Valuable Participant
          Sounds like the licensing service is being mismanaged by the operating system. Check your system management panel's "Services" section. You can assign a specific user account to each service and should be able to circumvent all issues by making the Adobe LM service run as Administrator all the time.

          Mylenium
          • 2. Re: After Effects- Administrator Account
            Level 1
            Hi Mylenium, im using windows vista, the thing is, ive already uninstalled the whole thing and reinstalled back again, did the clean script thing as well. After i install it(After effects cs3 ie) the menus work fine, but after sometime it just starts acting weird. Ive even opened up the 'Adobe After Effects Render Engine' to see if that interface atleast doesnt have a lag and well it Doesnt. Its really annoying. Could you please help me out. Its only the menus that have a 4-5 second delay, the cameras, filters everything else works just fine!
            • 3. Re: After Effects- Administrator Account
              Mylenium Most Valuable Participant
              Mmh, well, if it only occurs after a time, then my guess would be that Vista is accumulating garbage... Do you use any of the advanced security and hardware monitoring features? System restore? Signed drivers? Perhaps it's simply a matter of Vista permanently logging something. Beyond that of course you can always blame the graphics card. Other users that use 3D programs have reported similar problems on other forums due to not being able to obtain a bug-frre driver for their system. I can't really help you with that, as I'm running Vista 32bit on my MacBook and it works perfectly...

              Mylenium
              • 4. Re: After Effects- Administrator Account
                Level 1
                Well, ive tried updating my drivers, they are fine(geforce 8800 gt), security only anitivirus program, Eset, everything else runs fine. If i run after effects without the administrator permission i get two errors at the beginning of the start up, which is:

                "Please run this program from the Administrator account so it can set up your license. Once the license is set up, you can run it from any account"

                and if i try to use 'Render Multiple frames simultaneously' i get those errors repeatedly...
                • 5. Re: After Effects- Administrator Account
                  Mylenium Most Valuable Participant
                  Did you check the permissions as I was suggesting? The errors clearly indicate that the service is not running at all. Please do look into the matter. Do the following:

                  a) Right-click on your taskbar and chose "Task Manager"

                  b) Try to launch AE. While launching AE, you should see additional programs and services being launched. Their names are Adobelmsvc.exe and Adobelm_Cleanup.0001. If they don't launch proceed to the next step.

                  c) Log on to the Administrator account.

                  d) Find the "Programs/Adobe" and "Programs/Common Files/Adobe" folders and check their file permissions. They should have full access for "Special" permissions for all users and require to have the permissions set for "Modify" administrators and power users. If that's not the case, change them accordingly.

                  e) In addition, right-click on "My Computer", choose "Manage" and check your "Services". Double-click the "Adobe LM Service" and check its properties. The launch should be set to "Manual". On the second tab you can make it to run under a different user account if needed.

                  f) Lastly, check your own user account properties. Preferably you should be a power user, not just a normal user. If that is not so, add yourself to the power users group. This should final get you up and running.

                  Mylenium
                  • 6. Re: After Effects- Administrator Account
                    Level 1
                    ok this is weird, ive done the checking of the startup, no such adobelmsvc.exe and adobelm_cleanup.0001 running at all in the task manager.

                    whats really funny is that i cant find the Adobe LM Service running at all!!!

                    do i need to reinstall or something.

                    btw i am using the admin account itself. Mylenium you seem the only one to be helping me out with this, please stick with me to solve this problem. its been 2 days and its killing me..

                    thanx for all the effort though...much appreciated
                    • 7. Re: After Effects- Administrator Account
                      Mylenium Most Valuable Participant
                      That sounds extremely fishy. Did the program correctly attempt to activate on the first launch? Do you have any system protection software running that may be blocking the service (firewall, virus scanner or some such thing)? Do you have any other Adobe products installed? Do they run and launch the service correctly? Of course you can always re-install, but ultimately you might still be stuck with the same issue.... If you do, I recommend also running the CS3 clean scripts from the support pages to really get rid of any trace.

                      Mylenium
                      • 8. Re: After Effects- Administrator Account
                        Level 1
                        I have photoshop and flash running smooth as ever. The only virus scanner/firewall i have installed is Nod32-Eset and of course vistas defender. I have no issues what so ever with any of the other products from adobe. Here's what ive been doing repeatedly over the past days - Uninstalling AE only and reinstalling it, then i even tried uninstalling all adobe products, then reinstalling, thats when i had a good chance of getting AE working properly for a couple of times, then it goes back to its slow, sluggish style.

                        Ive even go about using the CS3 clean scripts multiple times over the couple of times that ive reinstalled the products again.

                        What is really annoying is that When i run it as an Administrator, everything works fine, except the sluggish behavior(the main reason of all this trouble), but when i run it without the administrator checked(right clicking>properties>Run as administrator) i get 2 of those errors at the beginning and then i get into the Interface, then the lag is suddenly all gone. Everything is working just GREAT! except when rendering i get those errors every now and then (these errors DO NOT occur when im in administrator mode btw)

                        Its just a matter of those 5 seconds of lag that really annoys me, everytime i need to insert a solid or even use the short cut key, it has this lag!

                        just to let you know, the other thread that i discovered

                        'Big problem with AE CS3 - abnormal slow with nvidia 8800 GTS 512 !'

                        well, i too have a gefore 8800 GT graphic card, does this make the problem even worse now?
                        • 9. Re: After Effects- Administrator Account
                          Jonas Hummelstrand Level 2
                          Sounds like you've run into a newly discovered bug that occurs with 8800 cards on certain systems. Please file a bug report at:

                          i http://adobe.com/go/wish

                          - Jonas Hummelstrand
                          http://generalspecialist.com/
                          • 10. Re: After Effects- Administrator Account
                            Level 1
                            but my concern is why does this run fine when im not in an admistrator mode, except for those 2 errors that i get when i fire AE up?
                            • 11. Re: After Effects- Administrator Account
                              Level 1
                              ok heres something new: i just got a fit to try this out, i basically ran photoshop as an administrator(which i dont need to and works Perfectly) but when i did it had the same lag as After Effects has...now im not bothered about the 8800 gt issue, if i can just figure out how to get after effects running without the Run as Administrator option and bypass that initial error!
                              • 12. Re: After Effects- Administrator Account
                                Mylenium Most Valuable Participant
                                *ouch* That's really turning into a mystery. If the graphics card does not seem to be the issue, then certainly it hinges on user management and security settings... Anyway, I think this has reached a point where only sitting in front of the machine would allow any deeper analysis. I really feel, sorry for all your troubles, but there's only so much one can do from afar.

                                Mylenium
                                • 13. Re: After Effects- Administrator Account
                                  Level 1
                                  i totally understand what you mean Mylenium,but what do you reckon? clean install vista and givin it a short or should i try installing it in a different account or something on those lines?
                                  • 14. Re: After Effects- Administrator Account
                                    Andrew Yoole MVP & Adobe Community Professional
                                    Personally, I would do a complete clean OS install, essential system drivers and Adobe products only. 3 or 4 hours of installation could save you days of troubleshooting.
                                    • 15. Re: After Effects- Administrator Account
                                      Mylenium Most Valuable Participant
                                      Yepp, Andrew is right. Just plain nuking the system and rebuilding it from the ground up might be less nerve wrecking - that is if you don't know a geek near you who can take one last hard look at the system. Well, whatever you do - good luck from us all. Let us know how things turn out. It might help other people in the future.

                                      Mylenium
                                      • 16. Re: After Effects- Administrator Account
                                        Level 1
                                        Ok, so far this is what ive done. Instead of going for a nuke...i sat down the entire day and just ran the clean script at different levels.

                                        Anyway heres what i did exactly.

                                        1) I uninstalled the stuff from the control panel>Restarted
                                        2) ran the Clean Script at level 1. Restarted
                                        3) ran the Clean Script at level 2. Restarted
                                        4) ran the Clean Script at level 3. Restarted
                                        5) ran the Clean Script at level 4. Restarted

                                        also kept deleting the log files before restarting each time.

                                        Then finally i installed the entire thing again. And well...the lag as reduced down to probably a fraction of a second, but still bearable! Im a little chilled down now coz i can handle this to some extent, but if this thing persists, im definately going to give it one last try by starting everything ground up.
                                        • 17. Re: After Effects- Administrator Account
                                          deucmp06

                                          I have a somewhat similar problem and here's the cause and sort of a fix:

                                           

                                          The problem is cause by the FlexNet (hissssssss!) license trying to change the installation protection settings laid down by Vista.

                                           

                                          The fix (if you can call it that) is this:

                                           

                                          In the Administrator account go into; Control Panel - User Accounts - Administrator and turn off the User Access Controls. Restart. No more errors. However, if you turn the UAC back on (I don't know to protect your computer from rogue installations) the whole thing will most likely start all over again. This is a straight up bug with FlexNet and Adobe should have put out a patch for this thing a long time ago.

                                           

                                          On our system the error message comes up on the administrator account and only on AFX and Premeire. Premeire it only shows up at the start with no 'OK' button in the center (blank space) and on AFX it comes up 10x! Weird part is after you hit okay enough times, the programs come on and run just fine. This software costs entirely too much money to have retarded glitches like this and get no support from Adobe.