12 Replies Latest reply on Jul 20, 2008 3:43 PM by (Jack_Liddon)

    not enough memory to render audio

      hi, I've searched the forum, and can't find any related posts. I'm running AE 7.01 pro, with Nucleo pro.

      I'm working on a fairly long greenscreen speech, about 7 mins, and when I do a RAM preview, it says "not enough memory to render 414.6 seconds of audio - try shortening your work area or turning off audio". (7 mins is about 414 seconds, so that's the length of the comp)

      Turning off audio isn't an option, but my work area is only about 20 seconds, so it doesn't seem to be rendering my work area - it's trying to render the whole comp!

      My audio preview preferences are set to 8secs, 22.050 khz, 16bit, and mono. (although they don't seem to have any bearing on the problem?)

      thanks for any advice!
        • 1. Re: not enough memory to render audio
          Mylenium Most Valuable Participant
          The question is, what source format the footage and audio are. Sounds like it is some compressed stuff or a sample rate not natively handled by AE and therefore it is trying to render the whole thing, regardless of how it is trimmed. I'd simply export a standard 44 kHz or 48kHz WAV/ AIFF file from your capture app and use it instead of the embedded audio. You can then split and disable the snippets as needed which should prevent all mishaps. You can always re-introduce the source audio at a later point in your edit suite.

          Mylenium
          • 2. Re: not enough memory to render audio
            Level 1
            Hi thanks very much for the reply - teh source footage is really nothing special. (I think?) It's the std capture format - Avi + 48Khz embedded Audio.

            I can extract a wav file from it if that would improve anything?

            But it's really nothing special - just the AVI that I've captured on a normal XP system.

            Thanks again for the help!
            • 3. Re: not enough memory to render audio
              Mylenium Most Valuable Participant
              MMh, how are you capturing and what is the CoDec of the AVI? If it uses a dedicated capturing CoDec (Blackmagic, AJA or whatever) it may introduce additional meta-streams that could potentially prevent Ae from correctly interpreting the timebase information and result in misalignment and successive audio failure...

              Mylenium
              • 4. Re: not enough memory to render audio
                Level 1
                The codec is the MS DV codec and I captured using Premiere Pro 2, with all default settings.

                It doesn't happen straight away, it's like on the third or 4th render, and sometimes if I purge all, it fixes it, and other times, purging doesn't fix it.

                I'm really confused as to why it says, "try reducing the work area" but then tries to render all 9 minutes, when the work area is only 40 seconds!

                thanks again!
                Chris.
                • 5. Re: not enough memory to render audio
                  Jonas Hummelstrand Level 2
                  The audio import and handling was rewritten and greatly improved in the AE CS3 release.

                  If you want to stick with AE 7, one workaround may be to duplicate (Ctrl-D / Cmd-D) the layer and then disable the video switch (looks like an eye) on one layer and the audio switch on the other.

                  - Jonas Hummelstrand
                  http://generalspecialist.com/
                  • 6. Re: not enough memory to render audio
                    Level 1
                    Thanks very much for the idea! I'll give it a try and see if it makes any difference.

                    And thanks for the phun lnk on your website! :-)I won't be trying to do anything work related for the rest of the day now!
                    • 7. Re: not enough memory to render audio
                      I've got a brand new Dell T5400 computer with 3gb of RAM and 2 DuoCore Xeon processors. I've also got 2 nVidia Quadro FX 3700 video cards with 512MB each.

                      I'm working on a 1.5 minute long music video with a 44k 16 bit stereo wav file. I can do a RAM preview (at 1/3 resolution) of the entire sequence. I can only do this once. After that I get a message that says "not enough memory to render 108 seconds of audio"

                      No matter what I do, AE will not preview this file with sound again. It proceeds to render just the video...and then it will only do 500 or so frames. I have to restart AE and start over.

                      On a side note, I have taken this exact same project onto my MacBook Pro, with only 2gigs of RAM, running off a firewire drive and have had no problems at all. I can RAM preview, with sound, until the cows come home.

                      Help! Anybody?
                      • 8. Re: not enough memory to render audio
                        Andrew Yoole MVP & Adobe Community Professional
                        What version of Windows?

                        I presume you've tried "Purge All Memory"?
                        • 9. Re: not enough memory to render audio
                          Mylenium Most Valuable Participant
                          >I'm really confused as to why it says, "try reducing the work area" but
                          >then tries to render all 9 minutes, when the work area is only 40
                          >seconds!

                          It's possible some of the samples do not align correctly in time with your footage due to some minor (unnoticable) audio delay on capture. this can have the strangest effects as AE will then think it has to resample every single bit of the file. Jonas's suggestion indeed provides a good workaround in such situations. Based on that, you could also physically split the individual audio sections to further make this "idiot proof" and prevent AE from causing a mess.

                          Mylenium
                          • 10. Re: not enough memory to render audio
                            Mylenium Most Valuable Participant
                            >I've got a brand new Dell T5400 computer with 3gb of RAM and 2 DuoCore
                            >Xeon processors. I've also got 2 nVidia Quadro FX 3700 video cards with >512MB each.
                            >
                            >I'm working on a 1.5 minute long music video with a 44k 16 bit stereo
                            >wav file. I can do a RAM preview (at 1/3 resolution) of the entire
                            >sequence. I can only do this once. After that I get a message that says
                            >"not enough memory to render 108 seconds of audio"

                            These may be Media Cache errors due to how AE needs to conform HDV and other MPEG formats (assuming that's what you are working with). Therfore check your preferences, clean the cache and move it to a different location. If you leave it in the default "My Files/Adobe/After Effects CS3/Media Cache", it may get locked up due to Windows applying its user permissions and quota. Also these directories are usually heavily fragmented due to the many operations on them, which will further minimize performance. Moving this stuff to a different location (e.g. a separate directory on your video RAID) is thereefore advisable.

                            Mylenium
                            • 11. Re: not enough memory to render audio
                              I have a problem where the complete project renders, audio and all,
                              but when I try to view the .mov, the video gets all choppy while the audio plays through.

                              By choppy I mean it plays smoothly for the first 30 seconds, then it freezes on a frame, while the audio plays with no problem, then it jumps to a frame further down the time line, and plays a few more frames, freezes, and plays a few more frames from further down the time line.

                              Any Ideas?
                              the comp is made up of .pngs from a 3D app, and the frame rate is set to 30.
                              and I output to a quick time format.
                              Thanks
                              • 12. Re: not enough memory to render audio
                                Level 1
                                Mylenium,

                                I'm actually working with a Quicktime movie using Apple Animation at 767x617. I've moved the cache file to the D: drive, I've purged the memory, etc. I moved all my files from the firewire drive to the D: drive as well. I still have the same problem. It ram previews once and then gives me errors every other time. It seems that After Effects CS3 on the PC just doesn't want to work with me. I am currently working on the same project on a Mac Pro tower with no problems at all, unfortunately it's my home computer. Not a great solution since we're not allowed to use Macs at work. Go figure.