8 Replies Latest reply on Jun 25, 2008 12:10 AM by Mylenium

    Alt-Shift-P

    Jack Cates Level 1
      Maybe I'm missing something basic here, but I'm going through a tutorial and it says to "press alt-shift-p to enable keyframing for position and reveal it in the timeline." But when I do this, Windows Media Player opens.

      Is there an override somewhere where I can shut that off in Windows or have AE shortcuts override Windows shortcuts when the program is open?
        • 1. Re: Alt-Shift-P
          Ko Maruyama User Group Manager
          Make sure that you don't allow AFter Effects to see outside keyboard shortcuts (you'll find the toggle on/off in General Preferences of AE).

          Otherwise, it might be at the system level. (change the shortcut in Windows prefs)

          On a Mac, you need to turn off Expose's default F10-12 in order to use the camera view shortcuts.
          • 2. Re: Alt-Shift-P
            Mylenium Most Valuable Participant
            The system shortcut pref option only exists on Macs, so that should be no issue. On Windows, find the shortcut that links to MediaPlayer, right-click and choose "Properties". You should see the shortcut listed there. Simply remove it and it should work as expected. Also make sure to not use any MediaCenter extensions or keyboard managers your hardware manufacturer may have installed. HP and Dell often have this on their systems and those tools, too, will respond to certain keyboard shortcuts to provide quick access to TV channels and such, which of course is not what you want.

            Mylenium
            • 3. Re: Alt-Shift-P
              Jack Cates Level 1
              My apologies... I'm used to posting in OS-specific forums in Illy and PS and forgot to mention which one I'm using in this one.

              I'm using Windows XP Pro, AE CS3.

              I didn't find a toggle box in the preferences regarding shortcuts and I don't know where to change Windows-specific shortcuts.

              And under properties for Media Player, the shortcut says 'none'.

              I also don't have any Media Center extensions running or installed. Computer is not a big box (HP, Dell, Sony...), it's a custom build by my company's tech department (I work for a regional computer retailer).

              I'll have to check about keyboard managers, but I doubt that's it unless there's something hidden somewhere. It's just a plain $10 keyboard (101/102-Key).

              Where would I find the Windows prefs so I could change that? That may be my only option here besides uninstalling MP which I need to test AE and Premiere exports.
              • 4. Re: Alt-Shift-P
                Mylenium Most Valuable Participant
                The keyboard itself is rather unlikely, except it has a hardware defect. If it's really a bog standard layout, the OS would configure it to en_US which does not have any extended keys. Did you enable any accesibility features? That's the only other thing that comes to mind...

                Mylenium
                • 5. Re: Alt-Shift-P
                  Jack Cates Level 1
                  The keyboard is a Keytronic Lifetime Series: Classic-P1... nothing special; as I said, it's a $10 keyboard. All I did was plug it in. Windows sees is as a Standard 101/102-Key or Miscrosoft Natural PS/2 Keyboard. It is KVMed to another computer.

                  I'm thinking this is some perversion of Media Player. I've discovered that Alt-Shift-P restores Media Player 10 from Mini Mode (even though I have 11 installed, this appears to be happening).

                  I'm going to try an uninstall and reinstall since I can't find any way to disable the mini mode garbage.

                  ETA: Also, I just test tested my manager's computer and this does not happen on hers.
                  • 6. Re: Alt-Shift-P
                    David Wigforss-Hv1BNN Level 2
                    Is that shortcut too crucial, that you need to reinstall AE? I'm all for shortcuts, but I'd get used to manually enabling animation, since you need to do that for any parameter you want to animate...
                    • 7. Re: Alt-Shift-P
                      Jack Cates Level 1
                      No no no... uninstall and reinstall Media Player since it was overriding the AE shortcut and would not release it.

                      Going through that whole process, though, did reveal the answer.

                      The versions of Media Player that can go into mini mode on the taskbar are/is the culprit. When I got to reinstalling MP, it told me to close all other windows (as everything does) and to turn off mini mode. It showed me how to turn it off if it was on: right click on the taskbar, go to toolbars, and uncheck Windows Media Player.

                      That being checked in the first place was probably what caused the shortcut override. I went to my manager's computer and WMP was not checked on hers and the Alt-Shift-P did not launch WMP.

                      Alt-Shift-P now works in AE as it is supposed to now that the WMP mini mode is disabled/unchecked in the taskbar toolbar menu. Had I known about that, this problem would have been solved in 1.5 - 2 seconds tops.

                      I feel a Yosemite Sam coming....
                      • 8. Re: Alt-Shift-P
                        Mylenium Most Valuable Participant
                        Indeed, that is rather annoying if you find it out the hard way. ;-) Thanks for checking back with the answer, this will certainly help to avoid similar confusion in the future.

                        Mylenium