11 Replies Latest reply on Jul 6, 2008 11:11 PM by (Darren_McNeill)

    Render stops early

    Level 1
      After Effects CS3

      I have a 20 second composition, that stops rendering at 11 seconds.

      I can't seem to figure it out.

      I'm rendering out to a standard avi file.

      RAM Preview also stops at the 11 seconds, although, standard playback will play the full 20 seconds.

      I have purged the cache but I cannot see it being a memory isue with 4 gb RAM.

      Any ideas would be helpful
        • 1. Re: Render stops early
          Joey Morelli Level 1
          What is a "standard avi file"? SD or HD? What is your platform = Mac or PC?
          • 2. Re: Render stops early
            Level 1
            Hi,

            Windows AVI file, on a PC.

            Quad Duo Core Xeon 2.66

            I've tried both the options of using Multi core processors and not ticking that option.

            It will render though it seems at quarter resolution, but rendering at full resolution shows the issue.

            cheers
            • 3. Re: Render stops early
              Ko Maruyama User Group Manager
              'had a similar error pop up the other day.... turned out it was user error - we didn't have enough room on the destination drive.
              • 4. Re: Render stops early
                Level 1
                Thanks for the info.

                I'll investigate that but the machine in question has eight harddrives, each one is 500gb.

                The destination drive for the AVI file has just over 300gb unused.

                I think it has to be something with memory of some sort but I can't see it.
                • 5. Re: Render stops early
                  Ko Maruyama User Group Manager
                  You may want to open the SECRET prefs, and purge your frame cache every "X" frames.
                  shift- prefs
                  • 6. Re: Render stops early
                    Level 1
                    Cheers,

                    I'll check that out.
                    • 7. Re: Render stops early
                      Level 1
                      It seems I have figured out the issue but i can't see how to resolve it.

                      for some reason after Effects is only rendering through the Active window, but I need it to Render via the created Camera window.

                      Although the View is set to Camera 1, the render only renders to Active View, which does not produce the Camera movements.

                      Any ideas?
                      • 8. Re: Render stops early
                        Ko Maruyama User Group Manager
                        Do you have the camera layer set to the duration of the entire composition? Maybe there's a gap somewhere?
                        • 9. Re: Render stops early
                          Joey Morelli Level 1
                          Windows AVI file, on a PC.

                          Didn't answer my question. SD or HD? What are the comp settings? How much RAM is onboard? Can't give complete answers without complete information.

                          AE only renders the Active Window in the final. If you want to render a different camera angle, precomp it and set up your final camera on that layer.
                          • 10. Re: Render stops early
                            Joey Morelli Level 1
                            Sorry...just noticed you have 4 GB RAM...

                            For what Ko's referring to ("SECRET" prefs), hold down Command/Control/Shift (Mac - not sure what it is on PC) and go up to Menu Bar/After Effects/Preferences/General to launch the prefs dialog. Click on the dropdown and go to "Secret" on the bottom. When I am having difficulty with large images, I click "Disable Layer Cache" / Purge every 1 Frame During Make Movie.
                            • 11. Re: Render stops early
                              Level 1
                              sorry was away for a few das.

                              It's an SD File.

                              The Comp settings are standard PAL settings to square pixels.

                              The Secret prefs on a PC are accessed by just holding the Shift button while clicking on Edit/Preferences, Secret is then at the bottom of the list.

                              I set Puge every 1 frame During Make Movie.

                              I had actually been handed the After Effects project from another department. We have creative teams in NAM, EMEA, ASIA and JPAA.

                              It was the ASIA departemt who were experimenting for the first time with After Effects. As I use it every day, it was sent to me to rectify the issue.

                              It seems that the person setting up the project was using the Camera 1 in the View all the time rather than through the Active View.

                              It was a basic error I should have picked up on.

                              I removed all the camera moves, changed the View to Active View, added the Caera in the Comp and set up the moves again.

                              I improved the camera movement by linking the camera to a Null object and adding the xyz effect to the null object making the control better and smoother.

                              It rendered fine this time to 19 seconds instead of the 20, but it it fine now.

                              Thanks for the help and advice.