5 Replies Latest reply on Jul 6, 2008 9:36 PM by Mylenium

    soundkeys problem

    Miha Kokalj Level 1

      Has anyone tried using trapcode soundkeys plug-in? Its an awesome plug, but it doesn't seem to work well with greater durations. When i click "apply" to generate the keyframes I run out of memory after a few seconds of the sound, followed by a thousand popups of after effects saying that it ran out of memory. It works to do it in short segments, and purging memory every time after the keys are generated, but thats very time consuming.

      Any ideas how to avoid that?

        • 1. Re: soundkeys problem
          Andrew Yoole MVP & Adobe Community Professional
          What OS? How much RAM?
          • 2. Re: soundkeys problem
            Miha Kokalj Level 1
            Win XP, 2 gigs of ram. Using AE CS3 and soundkeys 1.1.3.
            • 3. Re: soundkeys problem
              Mylenium Most Valuable Participant
              Set the work area in your comp. Just like any other audio processing in AE, the plugin will respect it. By setting multiple takes, you certainly should be able to get it done. Apart from that, obviously there are limits, but personally I've worked with 20 minute files and not experienced any such issues on a system with only 2GB, so maybe something else is interfering with your results.

              • 4. Re: soundkeys problem
                Miha Kokalj Level 1
                Mylenium i have been doing it piece by piece. Only the problem is that i have lots of tracks working (covering the whole specter), and doing it in segments is a big waste of time.

                I'm trying to set up a template which would serve me as a visualization tool for a few songs. So doing it over and over again for every song is out of the question. I wonder if thats the nature of the plug, that it doesn't purge memory every few keyframes.
                • 5. Re: soundkeys problem
                  Mylenium Most Valuable Participant
                  Has nothing to do with the plugin. The plugin only sees what AE hands it which is the uncompressed audio buffer including all effects processing and mixing. To my knowledge, it does not use any bypass functions to access the audio file directly. Therefore one could assume that it's more of a general config issue with your system and memory settings that makes it go boom. As I said, I can work on long pieces without problems even on my 3.5 year old "weak" system at home...