24 Replies Latest reply on Jul 5, 2016 4:11 AM by darionLeigh333

    Liquify stops working

    Andy Bay Level 1
      Hi!

      I'm not sure if it is me who is missing something, but seems like liquify effect many times suddenly quits working.

      What happens is I don't get the "pen" that I draw with usually (when liquify works), but the cursor just stays like the normal cursor in AE. If I drag on the picture, nothing happens.

      I thought I knew how to use liquify, is this a bug or could I be doing something stupid?
        • 1. Re: Liquify stops working
          (Steve_Patterson) Level 1
          Are you selecting one of the Liquify tools in the Effect Controls palette?
          • 2. Re: Liquify stops working
            Andy Bay Level 1
            Yes! Been clicking on them like crazy! :D

            I also tested this on another computer and after using it for a while the same thing happened.

            Is there any ristrictions using liquify? I tried to remove all other effects, scale everything back to 100% and test in both precomposed and regular layers. I also switched from 16 bit back to 8 bit, but still no help. Could there be something else to check!

            By the way, thanks for trying to help!
            • 3. Re: Liquify stops working
              Mylenium Most Valuable Participant
              Well, I'm not using this effect much and never had any problems, but I could imagine that you hit a limit with its internal transformations stack and/or create a conflict with AE's Undo stack. Another reason may be overlay drawing issues with the custom controls (for the tools). Therefore some things to try would be to increase the undo steps to the maximum of 99 or the other extreme, zero, to regularly flush the undo buffer, to temporarily toggle to another tool and do one or two steps to "break" the undo stack and, in case of drawing issues, maximize/ minimize the application to enforce a full interface refresh. If you are still getting issues, try to keep track of how many steps you are actually able to do in Liquify, then report your findings to the official bug form:

              http://www.adobe.com/go/wish

              Mylenium
              • 4. Re: Liquify stops working
                (Steve_Patterson) Level 1
                Mylenium makes some excellent suggestions above.
                I've never run into a limit with Liquify, and I have used it a good amount. You might want to try to apply another instance of Liquify on your layer, and continue morphing on the second instance. Maybe that will work?
                • 5. Re: Liquify stops working
                  Andy Bay Level 1
                  I really appreciate you guys trying to help!

                  The strange thing is, once a liquify stops working in a specific project, nothing seems to bring it back. I have tried deleting the effect and adding it again and closing AE and restarting the project, but nothing seems to help. I can however start a totally new project, and in that liquify will work again beautifully. Because restarting AE doesn't seem to help, I don't believe it could be an undo problem. I will however try to increase the undo levels and see if it works out.

                  The puzzling thing is why the problem stays in the projects after it first occurs and won't go away no matter what I try. That makes me think that maybe I do something in the project that causes this effect not to work anymore. Just can't figure out what it is.
                  • 6. Re: Liquify stops working
                    (Steve_Patterson) Level 1
                    You mentioned scaling everything back to 100%...what transformations are you applying? Did you try enabling the viewable mesh to see what's going on with your actual distortion?
                    • 7. Re: Liquify stops working
                      Andy Bay Level 1
                      I did a new comp and put a totally untouched layer in it, then applied liquify, but even then I get nothing. Even the distortion mesh won't show up no matter how much I click the button for it. :(
                      • 8. Re: Liquify stops working
                        (Steve_Patterson) Level 1
                        Have you tried trashing (removing) your prefs?
                        How about uninstall/re-installing?
                        • 9. Re: Liquify stops working
                          Ko Maruyama User Group Manager
                          I've had a problem with the MESH not showing up, but the effect continues to work without it. On the station I was working on, Liquify didn't show the mesh in any resolution in any comp. I didn't make a note of the AE build.

                          I attributed it to a Graphics card or display error, because the same version had worked before for me.

                          What happened was that the mesh would appear until it was distorted. The regular grid was fine, but when it was distorted, a hole would appear - as if the mesh were erased, but the image was distorted underneath (as it should be).

                          All other functions in Liquify worked as expected even without a visible mesh.
                          • 10. Re: Liquify stops working
                            Andrew Yoole MVP & Adobe Community Professional
                            Andy - just a thought. Perhaps you've accidentally switched to Layer view (usually by double-clicking the layer at some point)? That will disable all the Liquify tools, until you return to the Comp view.

                            Just thinkin' out loud.
                            • 11. Re: Liquify stops working
                              Andy Bay Level 1
                              Hi and thanks for your input!

                              Layer view doesn't seem to be the case, I double checked this thing many times. I'm left to believe there is something in the project settings or that the project has become corrupted in some way. I started a totally new project with all the same files, and in this new project liquify works again..

                              One thing that I did in the problematic project that was a bit unusual is that I duplicated the comp I was working for and made some changes to this duplicated comp to see different results. It is a strech, but do you think it could have anything to do with the matter?
                              • 12. Re: Liquify stops working
                                Mylenium Most Valuable Participant
                                Anything is possible. Since Liquify uses compound keyframes and large chunks to store its data, duplicating a layer or comp with it could potentially not correctly duplicate those data structures. It's still a bug, though, and a severe one at that, so I still recommend you send in the faulty project for analysis.

                                Mylenium
                                • 13. Re: Liquify stops working
                                  Andy Bay Level 1
                                  Will do that! Thanks for everyone for trying to help!
                                  • 14. Re: Liquify stops working
                                    Ferguda123 Level 1

                                    Did anyone ever figure out this bug?   I'm running into the same issue.  I have an arrow cursor but no brush.  I've run through the same troubleshooting methods above.

                                    • 15. Re: Liquify stops working
                                      Mashup_Man Level 1

                                      For what it's worth, I'm experiencing the exact same problem in After Effects CC. What's curious in my case is that the liquify tool refuses to work only on one specific composition within my project. Works like a hot damn on my other ones. This is a serious and baflling bug. How do we report it?

                                      • 16. Re: Liquify stops working
                                        Andrew Yoole MVP & Adobe Community Professional

                                        As Mylenium posted above, report bugs and feature requests here.

                                        • 17. Re: Liquify stops working
                                          Mashup_Man Level 1

                                          Thank you, Andrew. I missed the URL Mylenium had provided above. Was scanning for a hyperlink.

                                          • 18. Re: Liquify stops working
                                            Alex Fall

                                            I hope this helps, I had this problem using liquify in CS5.5 and found it woud not show the liquify tool brushes. When I applied the effect to other layers in other comps it worked. So I copied the layers from the comp that woudn't work into a new comp and the effect was usable again. I hope that work best of luck

                                            • 19. Re: Liquify stops working
                                              Mashup_Man Level 1

                                              I appreciate the tip, Alex. Thanks! I'll definitely try that the next time it acts up.

                                              • 20. Re: Liquify stops working
                                                xardasrs Level 1

                                                Hi all,

                                                 

                                                I run into the same problem (Liquify-tool not usable). After 20 minutes of research I solved it.

                                                The button "Toggle Mask and Shape Path Visibility" in the "Viewer"-window was disabled.

                                                Activating this button resolved the problem and I could use the liquify-tool as usual.

                                                 

                                                Best,

                                                Stefan

                                                • 21. Re: Liquify stops working
                                                  ckingfilm Level 1

                                                  Oh my god THANK YOU, xardasrs. This solved it for me entirely.

                                                   

                                                  For anyone wondering the "Toggle Mask and Shape Path Visibility" is in the lower left-hand corner of the composition window:

                                                   

                                                  Screen Shot 2014-12-20 at 11.32.32 AM.png

                                                   

                                                  You can also hit SHIFT+CMD+H on mac to toggle the outlines of the layers and masks ON and OFF---this creates/solves the same situation regarding the Liquify tool.

                                                  1 person found this helpful
                                                  • 22. Re: Liquify stops working
                                                    ignatb16649679 Level 1

                                                    Hahahaha, THANK YOU !

                                                    • 23. Re: Liquify stops working
                                                      andrews20677379

                                                      Thank you!

                                                      • 24. Re: Liquify stops working
                                                        darionLeigh333

                                                        You genius - thank you!