4 Replies Latest reply on Aug 11, 2008 11:34 AM by Mylenium

    Rendering and working with AE is very slow.

    Level 1
      Hey guys,

      I'm running on Windows XP Pro, Intel Core 2 Quad CPU, Q6600 @ 2.40Ghz, Clockspeed; 2,40Ghz, 3GB RAM. Whenever I'm working in AE it's very slow to use in full resolution. When I lower the resolution I still have to wait for the preview screen to 'load'. This is very annoying in a work situation. Am I doing something wrong? My pc is very fast with other 'heavy'programs.
        • 1. Re: Rendering and working with AE is very slow.
          Level 1
          You're pretty low on RAM. Do you have Multiprocessing turned off in your preferences?
          • 2. Re: Rendering and working with AE is very slow.
            Level 1
            I forgot to say it's DDR2 RAM. I hadn't enabled Multiprocessing. Now I have but there isn't much difference. When I looked for the Multiprocessing menu, I came across a bunch of other very important menus of which I wasn't aware of. I'm not sure what to enter though.

            For example, the memory & cache menu says;

            Maximum memory usage; 120% = 2GB.
            Maximum RAM cache size; 100% = 2GB.

            It also says Enable Disk Cache, but when I enable it, it asks me to select a folder. I'm not sure which folder I have to choose. I tried my main hard drive but that didn't work. I got an error message saying I have to choose a folder WITHIN that volume. Which one?

            I also don't know what to select in the Previews menu and what to enter in the OpenGL menu. What are the best settings for all of this?
            • 3. Re: Rendering and working with AE is very slow.
              Level 1
              Also, for some reason the info box says there's insufficient RAM eventhough it's only using 44% of my RAM. Also, it says Multiprocessing is off butit is enabled. What's up with that?
              • 4. Re: Rendering and working with AE is very slow.
                Mylenium Most Valuable Participant
                AE will auto-disable MP if it does not detect enough RAM. You can still toggle it, but AE won't use it in any case. You could only change that by flipping some switches in your BIOS (if it supports this) that will make your 4 cores appear as only 2 cores or one core even, but this has some other side effects like possibly requiring a full re-install of your entire system...

                The disk cache should be located on the fastest disk in your system. Doesn't matter which one, as long as it has enough space and is permanently available. Even a network drive or external disk would work. The only requirement is to create a dedicated directory for it. you can call it "Mom" or "Popsi" - doesn't matter. Calling it "AE Cache" would be smarter, though. ;-)

                As for the rest: Don't expect miracles. Processing an x number of pixels can take its time, especially with some effects and in 32bpc mode.

                Also be aware that, while AE will handle it, some compressed formats do not lend themselves for working interactively. AE needs to conform them and it will take time to look up the correct time index. This is further complicated if you have lots of clips or rather long clips. You can improve these behaviors sometimes by capturing to different CoDecs or converting the footage.

                Part of the problems also may come from the graphics card. Even without OpenGL, AE will use your hardware to decode certain formats if possible and also for accelerated drawing. If your graphics are not up to snuff, have a bad driver or simply are configured poorly, they may have the opposite effect and instead of accelerating your workflow slow it down...

                Lastly, make sure your system is in good shape. Work off the fastest disks, clean them regularly of temporary files, defragment them and make sure their RAID/ SATA drivers and configuration are flawless.

                Mylenium