3 Replies Latest reply on Sep 10, 2008 10:09 PM by Mylenium

    strange error

      hey, has anyone gotten this error:

      After Effects Error: Levels returned invalid max_result_rect from PF_Cmd_SMART_PRE_RENDER

      i cant seem to lock it down to any specific filter. i have a 4k 16bit comp with unsharpmask on an adjustment layer, when i turn that layer off it will work, but then the error will crop up again even without the layer on. also it only seems to be happening in 2 scenes, all of my scenes are using unsharp mask.

      anyone know what i should be checking?

      intel mac
      2 x 3.2 GHz quadcore
      16GB 800 MHz DDR2 FB-DIMM
      OSX 10.5.4
      AE 8.0.2.27
      quicktime 7.5 (149.5)
        • 1. Re: strange error
          Mylenium Most Valuable Participant
          It tells you that the layer bounding box is too small to accommodate the results of the edge convolution kernel. This is a "hard" bug, so there's no real workarounds. You might try to pre-compose to enforce a different processing order, but if that doesn't work, either, then I'm afraid you'll have to resort to third-party products. You could e.g. use Sapphire Sharpen. If you download the trial and use, you can at least get the project out of the door and ponder on other solutions later...

          Mylenium
          • 2. Re: strange error
            Level 1
            hmmm i have done the precomp thing too... do you think the radius setting of the filter could affect it? thanks for the suggestion on sapphire... i will check that out
            • 3. Re: strange error
              Mylenium Most Valuable Participant
              Yes, of course the radius is the decisive factor. In effect it can increase your image dimensions by a considerable amount, which, if not programmed "safe" can have some side effects as the ones you're seeing.

              Mylenium