23 Replies Latest reply on Jun 28, 2017 4:24 AM by Lionarith

    Can't select keyframes

    Level 1
      I noticed someone else had a very similar problem back in February, but had just upgraded to CS3 and opened a 6.5 file. I'm working on a file I just began a couple of days ago in CS3 and have begun having the same problem today.

      The problem is that at seemingly random times, keyframes that I've been moving back and forth to tweak suddenly cease to be selectable. If I singe-click on them with either mouse button, nothing happens. If I double-click on them with either mouse button, the current setting dialogue box pops up. BUT--if I drag a marquee around one or more of them, they will get selected--I just can't move them.

      I'll drag a keyframe or keyframes one way, it won't be quite right, so I'll try to drag them back, and suddenly some of them won't go, and when I try to select them singly, they just stay gray. They show up in the graph editor, but I can't move them there either. I have no idea what's going on.

      Anybody else know what's going on?

      Thanks,

      Clint
        • 1. Re: Can't select keyframes
          Mylenium Most Valuable Participant
          It's a bug in the timebase calculations that happens under a number of circumstances including

          - time-stretched items
          - time-remapped items
          - mixing compositions with different framerates, in particular mixing non-integer (e.g. 23,96fps) with full integer (24fps) ones

          To cut a long story short: nothing you can do but delete the keyframes and create them again (and wait for CS4 to arrive in the hope it is finally fixed)

          Mylenium
          • 2. Re: Can't select keyframes
            Level 1
            Thanks much for the quick response. I don't understand why they'd be happening with this project, since none of the circumstances you list are anything I've done. It's a single composition, all at the same frame rate, and they're getting screwed up *within a layer.* And also, it's the first time it's happened. I've done numerous projects with AE CS3 now, and it's just starting now.

            As for your solution, that's what I've been having to do, so I guess I'll just have to keep doing it. Bugger.

            Thanks again for the reply.

            Clint
            • 3. Re: Can't select keyframes
              Mylenium Most Valuable Participant
              Well, the list is not complete, just covering a few options. Perhaps in your case you created the comp at a different framerate, then adjusted it later after you already had moved keyframes. In that case, they too might have ended up "somewhere inbetween", not being movable. I agree, it's damn inconvenient, no matter what the reason and excuse.

              Mylenium
              • 4. Re: Can't select keyframes
                Level 1
                Nope, haven't adjusted the frame rate of the composition, either. At least not consciously. And definitely not between moving frames. It's like by moving them around I'm doing something to them. I'm not doing anything different than I have in any other AE project I've created. I'm stumped.

                I know it's something within the file, because I opened it in AE *on a different Mac* and the keyframes are still un-selectable.

                Thanks again for the suggestions. I'm just about to start over.
                • 5. Re: Can't select keyframes
                  (Steve_Patterson) Level 1
                  Did you time stretch your keyframes perhaps?
                  You know, when you have multiple keyframes selected, hold down alt (PC), click on an end keyframe, and drag? Sometimes this can create weird keyframe/timeline related errors. Just out of curiosity, have you tried increasing the frame rate of your comp to see if you can then access the frozen keyframes?
                  • 6. Re: Can't select keyframes
                    Level 1
                    I've dragged multiple keyframes several times, but not while holding the option key (I'm on a Mac). I'll change the frame rate just to check, but I've not messed with that before. Can I then put it back to 29.97 afterward? And can I not move multiple keyframes at once without screwing up the frame rate?

                    I'll check it out now.
                    • 7. Re: Can't select keyframes
                      Level 1
                      Nope, that didn't work either. I just increased the frame rate to 60 and they're just as unselectable and immobile. I just don't know.

                      Thanks for the suggestion.
                      • 8. Re: Can't select keyframes
                        Jonas Hummelstrand Level 2
                        Try clicking on the property's name in the Timeline window, which will select all the keyframes of that property. Then cut them with Ctrl-X / Cmd-X and paste them back.

                        - Jonas Hummelstrand
                        http://generalspecialist.com/
                        • 9. Re: Can't select keyframes
                          Level 1
                          A-ha. Some progress here. Doing that made some of the previously inaccessible frames accessible again, but not all of them. I have opacity property that fades in, holds steady for a few seconds, then fades out. Before the cut/paste, all but the first one wouldn't let me grab them. After the cut/paste, only the last one, the final out keyframe, remained inaccessible. So something about the cut/paste frees some of them up.

                          What does that mean?
                          • 10. Re: Can't select keyframes
                            Level 1
                            UPDATE: I just cut and pasted that last keyframe that I couldn't access and that made it accessible as well.

                            Thanks, thanks, a million times thanks for the suggestion, but what on earth is going on that that's fixing the problem?

                            Clint
                            • 11. Re: Can't select keyframes
                              Level 1
                              UPDATE 2: Okay, it doesn't work in all cases. One "in" keyframe doesn't want to play along. Cut, paste, still inaccessible. But to the degree that it works, I'll take it.
                              • 12. Re: Can't select keyframes
                                Ben_Day Level 1

                                Crazy! This issue originally came up in 2008 and here I am having the same issues with AE CC in 2014. Randomly some keyframes can't be selected or moved. Copying/deleting/pasting the keyframes helps sometimes. Any other solutions out there?

                                • 13. Re: Can't select keyframes
                                  zuhloobie Level 1

                                  I am having the same issue - AE CS6

                                  • 14. Re: Can't select keyframes
                                    SteveBlacker Level 1

                                    This is happening in AE CC 2014 for me too. 

                                    • 15. Re: Can't select keyframes
                                      SteveBlacker Level 1

                                      I have found that if you hold down alt+left/right arrow keys to move the keyframes in question, it seems to free them up.  Weird bug.  In my case, I *did* change the frame rate during the project.  Still, that shouldn't lock the keyframes.

                                      • 16. Re: Can't select keyframes
                                        steveohm2 Level 1

                                        I also have this problem and have randomly had it for over a year on multiple machines, home and office. Thanks Blacker, but the alt left right doesn't work for us since we can't actually select the keyframe. In my case now, I have an audio track, so frame rate should'nt be an issue (though I do have have mixed frame rates in the comp). On this particular layer I can select the first two keyframes, but not the last two. ...An interesting discovery - I can select it by dragging a selection box around it rather than clicking on it. But even selected I can't move it... BUT if I use Blackers trick and option-shift-arrow move it, it's suddenly a well-behaving keyframe and I can do what I need. This is a horribly desperate work-around for a bug that that's been around SEVEN years.

                                         

                                        Side note: I've also been experiencing the dreaded sticky-cursor when using AE - a click acts like it's held down and creates a selection box (again, multiple machines, multiple versions, multiple years) - only on wacom and only in AE, not mouse - so I suspected the unselectable keyframes might also a wacom issue. To test I removed wacom, which resolves the sticky cursor, but no effect on the "unselectable keyframe" issue.

                                         

                                        I'd like to think CC 2015 would fix the problem, but I tried that, for one day, as-of 7/2015 it wasn't worthy of beta status. Love ya Adobe, but let's fix some of these legacy issues first.

                                         

                                        Imac 27" 2013

                                        Yosemite 10.10.4

                                        AE vers13.0.0.214 (Again, have had this problem for several versions, I updated yesterday, but apparently there's yet another update today)

                                        Wacom (but tested with and without)

                                        Plugins (some installed, but none on this layer and I think none in this comp)

                                        Pro user

                                        • 17. Re: Can't select keyframes
                                          hairygrak Level 1

                                          If it's of any use: I've had the same error in CC 2015 (adjusted the speed of a clip in Premiere, imported to AE, keyframes don't react to right click) and precomping the clip fixed the problem.

                                          • 18. Re: Can't select keyframes
                                            MMazor Level 1

                                            Same issue on latest version of AE 13.7.0.124

                                            Time-stretched clip not allowing to select Scale Keyframe.

                                            • 19. Re: Can't select keyframes
                                              darrellhaemer Level 1

                                              Pretty amazing this is still happening in 2017. I just experienced a stuck "in" keyframe like Clint Hayes mentioned. Fortunately, cutting and pasting unstuck it. Before that though, I had already tried deleting and re-creating the keyframes, duplicating the layer and re-creating the keys, duplicating a different (but similar) layer and re-creating the keyframes, and I had the same exact issue every time!

                                              • 20. Re: Can't select keyframes
                                                Roei Tzoref Adobe Community Professional

                                                How about in 14.2? An update was released a few days ago. Is this still happening? If so, please provide the exact steps to reproduce this bug and write them here for other users to be aware of. As for the fix, please report this bug here: Feature Request/Bug Report Form so they may actually fix it. in the report, a link to this thread would help also.

                                                • 21. Re: Can't select keyframes
                                                  darrellhaemer Level 1

                                                  Yes, in 14.2.0.198. This happened to me just last night with AE being fully up-to-date.

                                                   

                                                  Unfortunately, I don't know if there's a simple collection of steps to reproduce the bug. It didn't happen until I had a moderately complex project put together. Once it happened, it did continue to happen with more frequency, but not with much consistency. Sorry!

                                                  • 22. Re: Can't select keyframes
                                                    Roei Tzoref Adobe Community Professional

                                                    Thank you darrellhaemer. this never happened to me in Ae so if you or anyone else seeing this can get a chance to figure out the steps to reproduce it, please do so that we all learn how to avoid it maybe and fix it of course.

                                                    • 23. Re: Can't select keyframes
                                                      Lionarith Level 1

                                                      Just happened to me also, i cannot drag or select any keyframe in the project. Didn't do anything new, feels random. Serious bug Adobe...