1 Reply Latest reply on Sep 11, 2008 8:18 AM by riesvantwisk

    BlazeDs General Messaging Error

    hilalsofu
      hey to all,

      I am trying to call a method from server side; that I wrote in Java and deployed to tomcat via BlazeSpringFactory.
      When I call that method from flex i get this error:


      BlazeDS][ERROR] [Message.General] Error handling message: flex.messaging.MessageException: Cannot invoke method 'getAssetDevices'. Method 'getAssetDevices' not found.
      incomingMessage: Flex Message (flex.messaging.messages.RemotingMessage)
      operation = getAssetDevices
      clientId = D57B6468-1108-8A53-A9DA-E81FBFC9AAB1
      destination = NousfluxService
      messageId = 4A7FEC2B-0F48-A8B6-FEBC-31DA4F153758
      timestamp = 1220607102936
      timeToLive = 0
      body = null
      hdr(DSId) = D57B6382-930B-05E6-5ED3-207959DD7E53
      hdr(DSEndpoint) = my-amf
      errorReply: Flex Message (flex.messaging.messages.ErrorMessage)
      clientId = D57B6468-1108-8A53-A9DA-E81FBFC9AAB1
      correlationId = 4A7FEC2B-0F48-A8B6-FEBC-31DA4F153758
      destination = NousfluxService
      messageId = D5B5FCF3-3A0B-C271-13B3-1C122AE53D05
      timestamp = 1220607102938
      timeToLive = 0
      body = null
      code = Server.ResourceUnavailable
      message = Cannot invoke method 'getAssetDevices'.
      details = Method 'getAssetDevices' not found.
      rootCause = null
      body = null
      extendedData = null



      however, I have already called other methods from my service, NousfluxService; and they r working well.

      what is the problem with this method , 'getAssetDevices' ?

      please help
        • 1. Re: BlazeDs General Messaging Error
          riesvantwisk
          check if the parameters are correctly for getAssetDevices


          if you send a string into getAssetDevices, and your function declaration of getAssetDevices is set as a integer then it might fail.



          public void getAssetDevices(int value) {
          ....
          }

          and from AS you call it like this:
          remoteObject. getAssetDevices("10"); it might fail.

          it's hard to diagnose this with little information....

          Ries