0 Replies Latest reply on Sep 2, 2008 8:36 AM by kilyas2007

    HTTPS on IE

    kilyas2007 Level 1
      I have an Adobe flex app built as an ear file running on a JBOSS app server. The problem is that I can access it via http on both IE and Firefox but with https it works only on firefox. The crossdomain file is as follows:-

      <?xml version="1.0"?>
      <!DOCTYPE cross-domain-policy SYSTEM " http://www.macromedia.com/xml/dtds/cross-domain-policy.dtd">
      <cross-domain-policy>
      <allow-access-from domain="*" secure="false" />
      </cross-domain-policy>


      The html file embedding the swf uses object tag as follows:-
      <object
      id="Cairo" width="100%" height="100%"
      codebase=" http://fpdownload.macromedia.com/get/flashplayer/current/swflash.cab">
      <param name="movie" value="Cairo.swf" />
      <param name="quality" value="high" />
      <param name="bgcolor" value="#869ca7" />
      <param name="allowScriptAccess" value="sameDomain" />
      <embed src="Cairo.swf" quality="high" bgcolor="#869ca7"
      width="100%" height="100%" name="Cairo" align="middle"
      play="true"
      loop="false"
      quality="high"
      allowScriptAccess="sameDomain"
      type="application/x-shockwave-flash"
      pluginspage=" http://www.adobe.com/go/getflashplayer">
      </embed>
      </object>

      and the web.xml file is as follows:-
      <?xml version="1.0" encoding="UTF-8"?>
      <web-app id="WebApp_ID" version="2.4" xmlns=" http://java.sun.com/xml/ns/j2ee" xmlns:xsi=" http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation=" http://java.sun.com/xml/ns/j2ee http://java.sun.com/xml/ns/j2ee/web-app_2_4.xsd">
      <display-name>bizAppWar</display-name>
      <security-constraint>
      <web-resource-collection>
      <web-resource-name>All resources</web-resource-name>
      <description>Protects all resources</description>
      <url-pattern>/*</url-pattern>
      </web-resource-collection>

      </security-constraint>
      <welcome-file-list>
      <welcome-file>bizApp.html</welcome-file>
      </welcome-file-list>
      </web-app>


      Please advise what do I need to do to get it working om https on IE browser. Thanks in advance