3 返信 最新の回答 日時: Apr 5, 2004 5:04 PM ユーザー:(xig)

    Adobe Reader 6.0.1にV.UP後Webブラウザ上でPDFが開かない。

       私が担当しているお客様のPCで、先日Acrobat Reader 5.0.5->Adobe Reader 6.0.1に
      入替えたのですが、その後IE上で.pdfのボタンをクリックしてもReaderが開かず、×表示と
      なってしまいます。
       本件、既出のレジストリを見てみようと思ったのですが、
      >HKEY_CLASSES_ROOT¥Software¥Adobe¥Acrobat¥Exe
      の、Softwareの下にAdobe又はAcrobat等の項目が無いので、変えようが無い状態です。
      アプリの関連付けの問題かと思いましたが、マイコンピュータのフォルダオプションから
      ファイル一覧を見る限りでは、関連付けされている様に見えます(他の確認方法が分りません)。
       下記に分かる範囲の環境を記しますので、どなたか気づいた点がありましたらご教示願います。

      使用PCのOS:WinXP Pro SP1
      使用中のIE:IE6.0 SP1
      インストール済みの他のAdobe製品:
      Photoshop Elements 2.0

      ちなみに、ローカルのデスクトップに保存し、それをダブルクリックすると
      Adobe Reader 6.0が起動し、読めます。ダメなのはIE上で.pdfのファイルをクリックした時だけで、
      現象的にはプラグインの入っていない状態でjpgを開こうとした時の様に、
      IEの枠下のURL等を表示される部分には、2秒ほど「ダウンロードしています」という表示が見えるが、その後赤文字で「×」が表示されることです。

      補足として、6.0.1のインストール方法は、一度5.0.5を「アプリケーションの追加と削除」からアンインストールし、その後6.0.1をインストールしております。
        • 1. Re: Adobe Reader 6.0.1にV.UP後Webブラウザ上でPDFが開かない。
          Level 1
          本来あるべき?レジストリがないのであれば、(私の環境WinXP Pro SP1にはあります)
          インストールに失敗しているのではないでしょうか。

          >アプリの関連付けの問題

          HKEY_CLASSES_ROOT¥Software¥Adobe¥Acrobat¥Exe
          ココは、ダブルクリックで呼び出される関連づけとは違うところのようです。
          理由:関連づけをReaderに変えてもブラウザ内でAcrobatが起動する。

          1)(自己責任で)レジストリを手動で追加してみる
          2)インストールをやり直してみる

          ってとこでしょうか。

          ウイルス対策ソフト、
          ノートンユーティリティ的なソフト、
          インストール監視ソフトの類は停止してからインストールしましたよね?

          MsconfigでMicrosoft以外のサービスを無効。
          スタートアップを無効にしてインストールするのもいいと思います。
          • 2. Re: Adobe Reader 6.0.1にV.UP後Webブラウザ上でPDFが開かない。
            Level 1
            早速のご回答ありがとうございます。
            来週また客先に伺う予定なので、その際再インストールをやってみます(既に稼動中の為、レジストリの変更は怖くてできません)。
             ちなみに、インストールした時はウィルス対策ソフトは停止させております。
            もしそれでもダメなら、5.0に戻す方向で考えます。
            • 3. Re: Adobe Reader 6.0.1にV.UP後Webブラウザ上でPDFが開かない。
              自分自身の問い合わせでも書いたのですが
              Reader5.05などから6へバージョンアップするとブラウザ上でのPDFの関連付けがおかしく
              なる様です。
              当方、IEとNCを使っているのですが
              両方とも関連付け自体が消えてしまいました。
              その際に
              6を削除→5.05を削除→6をインストール
              をすれば問題解消されました。
              同等の手順で直るか分かりませんが
              一度お試しください。