5 返信 最新の回答 日時: Jul 26, 2007 8:39 AM ユーザー:(turu)

    FirefoxでFlash Playerを使う場合

      ブラウザーとしてFirefoxを使っています。
      しかし、Flash Playerをインストールすると、
      Firefoxが起動しません。
      どなたか知識のある方、アドヴァイスをお願いします。
      ちなみに、「Fierfoxが原因で、KRN386.EXEにエラーが発生しました。Firefoxは終了します」という、エラーメッセージが出ます。
        • 1. Re: FirefoxでFlash Playerを使う場合
          Flash Playerをupdateしたら、同様の
          症状がでるようになりました。
          OS : Windows 98SE 日本語版
          Browser : Firefox 2.0.0.3 (1.5系でも同じ)
          Flash Player : 9.0.45
          • 2. Re: FirefoxでFlash Playerを使う場合
            Windows XP SP2
            Firefox 2.0.0.3
            Flash Player 9,0,45,0
            ですが、特に問題なく動作しているようです。OSの差でしょうか。

            ネットを調べてみたところ、
            1)
            http://www.adobe.com/jp/shockwave/download/alternates/
            から、Flash Playerのアンインストーラをダウンロードしてアンインストール
            2)
            Firefoxを再インストール
            すると、回避できるケースがあるようです。

            もしくは、あまりおすすめできませんが
            http://www.adobe.com/jp/support/flashplayer/ts/documents/tn_14266.htm
            ここから旧バージョンをインストールして回避、という方法もあるかもしれません。

            現象に会ったことがないので、推測ですみません。
            • 3. Re: FirefoxでFlash Playerを使う場合
              私も昨日、Firefox 2.0.0.4 (Windows 98) で、Flash Player を
              最新版の Flash Player 9.0.45.0 にバージョンアップさせたら、
              同じようなエラーが発生するようになりました。

              どうやら、このバージョンのプラグインを使って、フラッシュを使用したページを開くと
              「Fierfoxが原因で、KRN386.EXEにエラーが発生しました。Firefoxは終了します」
              のような不具合が発生するようです。

              なお、Flash Player 9.0.45.0 をインストールしていても、フラッシュが使用されていない
              ページなら、エラーなく表示されます。

              また、フラッシュが使用されているページであっても、Flash Player 9.0.45.0 を
              アンインストールしていれば、エラーは発生しません。
              (もちろん、フラッシュの部分は、表示されませんが…)

              ここで一番気になるのは、プラグインのファイル(NPSWF32.dll)を
              エクスプローラで選択し、そのファイルのプロパティを表示させた後に
              [バージョン情報]のタブをマウスでクリック ⇒ 表示させようとすると
              エクスプローラがエラーを起こし、強制終了してしまうことです。

              そのため、Flash Player 9.0.45.0 のファイル(NPSWF32.dll)は、
              Windows 98 上では、正常に動作しないのでは?と推測しています。

              試しに、Flash Player 9.0.45.0 の直前のバージョンを
              インストールして、同じ様なエラーが発生するかどうか
              実験してみたいのですが、少し古い Flash Player 9.0.xx.0 を
              入手する方法は、ないのでしょうか?
              • 4. Re: FirefoxでFlash Playerを使う場合
                Level 1
                Flash Player 9.0.45.0 が、
                Firefox 2.0.0.4 (Windows 98) 上で、正常に動作しない件についてですが、
                つい先ほど、1つ前のバージョンをインストールすることができました。
                その結果、前のバージョンでは、不具合が発生しないことが分かりました。

                つまり、(私の使用しているPC環境では…)

                ●Flash Player 9.0.45.0 は、
                 Firefox 2.0.0.4 (Windows 98) 上では、正常に動作しない。
                ⇒フラッシュが使用されているページを参照すると
                 Firefoxでエラーが発生し、強制的にブラウザが終了する。
                ⇒エクスプローラで、NPSWF32.dll ファイルのプロパティを
                 参照し、[バージョン情報]を見ようとすると
                 エクスプローラがエラーになり、強制終了してしまう。

                ●Flash Player 9.0.28.0 は、
                 Firefox 2.0.0.4 (Windows 98) 上でも、正常に動作する。
                ⇒フラッシュが使用されているページを参照しても
                 エラーは発生せず、正常に表示できる。
                ⇒エクスプローラで、NPSWF32.dll ファイルのプロパティを
                 参照し、[バージョン情報]を普通に見ることができる。

                ということです。

                以上のことから、Flash Player 9.0.45.0 には、
                致命的な欠陥が含まれている可能性があります。

                次のバージョンでは、この不具合が解消されていることを
                期待しつつ、今のところは、1つ前のバージョン (Flash Player 9.0.28.0 ※) を
                使用し続けていこうと思っています。

                ※Flash Player 9 の過去のバージョンのインストールファイルは、
                http://fpdownload.macromedia.com/get/flashplayer/installers/archive/fp9_archive.zip
                 から入手できました。
                • 5. Re: FirefoxでFlash Playerを使う場合
                  こちらibookG4環境ですが、同様の現象が起きています。Flash Player 9.0.47.0でも同じ現象が起きていますので(win環境では発生しておりません。)、Flash Player 9.0.47.0でwin環境のバグは取れたと思うのですが、mac環境はまだ発生しています。
                  仕事でデバッグが出来ないで困ってしまいます。
                  早く修正したバージョンにアップデートしてほしいです。