9 Replies Latest reply on Mar 11, 2009 2:07 PM by earlbolo

    Visual Studio 2008 Debugger Kills Dreamweaver

    IowaDave
      All of a sudden I'm getting the following error:

      An unhandled win32 exception has occurred in Dreamweaver.exe[random number]

      When I answer no (or yes) to debugging, Dreamweaver closes. It happens when I highlight any number of characters in my file, whether in code or design mode.

      I, for the life of me, can not figure out why the VS2008 debugger is firing and why it's killing Dreamweaver. I've done enough Googling of my error to know this "exception" has caused many others grief as well. I've tried turning this debugger off but I still get the error (or a Windows error which also closes it).

      My programming is at a standstill. If anyone has ideas, I'd appreciate it. It's extremely frustrating. It just started doing this out of the blue. All I wanted to do was hyperlink something... I don't remember ever seeing this problem before installing Visual Studio.

      Thanks,
      Dave
        • 1. Re: Visual Studio 2008 Debugger Kills Dreamweaver
          Level 7
          Try disabling the bedugger in IE.

          Start IE, In tools go to the advance tab, In there in browsing check the box
          related to debugging in IE and check debugging in other.

          aka Frenchy ASP
          "IowaDave" <webforumsuser@macromedia.com> wrote in message
          news:gevfkj$b4r$1@forums.macromedia.com...
          > All of a sudden I'm getting the following error:
          >
          > An unhandled win32 exception has occurred in Dreamweaver.exe[random
          > number]
          >
          > When I answer no (or yes) to debugging, Dreamweaver closes. It happens
          > when I
          > highlight any number of characters in my file, whether in code or design
          > mode.
          >
          > I, for the life of me, can not figure out why the VS2008 debugger is
          > firing
          > and why it's killing Dreamweaver. I've done enough Googling of my error
          > to
          > know this "exception" has caused many others grief as well. I've tried
          > turning
          > this debugger off but I still get the error (or a Windows error which also
          > closes it).
          >
          > My programming is at a standstill. If anyone has ideas, I'd appreciate
          > it.
          > It's extremely frustrating. It just started doing this out of the blue.
          > All I
          > wanted to do was hyperlink something... I don't remember ever seeing this
          > problem before installing Visual Studio.
          >
          > Thanks,
          > Dave
          >


          • 2. Re: Visual Studio 2008 Debugger Kills Dreamweaver
            IowaDave Level 1
            That was a common solution in many postings, but unfortunately, one that doesn't work. The debugger still pops up. It works when the error message occurs in IE, but unfortunately, not in Dreamweaver, even if "other" is selected. I've been searching for other ways to stop the debugger, short of uninstalling VS2008. There has to be a better way. Thanks for the suggestion, though.
            • 3. Re: Visual Studio 2008 Debugger Kills Dreamweaver
              Level 7
              I have VS2008 enterprise installed on my PC and I don't have this problem at
              all. And I dont remember how I have set up the debugger option when
              installing.

              Try this. Go in your service and check to see if remote debug service is
              disable or not. If it is runnung stop the service and try again.
              And try creating a new page HTML with no script and put some content without
              any script. Does it do it?

              Will look further
              "IowaDave" <webforumsuser@macromedia.com> wrote in message
              news:gevkka$him$1@forums.macromedia.com...
              > That was a common solution in many postings, but unfortunately, one that
              > doesn't work. The debugger still pops up. It works when the error
              > message
              > occurs in IE, but unfortunately, not in Dreamweaver, even if "other" is
              > selected. I've been searching for other ways to stop the debugger, short
              > of
              > uninstalling VS2008. There has to be a better way. Thanks for the
              > suggestion,
              > though.
              >


              • 4. Re: Visual Studio 2008 Debugger Kills Dreamweaver
                Level 7
                Ok try this
                Right click on my computer and select properties > Advance > Performance >
                Setting. In there select the DEP setting (last tab). And click Turn on DEP
                for all programs and services except those I select. Click add and select
                DW.

                DEP monitor the memory usage and prevent somme applications to use the
                memory in a weird way. This will also cause VS debugger to lunch (??????).
                So by disabling the DEP for DW it should stop the debugger.

                See if this help
                aka Frenchy ASP.

                "Alain St-Pierre" <alainetcolleen@hotmail.com> wrote in message
                news:gevlit$ivm$1@forums.macromedia.com...
                >I have VS2008 enterprise installed on my PC and I don't have this problem
                >at all. And I dont remember how I have set up the debugger option when
                >installing.
                >
                > Try this. Go in your service and check to see if remote debug service is
                > disable or not. If it is runnung stop the service and try again.
                > And try creating a new page HTML with no script and put some content
                > without any script. Does it do it?
                >
                > Will look further
                > "IowaDave" <webforumsuser@macromedia.com> wrote in message
                > news:gevkka$him$1@forums.macromedia.com...
                >> That was a common solution in many postings, but unfortunately, one that
                >> doesn't work. The debugger still pops up. It works when the error
                >> message
                >> occurs in IE, but unfortunately, not in Dreamweaver, even if "other" is
                >> selected. I've been searching for other ways to stop the debugger, short
                >> of
                >> uninstalling VS2008. There has to be a better way. Thanks for the
                >> suggestion,
                >> though.
                >>
                >
                >


                • 5. Re: Visual Studio 2008 Debugger Kills Dreamweaver
                  Level 7
                  I should have been more precise. If DEP is configure for "Turn on DEP
                  > for all programs and services except those I select." Select the first
                  > choice instead. Wich is for essential Windows programs and services only.
                  And try again.

                  "Alain St-Pierre" <alainetcolleen@hotmail.com> wrote in message
                  news:gevn0j$kt9$1@forums.macromedia.com...
                  > Ok try this
                  > Right click on my computer and select properties > Advance > Performance >
                  > Setting. In there select the DEP setting (last tab). And click Turn on
                  > DEP for all programs and services except those I select. Click add and
                  > select DW.
                  >
                  > DEP monitor the memory usage and prevent somme applications to use the
                  > memory in a weird way. This will also cause VS debugger to lunch
                  > (??????). So by disabling the DEP for DW it should stop the debugger.
                  >
                  > See if this help
                  > aka Frenchy ASP.
                  >
                  > "Alain St-Pierre" <alainetcolleen@hotmail.com> wrote in message
                  > news:gevlit$ivm$1@forums.macromedia.com...
                  >>I have VS2008 enterprise installed on my PC and I don't have this problem
                  >>at all. And I dont remember how I have set up the debugger option when
                  >>installing.
                  >>
                  >> Try this. Go in your service and check to see if remote debug service is
                  >> disable or not. If it is runnung stop the service and try again.
                  >> And try creating a new page HTML with no script and put some content
                  >> without any script. Does it do it?
                  >>
                  >> Will look further
                  >> "IowaDave" <webforumsuser@macromedia.com> wrote in message
                  >> news:gevkka$him$1@forums.macromedia.com...
                  >>> That was a common solution in many postings, but unfortunately, one that
                  >>> doesn't work. The debugger still pops up. It works when the error
                  >>> message
                  >>> occurs in IE, but unfortunately, not in Dreamweaver, even if "other" is
                  >>> selected. I've been searching for other ways to stop the debugger,
                  >>> short of
                  >>> uninstalling VS2008. There has to be a better way. Thanks for the
                  >>> suggestion,
                  >>> though.
                  >>>
                  >>
                  >>
                  >
                  >


                  • 6. Re: Visual Studio 2008 Debugger Kills Dreamweaver
                    decoymccoy
                    Hi Dave,
                    Did you get an answer to this? I'm having the same problem with 3 different workstations and it began happening at the same time (about 3 weeks ago). I've tried the DEP, but didn't work.
                    • 7. Re: Visual Studio 2008 Debugger Kills Dreamweaver
                      IowaDave Level 1
                      I'm not sure what caused the problem, but I know what fixed it. I ended up repairing Dreamweaver CS3, which the suite made pretty easy to do. I was going to uninstall DW and reinstall, but I tried the repair option first and sure enough, that fixed it. I still have no idea what caused it to begin with. Software can drive you nuts, hope you find the solution to your problem.

                      Dave
                      • 8. Re: Visual Studio 2008 Debugger Kills Dreamweaver
                        Sal_Wilson
                        I have just encountered this problem with 'unhandled win32 exception error in dreamweaver.exe' and VS2008 Debugger killing the application. I found that neither repairing/reinstalling Dreamweaver nor disabling debugging within IE fixed the problem. What has fixed the problem however is that the error was within a particular batch of files rather than with the actual application. I restored a last known good file batch from backup and everything returned to normal. It was only two corrupt files (html and css) that I was working on when the problem arose, that was causing me all the problems.
                        • 9. Re: Visual Studio 2008 Debugger Kills Dreamweaver
                          earlbolo
                          This worked for me:

                          If Dreamweaver is open, quit the application.
                          Delete the WinFileCache-AD76BB20.dat file from the Dreamweaver user configuration folder. Note that on Windows, the Application Data and AppData folders are hidden by default, so verify that your Windows Explorer folder options are set to View Hidden Folders. The location of this file is as follows:

                          Dreamweaver CS3 on Windows Vista:
                          C:\Users\[username]\AppData\Roaming\Adobe\Dreamweaver 9\Configuration
                          Dreamweaver CS3 on Windows XP:
                          C:\Documents and Settings\[username]\Application Data\Adobe\Dreamweaver 9\Configuration
                          Restart Dreamweaver.


                          Jesus Loves You!