7 Replies Latest reply on May 24, 2012 5:07 PM by WebsiteMount

    My tools have stopped working


      I have been trying to learn the Adobe Suite and when I try to click on a tool in fireworks I am unable to switch from one tool to another. For example I am able to make a donut shape but I cannot switch that to a rectangle. When I click on the donut on the tool pallette, nothing happens. Sometimes when I open Fireworks the hand is on at which time no other tools are available.


      When I first loaded the program it worked fine so this is a new problem. I have already reloaded the program and that didn't help.



        • 1. Re: My tools have stopped working
          heathrowe Most Valuable Participant

          Try resetting Fw preferences:


          Close Fw.

          Browse to the below Preference file location, as per your OS.


              Windows [Drive]:\Documents and Settings\[UserName]\Application Data\Adobe\Fireworks CS#\English\

              Mac         [User]/Library/Preferences/Adobe Fireworks CS#/en/Fireworks Preferences


          Delete the Fireworks CS# Preferences.txt file associated with your current FW version.


          Restart FW and try again.



          • 2. Re: My tools have stopped working
            ManticoreDentist Level 1

            Good call.  I've had this same infernal issue for ages in Fireworks CS3, with the Tools freezing up on opening Fireworks.  I tried your solution and it worked like a charm!


            One thing I wanted to add, since I'm now using Windows 7 (which seems to have exacerbated the issue) is that the path has changed.  There is no longer a Documents & Settings folder. 


            Win7 example...


            C: Users/[username]/AppData/Roaming/Adobe/FireworksCS3/English/Fireworks CS3 Preferences.txt

            • 3. Re: My tools have stopped working
              ManticoreDentist Level 1

              So, I need to update my last post, which said that the problem is solved based on removing the "Preferences.txt" file.


              I am very sorry to report that this file GROWS BACK.


              Yes, every time you use Fireworks CS3 it will be recreated to bedevil you anew.  You can either take the time to remove it repeatedly, or lose the use of your tools palette altogether.


              I must say this is an ATROCIOUS bug, and I am extremely frustrated by it!!


              Workarounds?  I see only 4 options:


              - Adobe issues a patch

              - Customers never close Fireworks (after deleting "preferences.txt")

              - If you are a developer, write a do-it-yourself patch that compensates for the issue by deleting the "preferences.txt" file repeatedly

              - Create a shortcut to the "English" folder, and delete this file after every use of Fireworks, or before every use of Fireworks


              Alas, I hope Adobe reads these forums... and I hope this issue doesn't exist in future releases. :\

              • 4. Re: My tools have stopped working
                Linda Nicholls Level 4

                That's not a bug. It's supposed to grow back. That's how Fireworks remembers your, er, preferences. Have you installed the CS3 updater?


                • 5. Re: My tools have stopped working
                  ManticoreDentist Level 1

                  Yeah, ideally preferences files should be a good thing.  :-)  I've not installed the CS3 Updater since switching to Win7, but will give that a shot & see if it makes any improvement.  I did have the auto-updater in XP previously, and had the same issue with tools locking up.


                  I've manually updated CS3 through Help > Updates... that did not patch the issue. 


                  Will let you know if the Updater does the trick.

                  • 6. Re: My tools have stopped working
                    ManticoreDentist Level 1

                    Linda-- unfortunately, it doesn't seem to be resolved by the CS3 Updater.  I just downloaded it, and it's still a problem for me.


                    Thanks for offering up a possible solution! 


                    Wish I knew how to describe reproducing this problem... it doesn't seem dependent on file size, number of tabs I open, time the file remains open, or anything I can nail down w/any consistency.  Typically it happens on the 3rd tab I open.  Large amounts of graphics or stuff stored in frames seem certain to blow it up. 


                    Right now my only solution is to go in & delete that txt file every few minutes then restart Fireworks.  Bah.

                    • 7. Re: My tools have stopped working

                      I know this is like almost a two years later, but I also had this issue and have searched and searched the web, found this forum post and also updated my fireworks and yet then the tools did not even show anymore... I could only not click on them before, but after the upgrade they were gone.


                      I am on a Windows 7 PC... SO I set out to lookup windows7 to see if there is any answers. ah found this: http://www.sevenforums.com/software/26957-adobe-fireworks-cs3-issue.html


                      So I set up the compatibility mode for windows7 and still it changed nothing.


                      But then in settings under compatibility I also ticked


                      • Run in 640 x 480 screen resolution
                      • Disable desktop composition


                      This worked and fireworks is working again... but man every time I start it up, boom back I go to 1990....lol


                      What I must add is I am running two monitors and so the one goes down to 640 x 480 but the other one stays in its original resolution, and if this was not so I will still not be able to use fireworks seeing the the 640 x 480 is way to small to even see the application settings, so I move the window over to the one with the normal resolution and then I can work in it as I use to before.


                      Would be great if there is a better answer out there cause this is really a pain. But until then this at least gets it to work again...