0 Replies Latest reply on Apr 8, 2009 10:33 AM by LilyGE

    Strange Permission issues with cfexchangeconnection


      I've been trying to connect to MS Exchange 2003 server version 6.5.7638.1 using cfexchangeconnection on ColdFusion Enterprise version 8,0,1,195765 on a Windows 2003 server. I've tried 5 different logins within the company. Three logins have worked fine, and 2 logins won't work at all. On the logins that don't work, I get one of the following messages:


      Cannot access Exchange server as a web application at [exchange server name].
      Ensure that the Exchange web application is configured in IIS and Web Service Extension for the Exchange server is allowed

      Could not log in to the Exchange server.
      Verify server name, username, and password.


      The code I've used (which worked fine for 3 out of 5 logins) is:

      <cfexchangeconnection action="open" connection="myExchangeConnection" server="[servername]" username="[username]" password="[password]"/>


      The network admin has matched the permissions from the working logins to the non-working ones, and it doesn't help. Though occasionally the message will change from the "cannot access" to "could not log in."


      Has anyone else had this problem? Is there anyone with expertise about what happens under the hood with permissions when cfexchangeconnection tries to connect to exchange?