5 Replies Latest reply on Apr 27, 2009 11:44 AM by arocheking

    Developers can't access CFC but users can

    Flex2k
      I am developing an application using Flex and ColdFusion. I am finished with the coding and wish to move the application to a "Production" server. To make sure Flex and ColdFusion were talking, we used the HelloWorld sample application to test the connection. HelloWorld works for me on my "Development" server, but not on the "Production" server. The real mystery is that there are no problems for other people running the production version of HelloWorld. Only myself and one other Flex developer get a "Client.Error.MessageSend" error when trying to run the application. Both the production and development versions of HelloWorld work fine for everybody else. Has anyone run into this problem and if so do you know a solution.
        • 1. Developers can't access CFC but users can
          EvolvedDSM Level 2
          Let's try to hone in on the problem.

          I've seen this app before and it uses a remoteObject. I have a hunch that if you are not specifying an endpoint URL, it's possible that when running this app on your PC, it's looking for the ColdFusion destination located on your development CF installation as well as the CFC location, rather than on the server.

          My suggestion: include endpoint="http//your_server_up:cf_port/flex2gateway/" within the remoteObject. With this line, it specifically tells the remoteObject where your CF server is.


          Some other questions that will help us:
          Do both you and your other Flex dev both have CF installed on your development PC's?

          How is your Flex app set up on your production server? Are you deploying it with a J2EE server (Tomcat, Websphere, glassfish, etc)? Or simply deploying it from IIS?

          Post back after editing your remoteObject. Also, you may wish (or need to) restart the services for both CF and your deployed IIS (web publishing) or J2EE sever. Any time I deploy an app to production, I always restart these services just to clear out any old cache info, etc.
          • 2. Re: Developers can't access CFC but users can
            Flex2k Level 1
            Thanks for responding so quickly. I did try including the endpoint within the remoteObject and recieved the same error. I cleared the cache on my browser and the server was restarted without luck.

            Our Flex developers have only Flex, not ColdFusion, on our machines. Both servers have ColdFusion and Flex installed and are using IIS. My application was created on the development server, then copied over to the production server. Being our first Flex application, the production server wasn't setup with Flex until the other day. Now that I have the application finished, our tech starting preparing it for use with Flex. The HelloWorld example works for him and anyone else, but not for the developers.

            I know the app works but it's weird that it doesn't work for myself or the other developer. I thought maybe there was some sort of service or something on our machines that wasn't running, but then the app shouldn't work when accessed through the development server?
            • 3. Re: Developers can't access CFC but users can
              EvolvedDSM Level 2
              Yes, very strange indeed. A somewhat barbaric test would be to see if uninstalling Flex on your development PC and restarting the PC would allow you to get the app working correctly. If this was the case, then you could certainly pin Flex as the culprit. However, it just doesn't make sense that Flex itself is responsible for the error.

              Can you tell me how you are connecting to your application. Are you using an IP address, domain name, computer name, etc? What port is it using in the address (the port that is assigned in IIS).

              Are you able to use other CF applications on your production server?
              • 4. Re: Developers can't access CFC but users can
                Flex2k Level 1
                After a few days of checking settings, clearing my cache and cookies, restarting my machine and various services on the severs, nothing worked. We tried again on my machine this morning it didn't work. The server administrator then checked some of my browser settings, couldn't find anything out of the ordinary, and tried the page again and it worked. We tried the page on the other developers machine and it worked also. We don't know what happened but we aren't complaining. It just is frustrating to not know in case it happens again (if we wanted to setup another server). Anyway, I appreciate all the help.
                • 5. Re: Developers can't access CFC but users can
                  arocheking Level 1

                  omg, can you please tell me how you are set up. We would love to not have everyone require local cf. Or if we still had to each have local cf, we would love to point our remote object calls to a central cf server.