2 Replies Latest reply on Sep 10, 2008 12:02 PM by Peter Lorent

    Datagrid Rendering - Adobe please respond

    dro207
      Please take a look at the example below. If wordWrap=true, there are cutoffs in the datagrid rendering.

      <?xml version="1.0" encoding="utf-8"?>
      <mx:Application xmlns:mx=" http://www.adobe.com/2006/mxml" layout="absolute">

      <mx:Style>
      @font-face {
      src: local("Calibri");
      fontFamily: CalibriEmbedded;
      fontWeight: normal;
      }

      @font-face {
      src: local("Calibri");
      fontFamily: CalibriEmbedded;
      fontWeight: bold;
      }

      Application {
      font-family: CalibriEmbedded;

      }

      DataGrid {
      verticalGridLines: true;
      verticalGridLineColor: black;
      horizontalGridLines: true;
      horizontalGridLineColor: black;
      }

      </mx:Style>

      <mx:VBox width="100%">


      <mx:Panel width="100%" title="wordWrap=true, take a look at the cutoff at the bottom!">
      <mx:DataGrid rowCount="2" width="100%" wordWrap="true">
      <mx:columns>
      <mx:DataGridColumn headerText="Column 1" dataField="col1"/>
      <mx:DataGridColumn headerText="Column 2" dataField="col2"/>
      </mx:columns>
      </mx:DataGrid>
      </mx:Panel>

      <mx:Panel width="100%" title="wordWrap=false, looks ok">
      <mx:DataGrid rowCount="2" width="100%" wordWrap="false">
      <mx:columns>
      <mx:DataGridColumn headerText="Column 1" dataField="col1"/>
      <mx:DataGridColumn headerText="Column 2" dataField="col2"/>
      </mx:columns>
      </mx:DataGrid>
      </mx:Panel>

      </mx:VBox>
      </mx:Application>