1 Reply Latest reply on Apr 15, 2009 6:01 AM by Michael Borbor

    Radio Button grouping Issue

    Ajith_Cherian

      I have specified an Itemrenderer radiobutton inside a Datagrid and have also set selected="false" for the radio button. Have also set the groupName="rbGroup". But when the data gets displayed on teh screen few of the radioButtons gets selected randomly and keeps changing each time.

      Please let me know in case if you have a solution.

       

      Code::

       

       

       

       

       

       

       

       

       

       

       

       

       

       

       

      <mx:VBox

       

      visible="true" width="80%" horizontalAlign="center" height="70%" paddingTop="30"

      >

       

       

      <mx:DataGrid id="searchResult" dataProvider="{srv.findICDCodes.lastResult}" width="100%" height="90%" visible="true" styleName="DataGrid"

      >

       

       

      <mx:columns>

       

       

      <mx:DataGridColumn width="15"

      >

       

       

      <mx:itemRenderer>

       

       

      <mx:Component>

       

       

      <mx:RadioButton x="291" y="8" groupName="rbGroup" label="rbGroup" selected="false"

      />

       

       

      </mx:Component>

       

       

      </mx:itemRenderer>

       

       

      </mx:DataGridColumn>

       

       

      <mx:DataGridColumn headerText="Source Code" dataField="sourceCode"

      />

       

       

      <mx:DataGridColumn headerText="Description" dataField="sourceDescpr"

      />

       

       

      </mx:columns>

       

       

      </mx:DataGrid>

       

       

      </mx:VBox>