0 Replies Latest reply: Apr 16, 2009 2:29 PM by mcsanders RSS

    Error: "Cannot access the web server" with BlazeDS Turnkey

    mcsanders Community Member

      Help! I'm new to Flex and BlazeDS and Eclipse.  I was trying to setup a Flex Project using a BlazeDS/Tomcat server running from Eclipse on Windows XP per the example in flexbandit.com/archives/55#comment-269 and in (www.infoq.com/articles/blazeds-intro).   I am NOT using the Eclipse Flex plug-in.  I'm using Flex Builder for the Flex code.


      Here's what I've done:

      I installed BlazeDS and tested http://localhost:8400 - That worked.

      I setup Tomcat in Eclipse.  -  That seemed to work.

      I created a Dynamic Web Project in Eclipse - That seemed to work.

      I created the bare-bones BlazeDS Configuration under the Eclipse project and then created a basic HelloWorld java class.


      I added the destination in the “remoting-config.xml” file found in the c:/projects/workspace/ReportGenTool/WebContent/WEB-INF/flex” directory:

      <destination id="HelloWorld">   <properties>  <source>HelloWorld</source> </properties> </destination>


      When I started the application server by clicking on the server's green play button in Eclipse and then tried to open localhost:8400/ReportGenTool, I got the 404 error : The requested source (/ReportGenTool/) is not available which according to the instructions is fine.


      Next I created a Flex Project, but when I try to validate the new Flex project configuration, it gives me an error "Cannot access the web server. The server may not be running, or the web root folder or root URL may be invalid."

      When I validated the server was running after setting up the BlazeDs Turnkey, I saw the BlazeDS page.


      Now when I bring up http://localhost:8400 I get:
            Directory Listing for /
            Apache Tomcat/6.0.14

      My eclipse project is named ReportGenTool and I've overwritten the WebContent directory with the META-INF and WEB-INF directories from the BlazeDS installation (C:\blazeds\tomcat\webapps\blazeds).  According to Eclipse the server is running.

      My Flex project is named ReportGenTool and is located in another directory away from the Eclipse project directory.

           My root folder is: C:\Projects\workspace\ReportGenTool\WebContent
           Root URL: is http://localhost:8400/ReportGenTool/
           Context root is: /ReportGenTool/


      Any idea what might be wrong? What didn't I configure that needs to be configured?

      Thanks in advance.