8 Replies Latest reply on May 14, 2009 6:21 AM by Muzak

    FlexBuilder and Flashplayer10

    taneojala

      Hello,

       

      I've been struggling for hours to get everything working with FB and flash10. I have found several instructions from the internet some of which I used with limited success. Does anybody have steps that have recently been applied successfully?

       

      Some of the problems I've encountered in my trials:

      - debugger didn't work in the new configuration

      - some of imported web services (Import WSDL) mysteriously stopped working when run under FP10 (in both Firefox and IE)

      - in Firefox I was only able to have one flashplayer installed at a time (this might be intentional?)

       

      Currently I am in a situation where I can use FP10 features (like FileReference/load()), and compile it in FB, but can't run that feature in Firefox (because of old FP9 version). In IE I can run it, but web services don't work...

       

      So, if you know what needs to be done.... Thanks!

       

      Tane

        • 1. Re: FlexBuilder and Flashplayer10
          Michael Borbor Level 4

          Did you download the debug FP10 debug version for firefox? The WS 

          probably stop working due to new security restrictions.

           

          Do you have the sdk version 3.3?

           

          Sincerely,

           

          Michael

           

          El 17/04/2009, a las 8:39, taneojala <forums@adobe.com> escribió:

           

          >

          Hello,

          >

          I've been struggling for hours to get everything working with FB and 

          flash10. I have found several instructions from the internet some of 

          which I used with limited success. Does anybody have steps that have 

          recently been applied successfully?

          >

          Some of the problems I've encountered in my trials:

          - debugger didn't work in the new configuration

          - some of imported web services (Import WSDL) mysteriously stopped 

          working when run under FP10 (in both Firefox and IE)

          - in Firefox I was only able to have one flashplayer installed at a 

          time (this might be intentional?)

          >

          Currently I am in a situation where I can use FP10 features (like 

          FileReference/load()), and compile it in FB, but can't run that 

          feature in Firefox (because of old FP9 version). In IE I can run it, 

          but web services don't work...

          >

          So, if you know what needs to be done.... Thanks!

          >

          Tane

          >

          • 2. Re: FlexBuilder and Flashplayer10
            taneojala Level 1

            Hello,

             

            Yes, I downloaded the debug version for FP10 (and before that the normal version). Now I have debug version 9r115 which works like before, but only if I don't try to use FP10 new features.

             

            I also had sdk3.3 in FlexBuilder, but removed it when things weren't working. Now it looks like after FB installation: 3.2 sdk is the default, and the other is a hotfix for 2.0. I am able to write code and compile it, but not run it completely (either web service is not working or FP10 features are not working) and not debug new features.

             

            What are the new security restrictions you mentioned?

             

            Thanks,

            Tane

            • 3. Re: FlexBuilder and Flashplayer10
              Michael Borbor Level 4

              If you want to use fp10 the way to go would be to uninstall all fp 

              older versions and then install fp10

               

              Sincerely,

               

              Michael

               

              El 17/04/2009, a las 9:30, taneojala <forums@adobe.com> escribió:

               

              >

              Hello,

              >

              Yes, I downloaded the debug version for FP10 (and before that the 

              normal version). Now I have debug version 9r115 which works like 

              before, but only if I don't try to use FP10 new features.

              >

              I also had sdk3.3 in FlexBuilder, but removed it when things weren't 

              working. Now it looks like after FB installation: 3.2 sdk is the 

              default, and the other is a hotfix for 2.0. I am able to write code 

              and compile it, but not run it completely (either web service is not 

              working or FP10 features are not working) and not debug new features.

              >

              What are the new security restrictions you mentioned?

              >

              Thanks,

              Tane

              >

              • 4. Re: FlexBuilder and Flashplayer10
                taneojala Level 1

                Hi,

                 

                Ok, I tried that and ended up with a webservice not working (but FP10 features working AND another webservice working ok).

                 

                So what are the new security restrictions you mentioned? I am using crossdomain.xml already and enabled policy file logging without much new information. The web service call just seems to wait for response indefinitely when I use FP10. When replaced by FP9 it works normally.

                 

                Thanks,

                Tane

                • 6. Re: FlexBuilder and Flashplayer10
                  taneojala Level 1

                  Hello,

                   

                  I'm getting back to this issue which was never solved because I couldn't find the solution in the security changes of FP10. There is some new information about this situation that's really giving me headache.

                   

                  So, after I upgrade to Flash10.0.r22 from 9r159 some of my web services do not return the output to my Flex app.

                  - web services are called, but the handler never starts executing

                  - web services are implemented in PHP

                  - web service action scripts are regenerated (Imported) from a WSDL file in FlexBuilder after the upgrade

                   

                  And here's the weirdest part

                  - the code works as such with version 9

                  - web services that receive an XML string as input and return the modified XML as output will not launch the flex app handler. In this case the XML modifications are made in PHP using DOM.

                  - web services that receive a dummy string as input and return database content as XML back to flex are working normally. The data is fetched from an Oracle DB with SQLXML

                   

                  I have understood that FlexBuilder (3.0.2.214193) should be Flash10 compliant. I didn't do any reconfiguring in it. I'm using Flex compiler 3.2 with FlexBuilder.

                   

                  Any ideas?

                   

                  Tane

                  • 7. Re: FlexBuilder and Flashplayer10
                    taneojala Level 1

                    Ok, I was almost there....

                     

                    Now the problem seems to be that the XML string given as input (for example <a>text</a>) shows in PHP as &lt;a>text&lt;/a> thus affecting further processing with DOM. If I fix the string in PHP before anything else, then everything works.

                     

                    I don't know whether this is a bug in FP10 or somewhere else (FP?), but definitely something has changed.

                     

                    Closing the issue....

                    • 8. Re: FlexBuilder and Flashplayer10
                      Muzak Level 3
                      I don't know whether this is a bug in FP10 or somewhere else (FP?), but definitely something has changed.

                      t's a known bug I'm afraid.

                      http://bugs.adobe.com/jira/browse/SDK-19811