21 Replies Latest reply: Feb 12, 2011 8:43 AM by mowzer1945 RSS

    Can't open ACSM file

      Hi,  I can't open my ACSM files anymore.  I've been using DE 1.7 for a while and had no problems till one ebook came up as an "Error to Licensing...".  I tried to reinstall DE again but it wouldn't work from the "Install" prompt, so I went and followed the directions for the manual installation, with the "digitaleditions1x5" file deleted manually as well.  Now DE is reinstalled but it won't open any ACSM file at all.  I'm so lost.  I've been searching the forums forever but doesn't seem to be anything that addresses this specifically.  Can anyone help?  Thanks so much in advance.

        • 1. Re: Can't open ACSM file
          Jim Lester Community Member

          We've been tracking a hard to reproduce bug with failed tasks gumming up the works.  With Digital Editions closed, in your Digital Editions folder ( in your Document directory on the Mac, in your My Documents directory on Windows), rename the restore folder to something like restore.bad.  Then Start ADE and try to use an .acsm file to fulfill a book.

           

          If it works, you are good to go (and let me know if it worked).

           

           

          --

          Jim Lester

          Adobe Systems

          • 2. Re: Can't open ACSM file
            Community Member

            Hi Jim,

             

            Thanks so much for getting back to me.  I did as you suggested but now I get

            these prompts:

             

            Error getting license

            Server communication problem: E_ADEPT_INTERNAL

             

            and

             

            Error getting license

            Server communication problem: E_ADEPT_URN_UUID_SYNTAX

             

            Do you have any more suggestions?

            Thanks again!

            • 3. Re: Can't open ACSM file
              Jim Lester Community Member

              Those error indicates problem with the ACS4 server themselves, so you are going to need to contact the vendor in question to report the problem to them.  They unlike Adobe will be able to issue you new links or fix the problems on their server.

              • 4. Re: Can't open ACSM file
                Community Member

                Thanks very much for your help!

                • 5. Re: Can't open ACSM file
                  rav9891

                  Hi,

                   

                  Some of our customers are experiencing the same issue. How did you go about resolving the issue?

                   

                  I had contacted Content Server Support team and was told this was a known ADE issue. Is there anything that can be done at the ACS4 server side to mitigate this issue?

                   

                  Thanks in advance.

                  • 6. Re: Can't open ACSM file
                    Community Member

                    Hi,I found out that if you change your computer clock back to its original

                    time, it opens the files.  I'm not sure if that helps you but good luck!

                    • 7. Re: Can't open ACSM file
                      MESnyder

                      I'VE BEEN TRYING TO OPEN E BOOKS WITH ADOBE DIGITAL EDITIONS ON MY VISTA COMPUTER.  I GET SO FAR AND THEN GET A MESSAGE THAT "ADOBE DIGITAL EDITIONS HAS STOPPED WORKING".

                       

                      I'VE TRIED TO FIND A SOLUTION TO THIS PROBLEM BUT CAN'T.

                       

                      PLEASE HELP!

                       

                      MARY SNYDER

                      • 8. Re: Can't open ACSM file
                        bugsbunny8 Community Member

                        when i open the ascm file it comes up with Error getting license, Server communication probelm:E_ADEPT_10 .. i dont know what that means ..so does anyone have any ideas

                        • 9. Re: Can't open ACSM file
                          valleystar88

                          Hello Jim,

                           

                           

                          After searching online for 3 days, this has actually worked in letting me finally download my acsm files into adobe digital editions.

                          Thanks so much!

                           

                          Meagan

                          • 10. Re: Can't open ACSM file
                            Lulu_K111

                            To make it work follow the links of this page http://www.adobe.com/products/digitaleditions/ works with Explorer not google browser.

                            • 11. Re: Can't open ACSM file
                              rachunt1

                              I had a similar problem, and tried the rename restore file that you suggested, and it worked to be able to re-load all but 2 of my ,acsm books. I keep getting the following error on just those 2 books:Document is not licensed for this device type.

                              Any advice would be greatly appreciated.

                              Thanks - RACH

                              • 12. Re: Can't open ACSM file
                                CindyBramm

                                I have ADE but when I click on the download from the library, it wants to open in Adobe Reader and I get the message that the acsm file is unsupported.  I dont' see any restore files to rename since this is the first time that I'm attempting to read a book.

                                 

                                When I save it to try to transfer to ADE, it doesn't recognize the ascm file.  Any ideas?

                                • 13. Re: Can't open ACSM file
                                  Tom Franklin

                                  I'm troubleshooting this same problem on a MacBook Pro, running 10.6.4.

                                   

                                  The user has downloaded several free ebooks from the University of Chicago Press without any problems.  This past week he attempted to do this again.  The downloaded file opened ADE but failed to load the ebook into ADE.

                                   

                                  I've attempted this same process/same book on my G5 and had no problems.

                                   

                                  Next I tried this with several of the free ebooks listed on the Adobe site (http://www.adobe.com/products/digitaleditions/library/) and discovered the same problem with the files listed there.

                                   

                                  I renamed the Restore folder and restarted ADE.  I, too, received the Server communication problem:E_ADEPT_10 error message.  When I renamed the Restore folder back to its original name, the server communication error went away but, as before, no files upload into ADE.

                                   

                                  If, as you say, "Those error indicates problem with the ACS4 server themselves, so you are going to need to contact the vendor in question to report the problem to them" then the error exists with Adobe's servers and needs to be addressed by Adobe.

                                   

                                  Please look into this for us.   This is obviously affecting a goodly number of people who all need your assistance.

                                   

                                  Thanks,

                                   

                                   

                                  Tom

                                  • 14. Re: Can't open ACSM file
                                    Dink10

                                    I too struggled to open my ACSM files even though Adobe Digital Editions had worked for about 4 months without a hitch. Suddenly, for some reason, it would not open these files. I took the advice given here, to rename the restore file to "restore.bad" and it now works. The restore file is buried in the "Documents" folder in Vista and can readily be found by using the "search" function. Thanks Jim Lester

                                    • 15. Re: Can't open ACSM file
                                      (Its just me)

                                      I recently purchased an ebook, but when I try to open the acsm file, I get the following error message:

                                       

                                      Error getting license

                                      Server communication pfoblem

                                      E_ADEPT_URN_UUID_SYNTAX

                                       

                                      I contacted the vendor of the book.  They assured me that the problem lay with Adobe and I should contact Adobe.  Is this the case, or are they just being slack?  I would greatly appreciate any advice on this matter.

                                      • 16. Re: Can't open ACSM file
                                        Dink10 Community Member

                                        I had a similar problem and the instructions from the website are less than clear. In order to open the ACSM file, you need first to download the Adobe Digital Editions software (either from the website you originally downloaded the book from or some other source) then locate the ACSM file in your computer, right click on it and then choose "Open with Adobe Digital Editions". This should open the file and then you can drag and drop it into your electronic device which should appear in the ADE window.

                                         

                                        Hope that helps.

                                        • 17. Re: Can't open ACSM file
                                          (Its just me) Community Member

                                          To open my acsm file, I have been doing just as Dink10 suggests:  after having installed ADE, I right-click on the acsm file and then select open with ADE.  ADE starts and a short while later, I get a little window with the E_ADEPT_URN_UUID_SYNTAX error in it.  I have tried re-installing ADE and re-downlaoading the acsm file.  I have also tried renaming the restore folder as described above.  None of these things helps.  I can download and read the free books from Adobe without any problems.

                                          • 18. Re: Can't open ACSM file
                                            kvread122

                                            I need assistance too.

                                            I downloaded ADE and then went to my public library and downloaded an ebook.  The ACSM file comes over on a download but when I double click on it, drag it or try to open with ADE it does not do it.  I get no error message.  I will see the process of a file transferring very quickly (just seconds) but then no book opens in the ADE application.  The sample ADE book from the Adobe website do open in ADE.  I am working on a Mac OS X v10.6.6.  Does anyone have a suggestion how to correct this?

                                            • 19. Re: Can't open ACSM file
                                              kvread122 Community Member

                                              I finally got someone from Overdrive support (the ebook company) to help me.

                                              He had me reboot my computer and then the ADE worked.

                                              Something as simple as that and no one from technical support suggested it.

                                              • 20. Re: Can't open ACSM file
                                                (Its just me) Community Member

                                                I contacted the supplier of the e-book once again.  This time they were more helpful, and a lady looked into my problem more closely.  She found that there were some files missing from their server.  They have since removed this book from their selection and given me a refund.

                                                • 21. Re: Can't open ACSM file
                                                  mowzer1945 Community Member

                                                  Obviously many who have posted here have problems related to some very specific software issues, but I solved a procedural difficulty I used to have with acsm files which I think might be useful to those having problems after opening "saved" acsm files.

                                                   

                                                  I was taught always to "save" rather than "open" files I downloaded, so that is what I did with acsm files when I first got my eReader. Then I would open ADE and go to the acsm file and open it. The book would download OK to the ADE bookshelf and appear in My Digital Editions folder, and it would sometimes copy OK to my eReader. However, often I could not copy the book across and I would get an error message or a "no permission to transfer here" warning. I usually got around that problem by deleting the book from the bookshelf in ADE and forcibly dragging it across from My Digital Editions folder in Windows Explorer so that it copied back onto the ADE bookshelf - a very frustrating and stressful procedure as I'd just paid for a book which apparently was only readable on my PC.

                                                  Finally, after very carefully re-reading the instructions which came with my BeBook Neo eReader, I tried a different procedure:-

                                                   

                                                  I pay for my book and open up ADE in the background (though the instructions say it will automatically open at download, it doesn't on my PC), then I go to the bookseller's download page. I choose to "open" the acsm file rather than "save" it. At this point the ADE screen moves into the foreground on the desktop, and I can see as the acsm file is instantaneously downloaded and the download progression bar for the book itself starts to operate.  I have not had any problems with copying DRM books across to my eReader since I started this procedure, though I always hold my breath until I've succeeded. I have never found a cache of downloaded acsm. files anywhere on the PC, so I presume they self delete, or hide themselves deep in the System files somewhere.

                                                   

                                                  Hopefully this information might help one or two who have posted in this topic.