5 Replies Latest reply: Nov 12, 2009 12:36 PM by signcarver RSS

    A sharing violation occurred accessing???

    VladL.

      How to rectify an error? When I wish to save a css-file in DW - I have error A sharing violation occurred accessing

        • 1. Re: A sharing violation occurred accessing???
          VladL. Community Member

          Superb!

          Q: "This was driving me out of my mind, as well. I too was getting the dreaded "sharing violation" error. Turns out, the solution is pretty simple. Go into the CF Administrator. Under Server Settings, go into the Caching section. At the top of the page, you can enter the "Maximum number of cached templates." Enter zero, and submit changes. That worked for me!!!"

          • 2. Re: A sharing violation occurred accessing???
            VladL. Community Member

            Again does not work. Writes A sharing violation occurred accessing

            Help me please. It is impossible to edit CSS!

            • 3. Re: A sharing violation occurred accessing???

              I think I have the answer as I had the problem after i installed coldfusion 8. Each time you preview your html file in dreamweaver, keep open your CF administrator on the Server Settings - Caching page and select Clear Template Cache Now after each preview. It seems a temp file is stored each time you view html. If all the files are saved as .cfm then there seems to be less of an issue

               

              Lo

              • 4. Re: A sharing violation occurred accessing???
                Daverms Community Member

                Hi,

                 

                Also, if you are using DreamWeaver as your IDE, Try clearing the cache by deleting the files that are located at,

                 

                C:\Documents and Settings\your-profile-name-here\Application Data\Macromedia\Dreamweaver 8\Configuration\SiteCache\

                 

                That will solve your issue.

                 

                HTH

                • 5. Re: A sharing violation occurred accessing???
                  signcarver Community Member

                  I have tried most of the solutions below and they don't work for me (at least not every time).

                   

                  One solution i have found that is foolproof but is a pain is to keep the Coldfusion Administrator open in your browser and then logout twice. You can then save your file.

                   

                  I know, i know...  it sounds like "swing a rubber chicken over your head..." but it works every time.

                   

                  By the way, this problem occurs with html files as well as css files.

                   

                  Also, i have noticed that there does seem to be a timeout in Coldfusion (somewhere) that eventually lets the save work even if you don't log out. I can't find where that timeout value is though (it isn't the "Timeout Requests" setting as i have tried that to no avail).

                   

                  Edited to say:

                  I'm becoming more convinced that changing almost any setting in the Coldfusion Administrator will "fix" the problem (clear cache, log out, reduce the number of cached pages, etc.).

                   

                  Edited once more to say:

                  Has anyone confirmed if this is a problem in Coldfusion 9?

                   

                  Edited last time (?) to say:

                  I just installed Coldfusion 9 with its default settings and the access violation seems to be solved. I have tried numerous scenarios, including modifying a css and html file simultaneously. Should i find any scenarios that don't work, i'll post here.